Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Apr 2014, 16:58
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Mega Mario 1.5
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
dejan555


Joined: 30 Nov 2008
Posts: 2591
Location: Montenegro

PostPosted: Wed 25 Feb 2009, 17:21    Post subject:  Mega Mario 1.5
Subject description: Super Mario game clone
 

Quote:
Mega Mario is a Super Mario Bros. 1 clone.
It features everything the original features - with better graphics, higher resolution,
smoother movement and new levels.
The story of mario and Luigi continues in old-school style.

http://www.megamario.de/

This is repackaged from fedora's i386 rpm, requires SDL

Download here 2.14 MB




Download here 2.14 MB

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
SpideyLinux69


Joined: 26 Jan 2009
Posts: 16
Location: Beaumont, Texas USA

PostPosted: Fri 27 Feb 2009, 11:59    Post subject:  

Looks nice from the screen shots. I loaded the SDL and game, but it
freezes at the menu screen shortly after starting.

Running 4.1.2 new kernel, on Foxy 2.0
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2591
Location: Montenegro

PostPosted: Fri 27 Feb 2009, 13:22    Post subject:  

I've installed it on two of my 4.1 full installs and works fine on both. Try adding xorg dri package? Does it output any error when started from terminal?
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
dejan555


Joined: 30 Nov 2008
Posts: 2591
Location: Montenegro

PostPosted: Fri 27 Feb 2009, 13:29    Post subject:  

It would be great if someone with compiling knowledge could build it for puppy.
I know how to type ./configuree && make && make install, but when I compile any SDL-required game, it outputs an error of not finding SDL or sdl-config even if I have SDL installed (not sure about that sdl-config).

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
SpideyLinux69


Joined: 26 Jan 2009
Posts: 16
Location: Beaumont, Texas USA

PostPosted: Fri 27 Feb 2009, 20:48    Post subject:  

Loaded the Pet with XORG DRI. XORG then refused to work with my NVIDIA driver. I backed up and reloaded.

Okay. I went to another computer that is running the base 4.1.2 distro (new Kernel) and it froze at the same place. I don't know what could have changed with 4.1. Maybe I'll make a 4.1 live CD and see if it will work.
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2591
Location: Montenegro

PostPosted: Sun 01 Mar 2009, 07:17    Post subject:  

Just to point out that Mega Mario works with 1.2.9 SDL version, so the package from the main post should work, that's this pet:
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-2/libsdl-1.2.9.pet
^Right Click -> Save Link Target As...

@SpideyLinux
Do you have propietary drivers installed on that other machine too? I don't think that puppy version does anything to do with that, it sounds like it's something to do with your drivers...

I've tested it on Live CD, with only SDL package installed. Anyone else experiencing these problems?

md5sum of the package should be:
6d2457f177f3cb06be143cd3bfa8a3c1 megamario-1.5.pet

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
SpideyLinux69


Joined: 26 Jan 2009
Posts: 16
Location: Beaumont, Texas USA

PostPosted: Sun 01 Mar 2009, 19:27    Post subject:  

Thank you for your trouble. Only one of my machines is using proprietary drivers. I even loaded the 1.2.9 SDL package on top of my existing SDL load (I suppose I could have tried loading the 1.2.9 package only?) The machines in question both run SuperTux which requires OPEN GL / DRI / SDL as well.

<update> I was able to run it on one machine. There are additional SDL packages needed. SDL_mixer, SDL_ttf, SDL_image.

If anyone else is looking, I found them in the Puppy's Games post.

SDL Image 1.2.6
http://www.puppylinux.ca/tpp/ttuuxxx/programs/SDL-Programs/SDL_image-1.2.6-i386.pet

SDL ttf 2.0 fonts
http://www.puppylinux.ca/tpp/ttuuxxx/programs/SDL-Programs/SDL_ttf-2.0.9-i386.pet

SDL Net 1.2.7
http://www.puppylinux.ca/tpp/ttuuxxx/programs/SDL-Programs/SDL_net-1.2.7-i386.pet

Links were originally posted by ttuuxxx.
Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2591
Location: Montenegro

PostPosted: Mon 02 Mar 2009, 02:36    Post subject:  

Thanks, this may be usefull for others, but I don't get this, why do someone need additional SDL libraries and I don't on the same system and same game? Confused
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
SpideyLinux69


Joined: 26 Jan 2009
Posts: 16
Location: Beaumont, Texas USA

PostPosted: Mon 02 Mar 2009, 22:33    Post subject:  

I can only guess that the other SDL packages may have been on your system from another program or puplet (if you are using one) I verified that the original system will run it after loading the other three SDL packages.

Thank you again.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0479s ][ Queries: 12 (0.0049s) ][ GZIP on ]