Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 08:19
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 4.2 "Deep Thought" - Bugs & Fixes
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 20 [293 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11, ..., 18, 19, 20 Next
Author Message
trio


Joined: 21 Dec 2008
Posts: 1883
Location: अनुमोदना

PostPosted: Wed 01 Apr 2009, 22:18    Post subject:  

mouldy wrote:
Not sure what the idea with the calendar with black numbers on dark part of desktop screen. On my old lcd screen with my old eyes, I CANNOT see the numbers. I had to create a png background that is bright yellow in order to see the white days and the little black numbers. Can the calendar widget be easily modified some way from some menu or config file so I can determine what colors of numbers should be?


Hi,

go to menu -- desktop -- pwidgets -- plugins -- theme
choose which color theme suits best for your eyes Laughing

another one is the Today widget, which will show only today's date (off course) with BIGGER numbers, should suit your eyes better

Cheers

_________________
My apps
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1883
Location: अनुमोदना

PostPosted: Wed 01 Apr 2009, 22:23    Post subject:  

jayargent wrote:
I just want to say that I also have multiple 4.2 frugal installations on the same partition. What might not be generally known is there is code and a new parameter, psubok=TRUE, in Init (Thanks to Crash) that works with psubdir to really zero in on the subdirectory that contains the puppy files. This is documented in these two threads.:


http://murga-linux.com/puppy/viewtopic.php?t=38030

and

http://www.murga-linux.com/puppy/viewtopic.php?t=36703

I use these parameters plus PDEV1= which specifies the partition and really cuts down on the search time. Here is part of my menu.lst file:

Code:
title Puppy 4.20
fallback 6
rootnoverify (hd0,4)
kernel /Puppy420/vmlinuz pmedia=idehd pdev1=sda5 psubok=TRUE psubdir=/Puppy420
initrd /Puppy420/initrd.gz



Hope this helps.....

Jay


Hey, Thanks!
Is 4.2 capable of this? Did I miss something (I don't know this)? This should be a great feature and should be stated somewhere easily noticeable for users to see

_________________
My apps
Back to top
View user's profile Send private message 
Grenville Grimace

Joined: 27 Mar 2009
Posts: 8

PostPosted: Wed 01 Apr 2009, 22:35    Post subject:  

Gxine gives a fatal error - segmentation fault when it's launched.
SeaMonkey exits if you try to download a file with 'Save it to disk'.

(Edit) Sorry, please ignore.
Looks like my SD card install was corrupted.
A quick format and clean new install fixed everything.

Last edited by Grenville Grimace on Fri 03 Apr 2009, 10:28; edited 1 time in total
Back to top
View user's profile Send private message 
jayargent

Joined: 01 Feb 2009
Posts: 11

PostPosted: Wed 01 Apr 2009, 22:51    Post subject:  

@Trio Yes, that code is included for the first time in the 4.2 Init. and I agree it should probably be documented more prominently.
Back to top
View user's profile Send private message 
vanchutr

Joined: 05 Aug 2006
Posts: 427

PostPosted: Thu 02 Apr 2009, 02:52    Post subject:  

@himagin
Thank you very much
Follow to your post, I'd made SCIM run in Puppy 420Final
Back to top
View user's profile Send private message 
mawebb88

Joined: 13 Jul 2008
Posts: 245
Location: France nr Lyon

PostPosted: Thu 02 Apr 2009, 03:04    Post subject: Re: Lost Blinky  

trio wrote:
mawebb88 wrote:
I have lost Blnky! I stupidly made the mistake of on the right click options hiding both of my interfaces and now I would like to get the WiFi one back but can't figure out how to as Blinky has gone as one would expect. I searched for a configuration file eg. /root/.blinky but this lists (CSV) both interfaces but could not find where the hide option is stored?

Rgds Mike


Well, you should get blinky back after reboot


No joy after many re-boots still no Blinky using JWM. Any other suggestions? BTW I have already installed the official jwmtrayfix patch.

Thanks
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1883
Location: अनुमोदना

PostPosted: Thu 02 Apr 2009, 03:12    Post subject: Re: Lost Blinky  

mawebb88 wrote:
trio wrote:
mawebb88 wrote:
I have lost Blnky! I stupidly made the mistake of on the right click options hiding both of my interfaces and now I would like to get the WiFi one back but can't figure out how to as Blinky has gone as one would expect. I searched for a configuration file eg. /root/.blinky but this lists (CSV) both interfaces but could not find where the hide option is stored?

Rgds Mike


Well, you should get blinky back after reboot


No joy after many re-boots still no Blinky using JWM. Any other suggestions? BTW I have already installed the official jwmtrayfix patch.

Thanks


install again from the official site jwmtray_patch_update and reboot. If problem still persists pls report again

_________________
My apps
Back to top
View user's profile Send private message 
oztules

Joined: 01 Apr 2009
Posts: 2

PostPosted: Thu 02 Apr 2009, 04:57    Post subject: hangs on shutdown from the first install.  

Ok,
The problem may be more deeply rooted than thought. It seems that the pcmcia card actually gets powered off (lights go out), and then the shutdown program hangs.

Once again, if we force shutdown, It won't boot, and stalls with a #prompt. xwin gets puppy going, but no pcmcia modem (ttyUSB0).

Dmesg shown that it is not there. Removing and replacing the card does nothing. Dmesg does not see it.....In this state shut down can be properly effected.

Once shut down, it boots properly, with the card registered and running properly.

Pprocess seems to indicate that pccardd runs the show, as when I monitor the running process, I can see pccardd come to the top of the processes for a few seconds when I remove and replace the card.

However, if I remove the card it still shuts down normally, and as it seems to turn off the lights on the card, I guess it may be involved with something else.

What I have found, is if I let it hang and force shutdown, it starts next time to prompt and xwin to puppy... but these lines are missing in the process screen
SW<[pccardd]
SW<[ksuspend_usbd]
SW<[khubd]
SW<[kmapmd]
S syslogd-m0
S klogd
SW<[pccardd]

I am having difficulty trying to work out how the rc shutdown script works... mostly geared to saving the puppy file, struggling to see how it shuts down services...

Frustrating grizzle.........
It is disappointing that the startup and shut down is so fragile when not using it as a cd install/play thing. It is ready for serious desktop/laptop work, but hard to see how it can, if it is so easily stopped from booting up any time there is a poor shutdown. Maybe time to reconsider this puppy file business, and use that only for cd installations where it's frailties can't corrupt the cd files, and use a different reliable / robust system for the HD install.

It would seem that puppy is only as good as it's last shutdown....very sad indeed.

whimper whimper
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7082
Location: Perth, Western Australia

PostPosted: Thu 02 Apr 2009, 05:15    Post subject:  

This is a message to all the developer guys who contributed packages to 4.2.

Please read my recent blog posts, at puppylinux.com/blog

I will be uploading a "fixed" Unleashed core tarball later tonight, with a modified 'packages.txt' file. My request is that developers examine the entry(s) in that file for the package(s) that they contributed, and fill in all the fields, maybe post them somewhere
-- perhaps a new thread is needed for this.

The problem with the packages.txt file in 4.2 is that many of the package entries are missing everything except the package name, so when they list in the package manager, no information is displayed about them.

It would be good if filling in packages.txt could be a project for 4.2.1.
packages.txt.gz
Description 
gz

 Download 
Filename  packages.txt.gz 
Filesize  18.32 KB 
Downloaded  280 Time(s) 

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 1883
Location: अनुमोदना

PostPosted: Thu 02 Apr 2009, 06:33    Post subject:  

Whodo

Just a thought, now that .xinitrc doesn't contain fixPuppyPin (commented out), maybe you can put the trash & lock icons on the left screen side with the rest of the icons as default (4.2.1)?

_________________
My apps
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Thu 02 Apr 2009, 07:12    Post subject:  

trio wrote:
Just a thought, now that .xinitrc doesn't contain fixPuppyPin (commented out), maybe you can put the trash & lock icons on the left screen side with the rest of the icons as default (4.2.1)?

May be ... Wink

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Thu 02 Apr 2009, 07:42    Post subject:  

trio wrote:

Hi,

go to menu -- desktop -- pwidgets -- plugins -- theme
choose which color theme suits best for your eyes Laughing

another one is the Today widget, which will show only today's date (off course) with BIGGER numbers, should suit your eyes better

Cheers


Thanks, I also found how to access the configuration file for calendar so could change actual color of the letters and numbers displayed.



As to my dialup problems, seems I've narrowed it down. Nothing to do with wvdial or pupdial frontend. Problem is in the ch341 module. Module is installed and lets me dial out but but somehow doesnt let the modem communicate with the isp modem. The isp modem just knows it received a call but nobody talking.

So ch341 module is faulty as this cable works fine in Puppy 4.00 with the 2.6.25 kernel with supposedly same module.

As to shutdown, who knows, I booted from cd again and this time it shutdown flawlessly though I prefer it to directly shut down, not having the two step microsoft "are you really, really, really sure" procedure.

One weird thing, seems random whether icons show or not when booting from cd. I get error message that pinboard not found when it doesnt show icons. Oddly not having icons doesnt bother me that much.
Back to top
View user's profile Send private message 
mawebb88

Joined: 13 Jul 2008
Posts: 245
Location: France nr Lyon

PostPosted: Thu 02 Apr 2009, 08:13    Post subject: Re: Lost Blinky  

trio wrote:
mawebb88 wrote:
trio wrote:
mawebb88 wrote:
I have lost Blnky! I stupidly made the mistake of on the right click options hiding both of my interfaces and now I would like to get the WiFi one back but can't figure out how to as Blinky has gone as one would expect. I searched for a configuration file eg. /root/.blinky but this lists (CSV) both interfaces but could not find where the hide option is stored?

Rgds Mike


Well, you should get blinky back after reboot


No joy after many re-boots still no Blinky using JWM. Any other suggestions? BTW I have already installed the official jwmtrayfix patch.

Thanks


install again from the official site jwmtray_patch_update and reboot. If problem still persists pls report again


Downloaded again jwmtraypatch_update.pet from:

http://www.murga-linux.com/puppy/viewtopic.php?t=40537

Re-installed it. Re-booted. Still no joy with Blinky returning although the other tray items are now corrected compared with 4.2 out of the box where some were cut in half.(see screen shot of latest situation)

Thnx
no-blinky.png
 Description   
 Filesize   43.09 KB
 Viewed   979 Time(s)

no-blinky.png

Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Thu 02 Apr 2009, 08:16    Post subject:  

jayargent, trio

I think psubdir is the key parameter that allows multiple puplets in different subdirectories. Without that then Puppy just finds the first pup_420.sfs which sounds like what happened to trio. The psubdir parameter has been working since 3.0.1.

The psubok parameter makes puppy search directly for the psubdir directory. Previously he searched everywhere on the device and then filtered the results to only consider the files in the psubdir directory. This could be a lengthy process and psubok is a brilliant improvement - thanks Crash. Thanks for the reminder jayargent.

beem

I wish I understood why you have to copy your files to /mnt/home and why its different in 4.2. I don't do any copying in 4.2. Surely /mnt/home does not exist until Puppy is up and running so how can you copy an sfs file there before boot??

All

Documentation is always a problem in the Linux world. We need some stuff on the new features. The boot code documentation has not been updated for ages and now needs to include the new parameters.

Something on Pwidgets would be nice too. I managed to disable the left tray and spent quite some time trying to find out how to bring it back again - OK, I wiped my pupsave file and started again the first time!
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1883
Location: अनुमोदना

PostPosted: Thu 02 Apr 2009, 09:17    Post subject:  

Laughing mawebb88

aaah, the patch is actually working correctly, the problem is your blinky config! you did say you "managed" to make it disappear by using the options right? just find /root/.blinky and delete it! reboot and please report back the success story... Laughing

_________________
My apps
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 9 of 20 [293 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11, ..., 18, 19, 20 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1176s ][ Queries: 13 (0.0191s) ][ GZIP on ]