Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 14:41
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pCD 1.5 - CD-audio player
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 11, 12, 13 Next
Author Message
vovchik


Joined: 23 Oct 2006
Posts: 1287
Location: Ukraine

PostPosted: Sat 02 May 2009, 04:53    Post_subject:  

Dear Sigmund,

My problem hs been solved - and everything works. I recompiled libcddb from Slackware sources and everything is now OK, including my bash. It turns out that my version of libcddb was bad, failed to recognize /dev/cdrom generated a null string when executed, which then caused your logic test to fail. Nothing wrong from your side. Mea culpa!

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5814
Location: Valåmoen, Norway

PostPosted: Sat 02 May 2009, 05:05    Post_subject:  

Glad to hear !!!
_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
trio


Joined: 21 Dec 2008
Posts: 1951
Location: अनुमोदना

PostPosted: Sat 02 May 2009, 08:05    Post_subject:  

Sad Crying or Very sad
_________________
My apps
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5814
Location: Valåmoen, Norway

PostPosted: Sun 03 May 2009, 05:00    Post_subject:  

Dearest little Trio
Why this crying sadness ?

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Sylvander

Joined: 15 Dec 2008
Posts: 3555
Location: West Lothian, Scotland, UK

PostPosted: Sun 03 May 2009, 05:23    Post_subject:  

1. "Has anyone had trouble with this player in Puppy 4 ?"
I'm running it from BoxPup 4.1.3 installed to an ext2 Linux partition on my internal HDD.
It displays all tracks on a commercial audio CD, but will only play the 1st track.
It does this if I have the program running with no disk in the drawer ["No CD found"], and then if I put a disk in and close the drawer, the 1st window still shows no disk found, but a 2nd window opens showing the 1st track info and it plays.
If I then stop that playing, and close that 2nd window, the 1st window still doesn't display any tracks.
So I click "Read disk" and the tracks are displayed.
Then I can highlight any of the listed tracks OK, but when the play button is clicked, all that happens is a dotted square appears inside the edge of the button, but the track doesn't play.

2. I really like the simplicity of this player, so I'd like to get it to work. Very Happy
Back to top
View user's profile Send_private_message 
trio


Joined: 21 Dec 2008
Posts: 1951
Location: अनुमोदना

PostPosted: Sun 03 May 2009, 05:29    Post_subject:  

Dear teacher

Because you don't address my problem

_________________
My apps
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5814
Location: Valåmoen, Norway

PostPosted: Sun 03 May 2009, 06:17    Post_subject:  

Sylvander
I don't know boxpup, so it's hard to tell whats wrong. I would check if boxpup uses crdtools or cdrkit. This can be determined by execute 'which icedax' in terminal. Icedax is part of the cdrkit package, and is the one used in the official Puppy. Could you start pcd from terminal and post the output here.

trio
Sorry about your slow system Smile
It sounds like a hardware issue.
Vovchic used the 'interface' switch for scsi in /usr/local/pcd/func (-play)

cdda2wav -Igeneric_scsi -D/dev/cdrom -t $CDDA -Owav - | aplay &

the other interface option is

cdda2wav -Icooked_ioctl -D/dev/cdrom -t $CDDA -Owav - | aplay &
Please try


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sun 03 May 2009, 07:29    Post_subject:  

Ahh K,

Hmmm,

Using spup here, but so far all 412 apps work ok. Failure here but it tried, Screeny shows, I may be able to figure it out myself.

Applause, Sigmund. I see where you are going with this Wink

Mick
pcd.jpg
 Description   
 Filesize   32.57 KB
 Viewed   1379 Time(s)

pcd.jpg


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sun 03 May 2009, 08:44    Post_subject:  

Confused I can't figure out why (maybe only for me Question ) the circled file in my screeny appears in '/usr/local/pcd'. Should it be in '~/.pcd/tmp' ?
why.jpg
 Description   
 Filesize   21.02 KB
 Viewed   1406 Time(s)

why.jpg


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5814
Location: Valåmoen, Norway

PostPosted: Sun 03 May 2009, 08:53    Post_subject:  

Mick
Have you selected track before pressing play? I see there is no default track-setting.

What do you get if you run from terminal: 'cddb_query read' ?


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sun 03 May 2009, 09:02    Post_subject:  

From this screeny you can clearly see that I did select a track, that cdda is working in the term but not making it to the gui Confused And I get an error with aplay...."playback: 2148: read error"
pcderr.jpg
 Description   
 Filesize   47.2 KB
 Viewed   1382 Time(s)

pcderr.jpg


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Sylvander

Joined: 15 Dec 2008
Posts: 3555
Location: West Lothian, Scotland, UK

PostPosted: Sun 03 May 2009, 10:28    Post_subject:  

1. zigbert
(a) The terminal in BoxPup 4.1.3 is named sakura.
# which icedax
Produces the output:
/usr/bin/icedax

(b)
# pcd
Produces the output:
EXIT="Ready"
And the pcd - CD-audio player appears.
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5814
Location: Valåmoen, Norway

PostPosted: Sun 03 May 2009, 11:12    Post_subject:  

Mick
I still need the requested output. The CD-text info on your screeny is produced by cdda2wav, and not cddb_query as expected.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5814
Location: Valåmoen, Norway

PostPosted: Sun 03 May 2009, 11:17    Post_subject:  

Sylvander
Icedax is there - good

When I asked for the pcd output, I meant all output produced until the first song is playing. pcd will return much output (and errors) to the terminal, which is good when we searches bugs.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Sylvander

Joined: 15 Dec 2008
Posts: 3555
Location: West Lothian, Scotland, UK

PostPosted: Sun 03 May 2009, 16:49    Post_subject:  

zigbert
Repeated the pcd command, but this time I put a commercially produced CD in the drawer and closed it.
The 2nd player window opened, and the 1st track began playing, but...
There was no additional output in the sakura terminal.
Right-clicked the icon in the system tray and clicked "Stop", with no change.
Clicked the eject button in the 1st window and still no additional output in the terminal.
.
captured.jpg
 Description   
 Filesize   6.63 KB
 Viewed   1323 Time(s)

captured.jpg

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 13 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 11, 12, 13 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0738s ][ Queries: 13 (0.0061s) ][ GZIP on ]