Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 16:49
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
My Puppy Unleashed fails to load X. (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
tempestuous

Joined: 10 Jun 2005
Posts: 5262
Location: Australia

PostPosted: Sun 12 Jun 2005, 09:34    Post subject:  My Puppy Unleashed fails to load X. (Solved)  

I just tried Puppy Unleashed 1.0.3. My main purpose was to make a version of Puppy with Xfbdev instead of Xvesa.
The whole process seemed to go well, but when I booted the finished CD it got as far as starting X, then fell back to the command line. I ran xwin, failed again.
I then tried to make Puppy Unleashed with xf86_svga. Same problem again.
Then I tried to make Puppy Unleashed with Xvesa - the latest cvs version in pupget_packages. Same problem again, X won't launch.
Have I missed a step somewhere?
Craig
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 12 Jun 2005, 22:14    Post subject:  

which kernel are you using?
Back to top
View user's profile Send private message Visit poster's website 
tempestuous

Joined: 10 Jun 2005
Posts: 5262
Location: Australia

PostPosted: Mon 13 Jun 2005, 01:40    Post subject:  

Barry,
I just accepted the default 2.4.27 kernel.
And in the meantime, I've spent a few hours troubleshooting this problem. Typical with Linux - lots of investigation, trial and error required.
There are some critical files missing from the final CD -
/usr/X11R6/bin/xinit
/usr/X11R6/lib/libXmuu.so.1 (& maybe some other Xfree86 libs)

I copied these files over from DamnSmallLinux (into /packages/xfbdev-v1) and now it ALMOST works.
I briefly see the desktop as X loads, before it terminates and falls back to the command line.
It appears from the xwin (startx) script that X is launched like this -
/usr/X11R6/bin/xinit /root/.xinitrc
... so I ran this command manually. Same again - brief appearance of the desktop before disappearing. But now I see some error messages. I didn't write them down, but they related to missing fonts and wrong locale.
I don't have the expertise to troubleshoot this further.
Craig
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5262
Location: Australia

PostPosted: Thu 23 Jun 2005, 04:21    Post subject:  

I have kept working on my Puppy-Unleashed problem, and my discoveries are very timely now I see another post on this subject -
My final CD was missing many files from -
/usr/X11R6/bin/
/usr/X11R6/lib/
/usr/lib/
/usr/lib/qt/
These missing files are definitely absent from the (uncompressed) package folders, so I suppose for the recompile process to succeed these files would normally need to be copied into the rootfs-complete folder from the currently running Puppy operating system.
Clearly, this didn't happen for me, so I achieved success eventually by manually copying the missing files into the package folders, before running the "createpuppy" script. Now I have a remastered Puppy with XF86_SVGA X server and Opera.

I chose the option to have 1 large image.gz file, which worked fine. I'm hoping this single file will help, too, when I boot it from hard drive, since with previous attempts I was restricted to using certain partitions on my hard drive when usr_cramfs could not be found.

After boot, I check the /tmp/xerrs.txt file and the only error message is -
"Gdk-WARNING **: locale not supported by Xlib, locale set to C"
- this doesn't seem to be a problem.
Craig
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 23 Jun 2005, 05:09    Post subject:  

All the files needed to build Puppy are in the puppy-unleashed/packages directory, or should be, if you downloaded all the packages from ibiblio.org.
Back to top
View user's profile Send private message Visit poster's website 
papaschtroumpf


Joined: 17 Jun 2005
Posts: 250

PostPosted: Thu 23 Jun 2005, 05:21    Post subject:  

xinit is in the XFree-4.3.0 packages for example
qt is in package at-3.3.4

_________________
Mandriva LE 2005 user and puppy newbie
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5262
Location: Australia

PostPosted: Fri 24 Jun 2005, 22:42    Post subject:  

Thanks guys. I only copied packages I wanted, and THOUGHT I needed, into the Puppy-Unleashed folder, whereas I should have copied them all, then used the selection gui to deselect packages. And the main one I needed was xfree-4.3.0.
Now I know what to do, Puppy-Unleashed works great.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0601s ][ Queries: 12 (0.0040s) ][ GZIP on ]