Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 06:30
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
ultratiny html viewer - PuppyBrowser 0.5 + embeddedbookmarks
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 9 [123 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 7, 8, 9 Next
Author Message
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sun 10 May 2009, 04:05    Post subject:  

Dear Mark,

Wonderful work. I installed it in 4.12 on my Samsung NC10 netbook - after finding the libgee pet - and it works very well. It's great for browsing documentation, like your earlier html-viewer, only better.

Thanks.

With kind regards,
vovchik

PS. I share Lobster's enthusiasm.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 10 May 2009, 07:34    Post subject:  

Wow, just when I put together a internal HTML-viewer PET for Woof alpha7, you are already miles ahead (or I should say "kilometres ahead"!)

Well, perhaps I'llleave it as-is for alpha7, because if I attempt to update it, I'll look on the forum the next day and see you have done heaps more to improve it.

I'm planing the next Woof release after alpha7 will be 'beta1', then I'll update it.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 May 2009, 08:22    Post subject:  

Lobster, is there no icon in the menu?
Then I must change the "category" entry in /usr/share/applications/PuppyBrowser.desktop to a different one. I just had tested the menu-entry in lxde.
*edit: in Puppy 4.2 it works, just takes a moment to appear.

Vovchik,
yes, libgee is needed for the bookmarks.
It can be installed with PetGet.
I could replace the lists with fixed arrays, but must check, if it would have other advantages.
Libgee lists have an unlimited length, while arrays are fixed, so they would need some tricks to allow a non-limited amount of bookmarks. But it would be possible, so we had one dependency less.

Barry,
in the next 2 weeks I finish my C# course, and must work on my final project (C#2vala), so there will be not much time for the browser.
So it will remain like it is I think until then.

There is one issue, that is a showstopper:
if you click on links, that should open a new window, nothing happens.

E.g. the links on dotpups.de use "target=_blank", and do not work.
I have not found out yet, how to solve it, and if someone knows a solution, I would add it quickly.
A workaround is, to drag those links in the URL-entry, and click on the "ok" button.

Apart from that, it basically works as I like, I just would like to add support for tabbed browsing later, and mabe a very simple config dialog.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 May 2009, 09:51    Post subject:  

The pet included old sourcecode without active pwget button (but the binary was the current).
I updated the pet with the current source, and added some comments in it, to make it easier readable.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 10 May 2009, 12:09    Post subject:  

Quote:
Lobster, is there no icon in the menu?


Yes there is, just booted up (restart x might have done it too) Cool

- just did a JWM refresh which is sufficient in 4.2
(or there is a button to refresh menu - got confused with that . . .

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
sullysat


Joined: 16 Oct 2007
Posts: 364
Location: San Antonio, TX

PostPosted: Sun 10 May 2009, 13:07    Post subject:  

Mark,

This looks great but I need libgee and I don't see it in the petget list. I'm probably missing something simple and have no idea how to use petget from terminal.

Help?
Sully
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 May 2009, 14:01    Post subject:  

I added libgee to the message where you could download the browser.
http://www.murga-linux.com/puppy/viewtopic.php?p=303882#303882
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
sullysat


Joined: 16 Oct 2007
Posts: 364
Location: San Antonio, TX

PostPosted: Sun 10 May 2009, 14:04    Post subject:  

Awesome! Thanks Mark!

Sully
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 May 2009, 14:08    Post subject:  

I attach a pet for interested developers.

This NOT for endusers, as I just started to add tabs, they do not work at all as expected!

I has a new button, that opens a new tabpage with the current URL.
But when I click on the new tabs, a wrong index is returned (printed to console).

If someone can solve it, please let me know.
You must compile it on your own in ValaIde.

The corresponding code is around line 300:
Code:
    def new_tab()
        mozcount ++ 
        moz[mozcount] = new MozEmbed () 
        var a = note.append_page(moz[mozcount] , null)
        print("--%d" ,a)
        moz[mozcount].show()
        load(current_uri)
 


    def note_page_changed()
   
        var index = note.get_current_page()
   
        print("%d" ,index)


This NOT for endusers, as I just started to add tabs, they do not work at all as expected!
Mark
PuppyBrowser-broken-tabs.tar.gz
Description 
gz

 Download 
Filename  PuppyBrowser-broken-tabs.tar.gz 
Filesize  44.42 KB 
Downloaded  838 Time(s) 

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 May 2009, 14:22    Post subject:  

Lobster wrote:
Mark, you must be dependent on some libraries from Seamonkey?
Would it be viable to use this in Puppy - allowing users to download a bigger browser if required? Preferences for Opera, Seamonkey, Firefox, Konqueror, Flock, Dillo etc would no longer be an issue . . .


It can be used with Seamonkey 1.x, or Xulrunner 1.8.x.
PuppyBrowser does not replace Seamonkey, it is just a reduced grafical Interface written in pure Gtk. This should explain the faster start, as the Seamonkey interface is very complex to allow extensions and such, while PuppyBrowser just wants to offer the basic requirements to browse websites.
But it requires a full gecko installation (= Seamonkey or Xulrunner).

Xulrunner is a "seamonkey for developers", without own browser-interface, but supplying the Gecko engine and all the required stuff to write own applications based on Gecko.
Among the utilities is gtkmozembed.so, the library, that has wrappers in Vala/Genie.

As it is no longer supported in Seamonkey2 or Xulrunner 1.9, we need a new library for those newer browsers, or must install Xulrunner in an own folder in next versions of Puppy.
I have no idea, what kind of new library will follow for the new browsers.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Sun 10 May 2009, 16:04    Post subject:  

Hello Mark

I've been experimenting with trying to get the browser to run in fat_ free dillo on my 486 and realise it must actually need seamonkey, because I got all the dependant libs but still get an error, "TLS data" in regard to one of the libs. Giving up on that one

Next step is to remaster a 4.1.2 of puppy adding the puppybrowser and doing a full install to the 486. Methinks that should work. Seamonkey has next to no chance of running on that box due to ram constraints.

Thanks again

Mick

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 May 2009, 16:39    Post subject:  

Micko,
it also should run with this one:

http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.8.0.4/linux-i686/en-US/xulrunner-1.8.0.4.en-US.linux-i686.tar.gz

Extract it somewhere, you get a folder "xulrunner".

You should symlink it, e.g.:
Code:
ln -s /mnt/sda2/xulrunner /usr/lib/


I think you also need to type in a console:

Code:
export PATH=/usr/lib/xulrunner:$PATH

export LD_LIBRARY_PATH=/usr/lib/xulrunner:$LD_LIBRARY_PATH

export MOZILLA_FIVE_HOME=/usr/lib/xulrunner

/usr/local/PuppyBrowser/puppy-browser


I am not certain, that it is enough, though.
If it works, you could add the commands to a startscript or to "puppy-browser".

Maybe several files could be deleted, as we need no "xul", but only gecko.
I have not investigated yet, how far it can be strupped down, I want to try it, once I added tabs to the browser.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
trapster


Joined: 28 Nov 2005
Posts: 1999
Location: Maine, USA

PostPosted: Sun 10 May 2009, 17:41    Post subject:  

Very Impressive MU!
Using it for this message. Very snappy so far!

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 May 2009, 18:33    Post subject:  

uploaded Puppybrowser 0.2.
http://www.murga-linux.com/puppy/viewtopic.php?p=303882#303882

Changes:
- fixed bug, that pages for "new windows" did not load.
They now open in the same window.

- added a statusbar, so you can see where a link points to, when you move the mouse over it.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
sullysat


Joined: 16 Oct 2007
Posts: 364
Location: San Antonio, TX

PostPosted: Sun 10 May 2009, 19:10    Post subject:  

Okay, the system says the browser is installed and a dependency check says all is good now that I've got libgee installed. I even have the item in the menu, but it does not run.

The first time I try to run the browser when I boot the system I get some activity on the HDD for a few seconds, but nothing else happens.

I'm running 4.0 in a full install.

Sully
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 9 [123 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0878s ][ Queries: 13 (0.0055s) ][ GZIP on ]