Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Sep 2014, 09:55
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x » Bugs (4.x dev)
[SOLVED] CUPS Testing - 4.2.1 RC2
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9110
Location: Stratford, Ontario

PostPosted: Sun 10 May 2009, 15:11    Post subject:  [SOLVED] CUPS Testing - 4.2.1 RC2  

CUPS 1.3.10 looks basically sound. Here are some specifics.

1. The hpijs-2.8.2_static_1.pet (a previously downloaded copy) still needs the -U patch on /usr/lib/cups/filter/foomatic-rip-hplip. After that, it works.

2. The hpijs-3.9.4-dynppds.pet with dynamic HPIJS PPDs from here works as is.

3. Printers like the HP 720C that use the pnm2ppa filter need a modification. The file pnm2ppa must be moved from /usr/local/bin to /usr/bin. (Thank you to Wosh for identifying the problem.) This is because the new version of foomatic-rip in Puppy 4.2 uses a different search path.

4. Printers like the HP 1020 that use the foo2zjs filter work as is.

5. Based on limited testing, HPLIP devices can be made to work using the method described here.

6. Printers like the Xerox Phaser that use the splix package also work.

7. Both printers discussed here install correctly.

Last edited by rcrsn51 on Sun 10 May 2009, 20:32; edited 4 times in total
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 10 May 2009, 15:31    Post subject:  

the The hpijs-2.8.2_static_1.pet is now listed as 'patched' in the Puppy 4 repo, but there is a fault and it does not install in 4.2.1. The download begins, then drops out with a failure to install message
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9110
Location: Stratford, Ontario

PostPosted: Sun 10 May 2009, 15:42    Post subject:  

Because of a bug in the cups_shell script, all Gutenprint models are duplicated in the printer list. In /usr/sbin/cups_shell, the line
Code:
cups-genppd.5.2

can be commented out.

Read the discussion about dynamic PPDs here.

This change also eliminates the confusing pause that occurs after the purple information screen when running the CUPS Wizard.

Last edited by rcrsn51 on Sun 10 May 2009, 16:05; edited 2 times in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9110
Location: Stratford, Ontario

PostPosted: Sun 10 May 2009, 15:50    Post subject:  

The menu item System > CUPS Web Interface launches the default browser - Seamonkey.

But Setup > CUPS Printer Wizard starts in bareview, which has no navigation buttons.
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 10 May 2009, 15:55    Post subject:  

Loading the hpijs-3.9.4-dynppds.pet as you suggested fixed printing in 4.2.1 and makes the old hpjis-static package redundant. Other than installing the .pet, nothing else was required.
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9110
Location: Stratford, Ontario

PostPosted: Sun 10 May 2009, 16:29    Post subject:  

The folder /usr/lib/cups/backend is missing the smb symlink needed to connect to a Windows shared printer via Samba.
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 11 May 2009, 03:57    Post subject:  

rcrsn51 wrote:
The folder /usr/lib/cups/backend is missing the smb symlink needed to connect to a Windows shared printer via Samba.

Corrected for next release. Regressed CUPS-1.3.10-i486 package was missing a couple of links.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 11 May 2009, 04:00    Post subject:  

rcrsn51 wrote:
The menu item System > CUPS Web Interface launches the default browser - Seamonkey.

But Setup > CUPS Printer Wizard starts in bareview, which has no navigation buttons.

Mine has "Back", "Forward" and "Stop" buttons in the grey bar at the top left of the window.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 11 May 2009, 04:06    Post subject:  

rcrsn51 wrote:
Because of a bug in the cups_shell script, all Gutenprint models are duplicated in the printer list. In /usr/sbin/cups_shell, the line
Code:
cups-genppd.5.2

can be commented out.

Read the discussion about dynamic PPDs here.

This change also eliminates the confusing pause that occurs after the purple information screen when running the CUPS Wizard.

Odd, because the version of CUPS supplied in 4.2.1 doesn't appear to have cups_shell in that directory. Never mind ... found it in 0rootfs_skeleton-4.2.1 for some reason. Fixed for next release.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 11 May 2009, 04:10    Post subject: Re: CUPS Testing - 4.2.1 RC2  

rcrsn51 wrote:
CUPS 1.3.10 looks basically sound. Here are some specifics.

1. The hpijs-2.8.2_static_1.pet (a previously downloaded copy) still needs the -U patch on /usr/lib/cups/filter/foomatic-rip-hplip. After that, it works.

Already patched after 4.2.1RC1 but haven't uploaded the patched .pet file yet pending other fixes.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 11 May 2009, 04:39    Post subject: Re: CUPS Testing - 4.2.1 RC2  

WhoDo wrote:
rcrsn51 wrote:
CUPS 1.3.10 looks basically sound. Here are some specifics.

1. The hpijs-2.8.2_static_1.pet (a previously downloaded copy) still needs the -U patch on /usr/lib/cups/filter/foomatic-rip-hplip. After that, it works.

Already patched after 4.2.1RC1 but haven't uploaded the patched .pet file yet pending other fixes.

WhoDo............. for some strange reason the Hpjis patched pet in the official 4 repo refuses to install.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 11 May 2009, 05:59    Post subject: Re: CUPS Testing - 4.2.1 RC2  

DaveS wrote:
WhoDo............. for some strange reason the Hpjis patched pet in the official 4 repo refuses to install.

Seems ok using the copy I have here. Maybe the version uploaded was corrupted in the process. It will be re-uploaded shortly.
install-ok.png
 Description   
 Filesize   15.33 KB
 Viewed   1532 Time(s)

install-ok.png


_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Mon 11 May 2009, 06:08    Post subject:  

Ok, will try it. I have been able to download other .pets so my system seems basically ok this end.
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Wed 13 May 2009, 08:40    Post subject:  

WhoDo wrote:
rcrsn51 wrote:
The menu item System > CUPS Web Interface launches the default browser - Seamonkey.

But Setup > CUPS Printer Wizard starts in bareview, which has no navigation buttons.

Mine has "Back", "Forward" and "Stop" buttons in the grey bar at the top left of the window.


I get the same result as rsrsn51. No buttons in bare view. Ok in full Seamonkey fro system>cups web interface

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Wed 13 May 2009, 08:43    Post subject: Re: CUPS Testing - 4.2.1 RC2  

WhoDo wrote:
DaveS wrote:
WhoDo............. for some strange reason the Hpjis patched pet in the official 4 repo refuses to install.

Seems ok using the copy I have here. Maybe the version uploaded was corrupted in the process. It will be re-uploaded shortly.


Now installs perfectly thanks. Printing proving solid and fast so far in this version, even with my wifi connected HP PS4380, which can be a devil at times.

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x » Bugs (4.x dev)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1046s ][ Queries: 13 (0.0282s) ][ GZIP on ]