Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 09:41
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to set up an HP 5510 printer? (solved)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Sat 09 May 2009, 18:11    Post_subject:  How to set up an HP 5510 printer? (solved)  

I am trying out Puppy Linux 4.2 -v2. The only problem I have encountered so far is that I cannot get a printer setup to print, specifically my HP 5510. Cups sees it but I cannot print to it.

I have installed the hpijs-2.8.2_static-1 pkg.

I am running puppy on a dell machine with 2GB ram, 2Mhz processor.

thx in advance for your help.

Edited_time_total
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Sat 09 May 2009, 18:19    Post_subject:  

Go to the folder /usr/lib/cups/filter
Locate the file foomatic-rip-hplip and open it in a text editor
Change the top line to #!/usr/bin/perl -U
Run CUPS again
Back to top
View user's profile Send_private_message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Sat 09 May 2009, 20:46    Post_subject:  

Thanks. I have done that but alas, still the problem.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Sat 09 May 2009, 23:07    Post_subject:  

Go to the CUPS web interface and print a test page. What error message is displayed?
Back to top
View user's profile Send_private_message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Sun 10 May 2009, 10:11    Post_subject: HP 5510  

Cups shows the print job completed but the following error is displayed:
"/usr/lib/cups/filter/foomatic-rip-hplip failed".

thx
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Sun 10 May 2009, 16:22    Post_subject:  

Did you use an upper-case U in the patch above?
Back to top
View user's profile Send_private_message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Mon 11 May 2009, 17:46    Post_subject:  

Yes.
Back to top
View user's profile Send_private_message 
wah fun

Joined: 19 Apr 2009
Posts: 22

PostPosted: Mon 11 May 2009, 19:30    Post_subject: (Solved)  

Hey all. I just downloaded and install CUPS 1.3.10 with HPIJS Drivers per rcrsn51's instructions and everything works great with my HP 5510.

Thx rcrsn51!
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 12 May 2009, 08:21    Post_subject:  

Glad to help. When Puppy 4.2.1Final comes out, it will have CUPS 1.3.10 included. So you will just need to install the hpijs-3.9.4-dynppds.pet to get your printer working.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0509s ][ Queries: 12 (0.0091s) ][ GZIP on ]