Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 08:55
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
(possibly SOLVED) no recording using Audacity 1.3.4
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
charlie6


Joined: 30 Jun 2008
Posts: 1006
Location: South of Belgium

PostPosted: Fri 15 May 2009, 00:40    Post subject:  (possibly SOLVED) no recording using Audacity 1.3.4
Subject description: live recording with Audacity: how to get the audio card recognized?
 

Hi,
------------------------------------------------
UPDATED 15.5.2009:
I believe I got it working!
1. start audacity / verify there is no message telling 'no input device'; otherwise shutdown all audio applications, shutdown and restart audacity.
2. select 'Phone out' (somewhere in the center of the menu bar - options "Line, Mic,...Phone Out...");
3. start the audio application to be listened at and eventually recorded (for instance a radio broadcasting on web);
4. on audacity:
4.1 select (menu edit/preferences/ i/o ) wheter stereo or mono;
4.2 push the red dotted button (start record) and hopefully the sound wave is displayed.
4.3 press the squared button to stop; afterwards save as...etc. The record can be "shaped" using the audacity functions.

note: while recording activate some other functions can cause shutdown of audacity..!!! so may be preferable not touch anything then.

I believe I learned that alsa has nothing to do with audacity setup.
I also perform some recording using 'arecord' (just wonder how to set the gain record level).
If whatever audio application is running, /dev/dsp could be simply buzy for it and therefore no longer available for another one.
END UPDATE 15.5.2009
---------------------------------------------------
(post transferred here from 'additionnal software forum' and updated - I do not know how to erase it - sorry).
my rig: toutoulinux4.1.2 frugal (french translation of Puppy4.1.2)
+ audacity 1.3.4beta from dotpup (all files and dependencies well installed)

I apologize if this post could seem a bit trivial and simplistic.

I 'd (just...!) like to record sounds just from the pc built-in-soundcard
Sounds files (.mp3, .wma, .midi, etc..files) get well played using gxine or Pmusic)
I ran Alsa configuration and got setup on the intel card. (I did not try setup on legacy or other).

Here is the code returned when doing aplay -l in a terminal: (I found this browsing on the murgalinux forum looking at posts about souncard).
Code:
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
#

I just understand it gives chracteristics of the built in soundcard of my PC.

Running then Audacity and pressing the red button (record) keep the blue straight line constantly quiet (= there is nothing recorded).

When starting audacity, in the edit/preferences/ i/o there is a /dev/dsp device already displayed. I do not know which device is /dev/dsp. There is not any other optional device there to select.

After using alsamixer (and having closed it) and restarting audacity, audacity tells at start 'there is no input device) and further (edit/preferences/ i/o) both 'input' and 'recording' device are blank.

I wonder how to setup for getting sounds from the in built sound card.
Hereunder is a screenshot of alsa detected soundcards

for possible usefull info, here are some found links for Audacity
eb
(audacity1.3.4.sfs) http://www.murga-linux.com/puppy/viewtopic.php?t=29634&sid=13be4cfdc97b39fc1c4b7d16548972
(audacity 1.3.5) http://www.murga-linux.com/puppy/viewtopic.php?t=25372
http://www.murga-linux.com/puppy/viewtopic.php?t=2213&start=15

Many thanks for any answer
Cheers
Charlie
alsa_ist.png
 Description   
 Filesize   6.96 KB
 Viewed   687 Time(s)

alsa_ist.png

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0459s ][ Queries: 13 (0.0042s) ][ GZIP on ]