Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 15 Oct 2018, 17:00
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Trouble installing SCIM m17n in Puppy 3.01
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 38 of 41 [610 Posts]   Goto page: Previous 1, 2, 3, ..., 36, 37, 38, 39, 40, 41 Next
Author Message
Irihapeti
Guest


PostPosted: Sat 06 Jun 2009, 23:56    Post subject:  

Puppyiso:
What happens when you open Geany or OpenOffice or Leafpad and press ctrl-space? If scim is working properly, the input method panel should appear.

Scim has two configuration files: /etc/gtk-2.0/gtk.immodules and /root/.xinitrc (You'll need to show hidden files to see the last one.) Do you have both of these on your system. If they are in different places, that would be one reason for things not working.

It could be worth trying a standard version of Puppy first, and getting scim to work on that. The font file and the four scim packages should be all that you need.

Actually, I've just remembered that gconv4dingo was needed for some forms of Japanese input in Puppy 4. You could try installing that, if you are using a version based on Puppy 4. It's on puppylinux.asia, in the same place as the other files.
Back to top
puppyiso


Joined: 12 Jan 2009
Posts: 595

PostPosted: Sun 07 Jun 2009, 09:43    Post subject:  

As you can see in the attached image, the files do exist.

I cannot find the keyboard icon nor the selection icon in Gnome window.

Tried ctrl+space bar, shift+space bar nothing works.

It is too bad that I have to leave my computer next 8 days or so.

When I comeback, I will try again with "regular" puppies.

Thank you for your help.

John S
all ingred for scim 1.png
Description 
png

 Download 
Filename  all ingred for scim 1.png 
Filesize  108.16 KB 
Downloaded  466 Time(s) 
Back to top
View user's profile Send private message 
Irihapeti
Guest


PostPosted: Sun 07 Jun 2009, 18:24    Post subject:  

puppyiso wrote:
As you can see in the attached image, the files do exist.

I cannot find the keyboard icon nor the selection icon in Gnome window.

Tried ctrl+space bar, shift+space bar nothing works.

It is too bad that I have to leave my computer next 8 days or so.

When I comeback, I will try again with "regular" puppies.

Thank you for your help.

John S


You're welcome.

Scim can be very frustrating to get working, sometimes. It's not the most user-friendly program to set up, in my experience.

If I have any other ideas of things to try, during the next week or so, I'll post them here.

Irihapeti
Back to top
puppyiso


Joined: 12 Jan 2009
Posts: 595

PostPosted: Wed 17 Jun 2009, 01:52    Post subject:  

I am in different city with someone else's computer given to me to use temporarily. I don't have the files I downloaded from the puppylinux.asia site.

When I revisited the site, I found the site has exceeded its bandwidth limit.

Well, I guess I have to wait till July.

Or if you give me the file names and I will try to find them on the internet. (but of course puppylinux.ca first)

Those got to be somewhere.

John
delay.png
Description 
png

 Download 
Filename  delay.png 
Filesize  78.66 KB 
Downloaded  431 Time(s) 
Back to top
View user's profile Send private message 
Irihapeti
Guest


PostPosted: Wed 17 Jun 2009, 16:38    Post subject:  

Hi Puppyiso

The files you need are now on www.puppylinux.ca/members/Irihapeti and they are:

scim-1.4.7-i486.pet
scim-bridge-0.4.15-i486.pet
libhangul-0.0.9-i486.pet
scim-hangul-0.3.2-i486.pet

It's best not to use .pet packages from other sources, because they are often compiled differently, and that adds yet another possible source of frustration.

I have tested the hangul packages in Puppy 4.2 (with the replacement gtk+ packages) and it's working. I suggest starting with a standard Puppy, get that working, and then add the other features such as Gnome.

Puppylinux.ca still allowed me to download at the time of this post, by the way.
Back to top
puppyiso


Joined: 12 Jan 2009
Posts: 595

PostPosted: Thu 18 Jun 2009, 06:31    Post subject:  

Success!!!!

I missed the bridge file.

Now it works. The next is the menu.

Thank Thank Thank you, Irihapeti

Finally!!!!

John S
Back to top
View user's profile Send private message 
Irihapeti
Guest


PostPosted: Thu 18 Jun 2009, 16:24    Post subject:  

Puppyiso:

That is great news!

All the best with the rest of your project.

Irihapeti
Back to top
puppyiso


Joined: 12 Jan 2009
Posts: 595

PostPosted: Wed 15 Jul 2009, 06:36    Post subject:  

I tried Chinese today but there was NO correct pinying input.

None was correct.

Please check the Chinese input. The screen you see is with Gnome clothes on.

John
wrongchinese.png
Description 
png

 Download 
Filename  wrongchinese.png 
Filesize  177.87 KB 
Downloaded  402 Time(s) 
wrong-chinese-input.png
Description 
png

 Download 
Filename  wrong-chinese-input.png 
Filesize  135.27 KB 
Downloaded  406 Time(s) 
Back to top
View user's profile Send private message 
Irihapeti
Guest


PostPosted: Wed 15 Jul 2009, 08:11    Post subject:  

Puppyiso:

It looks as though you only have Scim-tables installed, which doesn't include pinyin. Scim-m17n (and you'll need the other two m17n packages as well) has some pinyin options.

The other choice is scim-pinyin (智能拼音), which is quite popular. That's just a single package download. When it's installed, it shows up in the scim menu as

Hope that helps.

Irihapeti
Back to top
Irihapeti
Guest


PostPosted: Sun 26 Jul 2009, 18:22    Post subject:  

你们好, 我的朋友 - Hello, friends

I have compiled new versions of Scim, Scim-bridge, Scim-tables and Scim-m17n (plus the lib and db files). They have been uploaded to

http://www.puppylinux.ca/members/Irihapeti/
and
http://www.puppylinux.asia/members/Irihapeti/ (You will need username: puppy, password: linux for this site.)

I can't get the QT3 and QT4 scim-bridge drivers to compile (so what's new?), but the existing QT drivers seem to work fine anyway, even with the later versions of scim and scim-bridge.

Regards
Irihapeti
Back to top
pacchiee


Joined: 30 Sep 2008
Posts: 28
Location: Bengaluru, KA, IN

PostPosted: Sat 01 Aug 2009, 11:55    Post subject:  

Irihapeti,

Good work! Does the newer versions still require libgtk-x11-2.0.so.0.1200.1 to be replaced or have you included it in the package?
Back to top
View user's profile Send private message 
Irihapeti
Guest


PostPosted: Sat 01 Aug 2009, 20:11    Post subject:  

pacchiee wrote:
Irihapeti,

Good work! Does the newer versions still require libgtk-x11-2.0.so.0.1200.1 to be replaced or have you included it in the package?


libgtk-x11-2.0.so.0.1200.1 is only needed for Puppy 4.2; later versions have been fixed. And no, it's not included in the new scim packages.

It's probably better to install the gtk-2.12.1-xinput packages instead. Just gtk-2.12.1-xinput.pet if you aren't going to be doing any compiling, and the other three if you are. The first one contains libgtk-x11-2.0.so.0.1200.1 anyway. (Maybe it's time to remove it from the directory; it was a stopgap sort of solution anyway.)

Hope that clarifies things a bit.
Back to top
levian

Joined: 06 Aug 2009
Posts: 36

PostPosted: Mon 10 Aug 2009, 03:48    Post subject:  

hi Irihapeti,
i was trying to install scim-pinyin into my puppy 4.2.1,
that includes installing

scim-1.4.7-i486.pet
scim-bridge-0.4.15-i486.pet
scim-pinyin-0.5.91-i486.pet

n more tables n files that were found in /members/Irihapeti/ which i eventually got lost. both geany n leafpad doesn't give me any reactions. nor with cltr+space. i even tried reinstalling my puppy to get the scim to work, but it still doesn't. what should i do next? please help.

i am able to read some chinese fonts though.
Back to top
View user's profile Send private message Visit poster's website 
Irihapeti
Guest


PostPosted: Mon 10 Aug 2009, 05:49    Post subject:  

levian:

For some further instructions, look here: http://www.puppylinux.org/wiki/localization/technical-how-tos/setting-puppy-multi-lingual-operation-beginner-friendly-method and
http://www.puppylinux.org/wiki/multi-lingual-puppy/technical-how-tos/getting-scim-working-after-its-installed

You shouldn't need to reinstall Puppy but you do need to restart the x-server, or reboot.

If you want a good display of Chinese characters, install wenquanyi bitmap font. The instructions are here: http://www.puppylinux.org/wiki/multi-lingual-puppy/technical-how-tos/installing-fonts
Back to top
Aitch


Joined: 04 Apr 2007
Posts: 6815
Location: Chatham, Kent, UK

PostPosted: Mon 10 Aug 2009, 07:21    Post subject:  

Hi Irihapeti

How you keeping?

Just a quick reminder, requests have been made to move your/everybody, that is - files from

http://www.puppylinux.org/wiki

to the new site/hosting - I think Confused [pm prit1 for confirmation]

see

http://puppylinux.org/wikka/HomePage

and

http://www.puppylinux.org/news/

Aitch Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 38 of 41 [610 Posts]   Goto page: Previous 1, 2, 3, ..., 36, 37, 38, 39, 40, 41 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1263s ][ Queries: 13 (0.0760s) ][ GZIP on ]