Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 16:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Pstreamvid v 1.3 - Streaming Video Controller
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 9 [126 Posts]   Goto page: 1, 2, 3, ..., 7, 8, 9 Next
Author Message
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 28 Jul 2009, 09:11    Post subject:  Pstreamvid v 1.3 - Streaming Video Controller
Subject description: For 430 and all 4.xx series
 

Streaming Video Controller - powered by Gxine (native puppy app) or Mplayer if available

Laughing Laughing This is maybe an answer to problem with gXine full screen from command line ( -f option) in 430 pre-beta or also any other puppy series 4.xx with old JWM

Patch for 430beta1 - reverting to gxine 0.5.9
Updated to v 1.3 - Major Bugfix - reconstruct many things - fixes jmps of cpu & RAM usage
Updated to v 1.2-5 - seperate kill player for off & quit button - gives a little sleep when quit - prevent jump of cpu usage when quitting
Updated to v 1.2-4 - Same functions, reconstructed conditonal commands - thanks rjbrewer
Updated to v 1.2-3 - basically the same as 1.2-2, but a few "&" at the end of commands, and i changed the way pstreamvid gui quits. Let's see if this one resolves what rjbrewer is experiencing problems with mplayer
Updated to v 1.2-2 - can change channel without having to click "off" (not opening 2 windows), click "quit" also turns off video
Updated to v 1.2-1 - added, flushing RAM on every click of "OFF" button
Updated to v 1.2

changelog:
- auto detect mplayer as default engine (if available)
- Fullscreen off and on function for both gxine and mplayer
- in gxine when fullscreen off, it will play 200% window (max) at top-left of screen
- Refresh fields after adding new channel
- A little changes on GUI to make buttons more understandable
- New working channels

NOTE: Some of the channels only play sound in gXine but play Video in mplayer

ENJOY!
pstreamvid-revertgxine-059-patch.pet
Description  reverting to gxine 0.5.9 (430 Beta1) - will replace /usr/local/pstreamvid/functions
pet

 Download 
Filename  pstreamvid-revertgxine-059-patch.pet 
Filesize  933 Bytes 
Downloaded  1275 Time(s) 
pstreamvid-1.3.jpg
 Description   
 Filesize   19.76 KB
 Viewed   4308 Time(s)

pstreamvid-1.3.jpg

pstreamvid-1.3.pet
Description  run fixmenus + restart window manager (refresh menus) after install
pet

 Download 
Filename  pstreamvid-1.3.pet 
Filesize  3 KB 
Downloaded  1625 Time(s) 

_________________
PET Maker|WbarCC|My Website

Last edited by trio on Sat 15 Aug 2009, 00:32; edited 16 times in total
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3203
Location: Chickasha Oklahoma

PostPosted: Tue 28 Jul 2009, 10:19    Post subject:  

Very Happy Hello,
Trio, you are the man... Very Happy
This is the perfect replacement for PupTv...
User ability to update channels is what it needed..as the channels can be fleeting and need updating often..
Without the MPlayer side, Id recommend upgrading to Gxine 0.5.11 as it streams better than 0.5.9
Great job!!! Very Happy
I hope BK sees it in time for the next Woof...

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...

Last edited by puppyluvr on Wed 29 Jul 2009, 23:17; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Tue 28 Jul 2009, 12:13    Post subject:  

Hi puppyluvr,

Thanks, actually Barry has included this in the pre-beta. I chose gxine only because it's native puppy app. Upgrade of gxine, I think a good idea

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Thu 30 Jul 2009, 04:23    Post subject:  

for more channels, try browsing pupTV thread here:

http://www.murga-linux.com/puppy/viewtopic.php?t=39445&start=30

there's also a streamsniffer by ttuuxxx

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Fri 31 Jul 2009, 08:56    Post subject:  

Hi Bro

In 422 k2.6.29.6 I saw your post on BB about the new gxine not working. I ran pstreamvid from a prompt and it complained about missing libgnomevfs-2.so.0. Just wondering if it is in devX. (uh, we don't have devX yet, I know).

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Fri 31 Jul 2009, 09:14    Post subject:  

01micko wrote:
Hi Bro

In 422 k2.6.29.6 I saw your post on BB about the new gxine not working. I ran pstreamvid from a prompt and it complained about missing libgnomevfs-2.so.0. Just wondering if it is in devX. (uh, we don't have devX yet, I know).

Cheers


Bro,

I don't relate that well with compiling and dependencies! Evil or Very Mad

I'd rather solving bash & gtkdialog puzzle than those things...just reporting & hoping somebody will resolve that issue

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 31 Jul 2009, 10:37    Post subject:  

I configured Gxine 0.5.904 to not need the gnome libs, but it still complains about that missing library at startup. Yet, it doesn't seem to cause any problem.
It's an oversight, the Gxine developers should probably be told about it.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Sat 01 Aug 2009, 03:36    Post subject:  

Hi

Running ppa-422 I downloaded pupTV. It exhibits exactly the same behaviour as Pstreamvid. Gxine is only showing the top left corner when it switches to full screen. Crying or Very sad

(darn that cd probe is annoying! Crying or Very sad Laughing )

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3447
Location: West Lothian, Scotland, UK

PostPosted: Sat 01 Aug 2009, 04:11    Post subject:  

I've installed this in BoxPup 4.1.3, ran fixmenus, and rebooted, but it doesn't show up in the menus, nor is it listed under "p" in a terminal. Sad

Might this be because BoxPup doesn't have either Gxine or MPlayer installed?
Has Xine and Xfmedia.
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Sat 01 Aug 2009, 04:15    Post subject:  

Sylvander,

No gxine, no mplayer, sorry, no pstreamvid

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3447
Location: West Lothian, Scotland, UK

PostPosted: Sat 01 Aug 2009, 05:35    Post subject:  

So should I install Gxine or what?
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Sat 01 Aug 2009, 05:45    Post subject:  

Sylvander,

Better install mplayer (easy, from official repo 4 series in puppy package manager) and install pstreamvid patch for mplayer.

Menu entry should be under multimedia group. If you want to execute the file directly, it,s in /usr/local/pstreamvid/pstreamvid

Thanks

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3447
Location: West Lothian, Scotland, UK

PostPosted: Sat 01 Aug 2009, 10:57    Post subject:  

1. "Better install mplayer (easy, from official repo 4 series in puppy package manager) and install pstreamvid patch for mplayer"
Did that in BoxPup.
[4 mplayer packages installed = player, codecs, fonts, plug-in]
Mplayer appeared in the menus, but wouldn't run.
Pstreamvid didn't appear in the menus or terminal.

2. Within Puppy 4.2.1-rc3, which includes Gxine:
I installed Pstreamvid, but it didn't show in the menus or terminal.
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Sat 01 Aug 2009, 11:14    Post subject:  

Sylvander wrote:
1. "Better install mplayer (easy, from official repo 4 series in puppy package manager) and install pstreamvid patch for mplayer"
Did that in BoxPup.
[4 mplayer packages installed = player, codecs, fonts, plug-in]
Mplayer appeared in the menus, but wouldn't run.
Pstreamvid didn't appear in the menus or terminal.

2. Within Puppy 4.2.1-rc3, which includes Gxine:
I installed Pstreamvid, but it didn't show in the menus or terminal.


1. Doesn't matter if Mplayer can't run from menu - Pstreamvid + mplayer patch will play mplayer with commands
2. Funny about the missing menu entry ...don't have that problem here..what I want you to do is:
a. look for inside /usr/share/applications/pstreamvid.desktop if found click on it
b. If still can't run, go directly to the file /usr/local/pstreamvid/pstreamvid and click on it

Pstreamvid is not executable from terminal - I did that on purpose

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send private message 
tasmod


Joined: 04 Dec 2008
Posts: 1461
Location: North Lincolnshire. UK

PostPosted: Sat 01 Aug 2009, 11:58    Post subject:  

Hi trio,

tried the app in Barrys pps422. Won't work for me, it opens gxine window then changes to a square black screen at top left of my screen.
I have to stop the app to exit.

Shame, looked good.

Hope all's well with you.

_________________
Rob
-
The moment after you press "Post" is the moment you actually see the typso Cool
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 9 [126 Posts]   Goto page: 1, 2, 3, ..., 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0810s ][ Queries: 13 (0.0055s) ][ GZIP on ]