Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 17:12
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Sound from headphone jack but not from speakers
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
pup2learn222

Joined: 22 Aug 2006
Posts: 25

PostPosted: Sun 02 Aug 2009, 13:21    Post subject:  Sound from headphone jack but not from speakers
Subject description: Acer aspire 5516 laptop
 

Hi all
Alsa see's card but no sound out of speakers with 4.2 standard, retro wont boot off cd, machine is a amd athalon 64 frugal install.Card identified as realtek 272 in alsa mixer in menu.

Usb flash drive 3.01 will boot but no sound as well.

Ok after banging head for several days & trying many of what others have tried I can get sound as is but out of only the headphone jack with wireless working.

If I use puppy acpi=ht with a cd boot I get sound from computer speakers but then I loose wireless function.

in modprobe.conf
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=acer <--- put this line in myself no effect though.

Either this is a bug or a missing direction in one of the files,I just don't know....

Thanks for the read & for the help in advance.
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Mon 03 Aug 2009, 08:13    Post subject: Re: acer aspire 5516
Subject description: Sound issue with laptop speakers
 

Hmmm .....

As far as I'm aware of, pup4.2.x is using alsa 1.0.16 modules mixed with alsa 1.0.19 lib/utils (can someone verify this?) ...

Basically, the sound modules are alsa 1.0.16 and can be considered a wee bit outdated for HDA support. Recent alsa versions have improved HDA support (but still not perfect yet, IMHO). If you're able to compile them latest ones, I recommend trying them out. I do have a complete binary set already made but for retro kernel (2.6.21.7).


1. In a terminal, get alsa module version :
Code:
# cat /proc/asound/version


2. Get alsa cards & hda sound codec in use:
Code:
# cat /proc/asound/cards
# cat /proc/asound/card0/codec#0 | grep Codec


3. Get alsa->oss mixer compat layer assignments:
Code:
# cat /proc/asound/card0/oss_mixer


4. Get amixer controls (ie. for hda widget assignments)
Code:
# amixer controls


(Note: If you intend to include all the above info, please upload as attachment.)

Previous alsa version used in puppy doesn't handle alc272 quirks yet. Alc272 is grouped together with alc662/663 in latest alsa and have specific model quirks assignments. No model assignments for alc272 is available in alsa-1.0.16 ...

I'm unable to make an alsa-1.0.20 binary set for k2.6.25.16 right now (probably I can do so this weekend). Maybe someone can beat me to it ?

Rgds
Back to top
View user's profile Send private message 
pup2learn222

Joined: 22 Aug 2006
Posts: 25

PostPosted: Mon 03 Aug 2009, 20:54    Post subject: acer aspire 5516
Subject description: Sound issue with laptop speakers
 

Patriot
here is what all those codes produced see attachment, like you suggested.
acer.png
Description  here is info if you guys would like to view
png

 Download 
Filename  acer.png 
Filesize  29.48 KB 
Downloaded  434 Time(s) 
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 05 Aug 2009, 06:04    Post subject:  

Hmmm .....

Based on the provided output, it does seems to me that alc272 support is not yet included into alsa-1.0.16rc2 (compared to latest alsa-1.0.20) ... The line 'Codec: Realtek ID 272' indicate this issue and I believe it is using a generic hda configuration.

Since you're running standard kernel (k2.6.25.16) then you'll have to wait until this weekend if you want the latest alsa-1.0.20 binary set as I'm having some hectic days right now ...

I have no ALC272, instead I was having some issues with VT1708B hda previously. I've had my alsa binaries (for k2.6.21.7) patched to work specifically for my audio setup.

Rgds
Back to top
View user's profile Send private message 
pup2learn222

Joined: 22 Aug 2006
Posts: 25

PostPosted: Wed 05 Aug 2009, 07:05    Post subject:  

Patriot

Quote:
Since you're running standard kernel (k2.6.25.16) then you'll have to wait until this weekend if you want the latest alsa-1.0.20 binary set as I'm having some hectic days right now ...
Not a problem I can wait . I been doing some research on this alsa thing & found something in ubuntu http://ubuntuforums.org/archive/index.php/t-1073090.html
this has the same kind of issue.
The funny thing is I installed the 9.04 with no problems, the 8.04 wouldn't boot in correctly some kind of error just like 4.2 retro, go figure.

Hey thanks for your help, I am kinda confused how you can work a far on a problem not on your machine. I don't really know much of linux but will learn, so if you'd like to give me code or what I need I can follow directions, "I think" Rolling Eyes
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 05 Aug 2009, 08:01    Post subject:  

Hmmm .....

pup2learn222 wrote:

The funny thing is I installed the 9.04 with no problems, the 8.04 wouldn't boot in correctly some kind of error just like 4.2 retro, go figure.

Ubuntu 9.04 is using k2.6.28 with alsa-1.0.18 while the 8.04 is k2.6.24 with alsa-1.0.15 (In contrast, puppy is k2.6.25 with alsa 1.0.16) ... That would probably explain why 9.04 works fine ...

pup2learn222 wrote:
Hey thanks for your help, I am kinda confused how you can work a far on a problem not on your machine. I don't really know much of linux but will learn, so if you'd like to give me code or what I need I can follow directions, "I think" Rolling Eyes

It all starts with the first step, so take it one step at a time. I've been looking on-and-off at alsa sources for weeks now and still learning to understand HDA internals (when time permits). The thing is, since alsa sources is publicly available, we can take a peek and see the 'magic' inside ...

Come back in a while and I'll post the new alsa binary as soon as possible ...

Rgds
Back to top
View user's profile Send private message 
pup2learn222

Joined: 22 Aug 2006
Posts: 25

PostPosted: Wed 05 Aug 2009, 19:55    Post subject: Sound from headphone jack but not from speakers
Subject description: acer sound
 

Patriot
Ok Thank you for your time & help, I would like to learn the process of the how to do things after all I am in it to learn as well so take your time & get a handle on it.
best regards

BTW in 8.04 I never got to desktop
on the 4.2 retro it didn't go far & either was a kernel thing or it just stalled/locked up I can't remember though, I do know both the disks did work on other machines fine.
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Fri 07 Aug 2009, 15:43    Post subject: Alsa 1.0.20 available ...  

Hmmm .....

I've just made a set of alsa 1.0.20 binaries ... Caution is advised as I have yet to make extensive testing on other audio hardwares. Please note your kernel version before using ...

I suggest that you try them on a small 32MB/64MB save file first. Please follow this link to get them.

Rgds
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0569s ][ Queries: 13 (0.0040s) ][ GZIP on ]