Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 12:30
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Alsa 1.0.20 driver update
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Author Message
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Sun 13 Sep 2009, 21:47    Post_subject:  

Well, that's one variable eliminated.

I will inform the Puppy person who sent me here of that news.

Thanks!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send_private_message Visit_website 
sprangalang


Joined: 09 Sep 2009
Posts: 15

PostPosted: Wed 16 Sep 2009, 16:50    Post_subject:  

Thank you for this post, a lot of information there.

My kernel in the Puppy 4.24 is 2.6.30.5. Can I use one of these libraries to get my sound working? Sound works with Puppy 4.12, I guess the ALSA is different. Or an older version of ALSA? Is it possible to just revert to older ALSA with this kernel?

I'm using an old Micron laptop, a Trek ii. WIth some ESS card that is not covered by ALSA 1.0.20.

Thanks for any comments.
Back to top
View user's profile Send_private_message 
timremy

Joined: 27 Jun 2009
Posts: 238

PostPosted: Wed 16 Sep 2009, 17:44    Post_subject: alsa driver
Sub_title: hda intel
 

hello
tried what you said, no effect.

timremy
Back to top
View user's profile Send_private_message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 16 Sep 2009, 19:32    Post_subject:  

Hmmm .....

sprangalang wrote:
........ I'm using an old Micron laptop, a Trek ii. WIth some ESS card that is not covered by ALSA 1.0.20. .....


I believe you probably have one of those micron trek 2 agp using ess maestro2 ... It's generally not possible to use the alsa driver update here as they are kernel version specific. BTW, kernel 2.6.30.5 is using alsa-1.0.20 ...

There's essentially no major code changes between alsa-1.0.16 and alsa-1.0.20 for the ess maestro2 driver. I only see minor fixes and two added small subroutines for polling and jitter suppression. The init routines are still the same ...

To see if alsa-1.0.20 is indeed the cause of your audio borking up, I suggest trying the alsa-1.0.20 driver update on puppy 4.12 using a small save file ... please check your kernel version if you intend to try this ... If you do have audio after doing alsa-1.0.20 update on 4.12 then there could be something else borking p424 ... if you don't then kindly let me know and I'll see what I can do .....


Rgds
Back to top
View user's profile Send_private_message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 16 Sep 2009, 19:46    Post_subject: Re: alsa driver
Sub_title: hda intel
 

Hmmm .....

timremy wrote:
..... tried what you said, no effect. .....


Ok, kindly open a terminal and do these:

# echo 'VOLUME "PCM" 0' > /proc/asound/card0/oss_mixer

# echo 'PCM "PCM" 0' > /proc/asound/card0/oss_mixer

# lspci > /tmp/vt1708.txt

# cat /proc/asound/card0/codec#0 >> /tmp/vt1708.txt

# cat /proc/asound/card0/oss_mixer >> /tmp/vt1708.txt

# amixer controls >> /tmp/vt1708.txt

then look in /tmp for vt1708.txt, zip it up and post it here for me to look at the configs.


Rgds
Back to top
View user's profile Send_private_message 
sprangalang


Joined: 09 Sep 2009
Posts: 15

PostPosted: Thu 17 Sep 2009, 14:41    Post_subject:  

Hello,
I don't know either, both versions of alsa suggested a 1968 chip, but only the 1.0.16 made it work. Guess I'll stick with p412.
Thanks
Smile
Back to top
View user's profile Send_private_message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Thu 17 Sep 2009, 15:30    Post_subject:  

Hmmm .....

sprangalang wrote:
Hello,
I don't know either, both versions of alsa suggested a 1968 chip, but only the 1.0.16 made it work. Guess I'll stick with p412.
Thanks
Smile


Interesting ...

Yes, that is correct, ess maestro2 uses the ess1968 driver. Did you try the alsa update on p412 with pfix=ram or pup_save? If you wish to try for a patched alsa-1020 with 1016 reverted codes, kindly pm me ...


Rgds
Back to top
View user's profile Send_private_message 
sprangalang


Joined: 09 Sep 2009
Posts: 15

PostPosted: Tue 13 Oct 2009, 10:36    Post_subject:  

Thanks Patriot.
I put in Puppy4.30, and it found it right away, and doesn't forget it either!
Smile
Back to top
View user's profile Send_private_message 
mikesumbler

Joined: 02 Dec 2009
Posts: 1

PostPosted: Wed 02 Dec 2009, 18:48    Post_subject: Absvolume Patch
Sub_title: Install Module????
 

Hi have a del latitude D630 and I can't get sound. Running 431 from USB. Trying to follow method 1 but I haven't the foggyist how to install a module?? Can someone help??
Back to top
View user's profile Send_private_message 
swiatmar


Joined: 09 Aug 2008
Posts: 241
Location: Danube, AT

PostPosted: Sun 10 Jan 2010, 09:27    Post_subject:  

Hello Smile

I've updated my alsa to 1.0.20 and now my alsa mixer is gone.
when I type in terminal alsamixer, I 've got this massage:
Code:
alsamixer: function snd_ctl_open failed for default: No such device


Code:
amixer: Control default open error: No such device


I am using puppy NOP 413. wit 2.6.25.16 kernel. I've updated from 1.0.16

I've run alsa sound wizard- there was no error. but I have no sound and no mixer:(
Back to top
View user's profile Send_private_message Visit_website 
technosaurus


Joined: 18 May 2008
Posts: 4353

PostPosted: Sun 23 May 2010, 21:14    Post_subject:  

if anyone wants them - here is a dot 23 update

only tested on my acer aspire 5630 so far
alsa-utils-1.0.23-i486.pet
Description 
pet

 Download 
Filename  alsa-utils-1.0.23-i486.pet 
Filesize  146.41 KB 
Downloaded  1184 Time(s) 
alsa-lib_DEV-1.0.23-i486.pet
Description 
pet

 Download 
Filename  alsa-lib_DEV-1.0.23-i486.pet 
Filesize  63.03 KB 
Downloaded  827 Time(s) 
alsa-lib-1.0.23-i486.pet
Description 
pet

 Download 
Filename  alsa-lib-1.0.23-i486.pet 
Filesize  283.98 KB 
Downloaded  1068 Time(s) 

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4353

PostPosted: Mon 24 May 2010, 09:50    Post_subject:  

@swiatmar - I renamed the alsamixer to alsamixer.bin and included the script that runs alsamixer in a terminal. That was probably the issue with the other version, since by default the newly compiled package will overwrite the script and leave the previous alsamixer.bin in place. This should have originally been done by leaving alsamixer with its original name and naming the script alsamixer.sh such that future upgrades would not break things.... but we are probably in too deep now so I have stuck with the established naming so-as to not break other unknowns.
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
swiatmar


Joined: 09 Aug 2008
Posts: 241
Location: Danube, AT

PostPosted: Tue 07 Sep 2010, 05:30    Post_subject:  

Thanks Smile
But one more thing.WQhre can I get alsa firmware 1.0.23. I need it for my emu sound card. Is there maybe somewhere a.pet?
Back to top
View user's profile Send_private_message Visit_website 
technosaurus


Joined: 18 May 2008
Posts: 4353

PostPosted: Tue 07 Sep 2010, 17:39    Post_subject:  

no pet but there is a tarball on their site
http://www.alsa-project.org/main/index.php/Main_Page

not sure if it is source or binary blobs though

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
darry1966

Joined: 26 Feb 2012
Posts: 481
Location: New Zealand

PostPosted: Wed 13 Aug 2014, 18:03    Post_subject:  

Alsa Updates 1.0.20 for kernels 2.6.25.16 and retro 2.6.21.7 (Left click on folders as .pets inside catergorised folders eg retro etc).
here: https://sourceforge.net/projects/old412forever/files/ALSA%20Upgrades/

http://murga-linux.com/puppy/viewtopic.php?p=794675#794675

Edited_time_total
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0805s ][ Queries: 13 (0.0047s) ][ GZIP on ]