Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:06
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 4.3 Final -- bug reports and suggestions
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 21 Posts_count   Goto page: 1, 2, 3, ..., 19, 20, 21 Next
Author Message
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 14 Sep 2009, 19:48    Post_subject:  Puppy 4.3 Final -- bug reports and suggestions  

I have started this thread as a placeholder, as I have put a link to it in the 4.3 release notes.

EDIT 20090917: NOW OPEN FOR POSTING!
SEE RELEASE ANNOUNCEMENT FURTHER DOWN


I will be monitoring this thread and will attempt to fix bugs as they come up, as will the other developer guys, and Puppy 4.3.1 will be a bug-fix release.

Note, I will be taking a couple of weeks off starting from 20th September, but will keep working on Puppy at a slower pace. I will probably only have Internet access every few days, so don't expect immediate response from me.

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Thu 17 Sep 2009, 16:55    Post_subject:  

Initial bug reports
http://www.murga-linux.com/puppy/viewtopic.php?p=342085#342085
(that thread is now locked) all further reports and bugs here please

I am using the 2.6.30.5 kernel, configured for SMP (multiprocessor) systems. Seamonkey OK and full screen Flash in BBC Iplayer

Now gonna read help file, which seem extensive
with many links

Happy Smile

_________________
Puppy WIKI

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
dogone


Joined: 21 Apr 2008
Posts: 202
Location: Arizona, USA

PostPosted: Thu 17 Sep 2009, 18:44    Post_subject: 430 standard 2.6.30.5 - significant problems (resolved)
Sub_title: Note: Barry has addressed this problem.
 

Update: pup-430small runs very well. No issues observed.

430 standard 2.6.30.5 appears to be experiencing rather serious problems related to module loading. Results vary from boot-to-boot. I captured /var/log/messages on one occasion in which neither network or audio setup worked - at one point the Connection wizard would not even run. See attached.

Again, the small cut of 430 is running with no apparent problems.

Note: all checksums verified and burns repeated on several media.
430std_var_log_messages.txt.gz
Description  Contents of /var/log/messages following problematic boot of Puppy-430 2.6.30.5 (standard) in which neither network or sound could be configured.
gz

 Download 
Filename  430std_var_log_messages.txt.gz 
Filesize  4.54 KB 
Downloaded  1125 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 17 Sep 2009, 21:09    Post_subject:  

Okay, everything has uploaded. Here is a copy of my blog announcement:

Puppy Linux version 4.3 released

Please note that the files have not yet fully propagated from ibiblio.org to the mirrors. For example, I just now checked 'nluug.nl' and it has an incomplete 'pup-430.iso' file. So, for now only download from ibiblio:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/puppy-4.3/

Announcement and release notes:

http://puppylinux.com/download/release-4.3.htm

There are a selection of live-CD ISO files and support files to choose from. Please read this page before going to the download page:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/puppy-4.3/readme-files.htm

Main download page, has links to ibiblio.org and download mirrors:

http://puppylinux.com/download/index.html

A thread has been created on the Puppy Linux forum for bug reports and suggestions:

http://murga-linux.com/puppy/viewtopic.php?t=46594

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 17 Sep 2009, 21:11    Post_subject:  

Quote:
Note that I will amend this post as I learn more about this.

Booting "the" 430 iso (assembled from parts w/ valid checksum) from CD, all went well - in no way different than 425. My NIC was detected and worked. I then created a pup_save and rebooted. 430 came up without problems BUT did not find my onboard NIC, (a Realtek RLT-8139 per 425). I suspect this may have something to do with the last-minute network mods but cannot substantiate this.

Booting 430 with pfix=ram, I do not see this problem.




please check my solution because this mb also use realtek nic.

http://www.murga-linux.com/puppy/viewtopic.php?t=46504

if it work then it's the card's bug btw not puppy's.

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Fri 18 Sep 2009, 01:19    Post_subject:  

Quote:
430 standard 2.6.30.5 appears to be experiencing rather serious problems related to module loading. Results vary from boot-to-boot.


m m m . . . this morning turned on and the standard 2.6.30.5 in updated and fresh install was not recognizing my internet connection (both had been set up) Even more worrying when I tried to re-connect, it told me no connect was available and wanted to load modules.
Going right back to reboot and 'puppy pfix=ram' and starting a new Puppy install and I was able to start a new connection

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
James C


Joined: 26 Mar 2009
Posts: 5867
Location: Kentucky

PostPosted: Fri 18 Sep 2009, 01:31    Post_subject:  

Did a full install of Puppy 430 (2.6.30.5) to my P3 test box several hours ago and no real problems yet.

Already installed FF 3.5 ( upgraded to 3.5.3) w/ Flash 10 and Ttuuxxx's Alsaplayer/Streamtuner pet.....everything working as expected.

Smile
Back to top
View user's profile Send_private_message 
lwill


Joined: 13 Jun 2008
Posts: 173
Location: City Of Lights

PostPosted: Fri 18 Sep 2009, 02:15    Post_subject:  

Gateway 4P-HT laptop 481M ram 512M swap Intel video and sound, wireless OK (b43), touch pad /w scroll OK
Frugal Install smp 1G save file, multi-boot XP, F11, and 421 frugal (on different partitions)

No Sound - ran "Setup ALSA Sound" - FILLED save file! Crashed. (no room left) Rebooted. Save file was corrupted and crashed with kernel panic.
Rebooted pfix=ram, deleted save file, created new one (1G) tried again. Started filling up save file again and Ctl-c before it crashed, Rebooted and save file still only has 444M free out of 1G.
Still no sound.

Couldn't mount a share using NFS. (didn't work in 421 either, might be my fault)

Does 430 use Ubuntu/Debian packages? Is there an easy way to install them? (using PPM?) I seem to remember this option from an early Alpha. (I didn't have a chance to test the beta's)

Lyle
Back to top
View user's profile Send_private_message Visit_website 
mysticmarks


Joined: 26 Feb 2007
Posts: 158
Location: California

PostPosted: Fri 18 Sep 2009, 02:30    Post_subject: bugz
Sub_title: bugz
 

First, the art is great. Simple, easy on the eyes. SUPER fast apps(fastest ever!) i never even got to let my mouse button unclick!


network wizard fails to find anything(nic or wireless intel 3945ABG), never had that happen before.
From cd, xorg wizard works; From USB xorgwizard fails?

woof: slack build script 2 errors
hack-install.sh gives errors for glic-2.7-i486-17.pet

Processing glibc_dev
processing glibc-2.7-i486-17.tgz
./hack-install.sh: line 82: chroot: command not found
./hack-install.sh: line 192: cd: bin: No such file or directory
./hack-install.sh: line 193: cd: bin: No such file or directory
Processing glibc
processing glibc-solibs-2.7-i486-17.tgz
processing glibc-zoneinfo-2.7-noarch-17.tgz
Postprocessing with packages-templates/glibc
./hack-install.sh: line 2: ldconfig: command not found
./hack-install.sh: line 12: chroot: command not found
./hack-install.sh: line 20: chroot: command not found

woof:debian build script 0
faac0 and faac0-dev not found
and drm-intel1 and drm-noveau1 not found
Back to top
View user's profile Send_private_message Visit_website 
cichlasoma

Joined: 12 Sep 2009
Posts: 69

PostPosted: Fri 18 Sep 2009, 05:32    Post_subject:  

As I reported for 4.25 already, I get no chance to enter boot options when booting from USB flash disk. (In 4.21, I do get the chance.)
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 18 Sep 2009, 07:07    Post_subject:  

ALSA Wizard crash. Yes, I'm going to re-upload 'pup-430.iso' tonight.

That was a curved ball, most unexpected. See my blog post:

http://puppylinux.com/blog/?viewDetailed=01097

But, if you already have pup-430.iso, no problem, just delete the '537' modules in /lib/modules/2.6.30.5/intelmodem

It does not affect pup-430-small.iso, as that does not have the big modem drivers.

Nor does the bug affect 4.3 built with the 2.6.25.16 and 2.6.21.7 kernels.

It amazes me sometimes. I think, I'll just do this one little thing, won't break anything. I did a few small things before the final, was ultra-careful. Oh well, Murphies Law I guess.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 18 Sep 2009, 07:15    Post_subject:  

cichlasoma wrote:
As I reported for 4.25 already, I get no chance to enter boot options when booting from USB flash disk. (In 4.21, I do get the chance.)


I never got around to implementing a boot menu for USB Flash install.

You have to edit syslinux.cfg (or extlinux.conf) on the Flash drive.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 18 Sep 2009, 07:24    Post_subject: Re: bugz
Sub_title: bugz
 

mysticmarks wrote:
First, the art is great. Simple, easy on the eyes. SUPER fast apps(fastest ever!) i never even got to let my mouse button unclick!


network wizard fails to find anything(nic or wireless intel 3945ABG), never had that happen before.
From cd, xorg wizard works; From USB xorgwizard fails?

woof: slack build script 2 errors
hack-install.sh gives errors for glic-2.7-i486-17.pet

Processing glibc_dev
processing glibc-2.7-i486-17.tgz
./hack-install.sh: line 82: chroot: command not found
./hack-install.sh: line 192: cd: bin: No such file or directory
./hack-install.sh: line 193: cd: bin: No such file or directory
Processing glibc
processing glibc-solibs-2.7-i486-17.tgz
processing glibc-zoneinfo-2.7-noarch-17.tgz
Postprocessing with packages-templates/glibc
./hack-install.sh: line 2: ldconfig: command not found
./hack-install.sh: line 12: chroot: command not found
./hack-install.sh: line 20: chroot: command not found

woof:debian build script 0
faac0 and faac0-dev not found
and drm-intel1 and drm-noveau1 not found


Don't report Woof build issues on this thread.

A note on building from Slackware, Debian, etc., basically you have to work out any problems yourself at this stage. Woof should build a Puppy from PET packages ok, because that's what I have done to create 4.3. The others though, that's up to you.

I will get around to working on building from one of the distros soon, but that is still a few weeks away.

Using Woof is for those proficient with the Linux commandline. And to build from another distro even more so.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 18 Sep 2009, 07:28    Post_subject: Re: bugz
Sub_title: bugz
 

mysticmarks wrote:
From cd, xorg wizard works; From USB xorgwizard fails?


I did a lot of testing. installing to USB, the xorgwizard always worked. I even did a sanity check install to USB Flash after 4.3final, still worked.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7836
Location: qld

PostPosted: Fri 18 Sep 2009, 07:37    Post_subject:  

Hmmm...

I'm yet to find a usb bug, have it working on my eee on sd card and a usb stick which I've tried on two of my boxes.

Trying the retro-retro (k2.6.21.7) on my p3 and it is working nicely except the xorg is playing up with my nvidia riva card. If I leave the pc unattended for an hour or so the display is garbled somewhat and a series of right clicks (bringing up the menu) is the only way to retrieve it. No big deal, a ctrl-alt-bkspce is quicker but sometimes I need the window I left open. This happens in all woofs I built with the newer xorg. I think the driver will fix it though, Smile

The small iso version (k2.6.30.5) is working great on my k6 400. Smile
Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 21 Posts_count   Goto page: 1, 2, 3, ..., 19, 20, 21 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1506s ][ Queries: 13 (0.0607s) ][ GZIP on ]