Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Nov 2014, 19:48
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
!!!!!FIXED!!!No audio from Dell Latitude CPI using Puppy 4.2
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 4 [57 Posts]   Goto page: Previous 1, 2, 3, 4
Author Message
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Sun 13 Sep 2009, 15:44    Post subject: Aitch
Subject description: Maybe I'm not using Geany correctly?
 

So in the place where I'm supposed to add lines to /etc/modprobe.conf using Geany, this is what I came up with, my lines are inserted at the end where it says Alsaconf has made these changes, do not edit:

alias binfmt-204 binfmt_aout
alias binfmt-263 binfmt_aout
alias binfmt-264 binfmt_aout
alias binfmt-267 binfmt_aout
alias binfmt-387 binfmt_aout
alias binfmt-332 iBCS
alias binfmt--310 binfmt_java
alias block-major-1-* rd
alias block-major-2-* floppy
alias block-major-3-* ide-probe-mod
alias block-major-7-* loop
alias block-major-8-* sd_mod
alias block-major-9-* md
alias block-major-11-* sr_mod
alias block-major-13-* xd
alias block-major-15-* cdu31a
alias block-major-16-* gscd
alias block-major-17-* optcd
alias block-major-18-* sjcd
alias block-major-20-* mcdx
alias block-major-22-* ide-probe-mod
alias block-major-23-* mcd
alias block-major-24-* sonycd535
alias block-major-25-* sbpcd
alias block-major-26-* sbpcd
alias block-major-27-* sbpcd
alias block-major-29-* aztcd
alias block-major-32-* cm206
alias block-major-33-* ide-probe-mod
alias block-major-34-* ide-probe-mod
alias block-major-37-* ide-tape
alias block-major-44-* ftl
alias block-major-46-* pcd
alias block-major-47-* pf
alias block-major-56-* ide-probe-mod
alias block-major-57-* ide-probe-mod
alias block-major-58-* lvm-mod
alias block-major-88-* ide-probe-mod
alias block-major-89-* ide-probe-mod
alias block-major-90-* ide-probe-mod
alias block-major-91-* ide-probe-mod
alias block-major-93-* nftl
alias block-major-97-* pg
alias char-major-4-* serial
alias char-major-5-* serial
alias char-major-6-* lp
alias char-major-9-* st
alias char-major-10-0 busmouse
alias char-major-10-2 msbusmouse
alias char-major-10-3 atixlmouse
alias char-major-10-130 wdt
alias char-major-10-131 wdt
alias char-major-10-135 rtc
alias char-major-10-139 openprom
alias char-major-10-144 nvram
alias char-major-10-157 applicom
alias char-major-10-175 agpgart
alias char-major-10-184 microcode
alias char-major-10-200 tun
alias char-major-13-* input
alias char-major-13-32 mousedev
alias char-major-14-* soundcore
alias char-major-19-* cyclades
alias char-major-20-* cyclades
alias char-major-21-* sg
alias char-major-22-* pcxx
alias char-major-23-* pcxx
alias char-major-27-* ftape
alias char-major-34-* scc
alias char-major-35-* tclmidi
alias char-major-36-* netlink
alias char-major-37-* ide-tape
alias char-major-48-* riscom8
alias char-major-49-* riscom8
alias char-major-57-* esp
alias char-major-58-* esp
alias char-major-63-* kdebug
alias char-major-90-* mtdchar
alias char-major-96-* pt
alias char-major-99-* ppdev
alias char-major-107-* 3dfx
alias char-major-108-* ppp_generic
alias char-major-109-* lvm-mod
alias char-major-161-* ircomm-tty
alias char-major-171-* raw1394
alias char-major-195-* NVdriver
alias char-major-200-* vxspec
alias char-major-206-* osst
alias dos msdos
alias dummy0 dummy
alias dummy1 dummy
alias iso9660 isofs
alias md-personality-1 linear
alias md-personality-2 raid0
alias md-personality-3 raid1
alias md-personality-4 raid5
alias md-personality-7 multipath
alias net-pf-1 unix
alias net-pf-2 ipv4
alias net-pf-4 ipx
alias net-pf-5 appletalk
alias net-pf-17 af_packet
alias netalias-2 ip_alias
alias irlan0 irlan
alias irda-dongle-0 tekram
alias irda-dongle-1 esi
alias irda-dongle-2 actisys
alias irda-dongle-3 actisys
alias irda-dongle-4 girbil
alias irda-dongle-5 litelink
alias irda-dongle-6 airport
alias irda-dongle-7 old_belkin
alias plip0 plip
alias plip1 plip
alias tunl0 ipip
alias cipcb0 cipcb
alias cipcb1 cipcb
alias cipcb2 cipcb
alias cipcb3 cipcb
alias ppp0 ppp_generic
alias ppp1 ppp_generic
alias slip0 slip
alias slip1 slip
alias tty-ldisc-1 slip
alias tty-ldisc-3 ppp_async
alias tty-ldisc-11 irtty
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-18 ppp_mppe
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate
alias parport_lowlevel parport_pc
alias usbdevfs usbcore
alias /dev/ppp ppp_generic
alias /dev/lp0 /dev/lp1 lp
alias char-major-116-* snd
options sb io=0x220 irq=7 dma=1 dma16=5 mpu_io=0x330
install binfmt-0000 /bin/true
install char-major-10 /bin/true
install char-major-10-1 /bin/true
install dummy0 /sbin/modprobe -o dummy0 --ignore-install dummy
install dummy1 /sbin/modprobe -o dummy1 --ignore-install dummy
install eth0 /bin/true
install net-pf-10 /bin/true
install net-pf-19 /bin/true
install net-pf-3 /bin/true
install net-pf-6 /bin/true
install ov518_decomp { /sbin/modprobe ov511; } ; /sbin/modprobe --first-time --ignore-install ov518_decomp
install scsi_hostadapter /bin/true
install wacom /sbin/modprobe --first-time --ignore-install wacom && { /sbin/modprobe evdev; /bin/true; }
remove ov518_decomp /sbin/modprobe -r --first-time --ignore-remove ov518_decomp && { /sbin/modprobe -r ov511; /bin/true; }
remove wacom { /sbin/modprobe -r evdev; } ; /sbin/modprobe -r --first-time --ignore-remove wacom
install sdhci /sbin/modprobe mmc_block ; /sbin/modprobe --ignore-install sdhci
remove sdhci /sbin/modprobe -r --ignore-remove sdhci ; /sbin/modprobe -r mmc_block
install tifm_7xx1 /sbin/modprobe --ignore-install tifm_7xx1 ; /sbin/modprobe mmc_block ; /sbin/modprobe tifm_sd

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.16 ---
alias snd-card-0 snd-cs4236
alias sound-slot-0 snd-cs4236
options snd-cs4236 index=0 port=0x530 cport=0x538 isapnp=0 dma1=1 dma2=0 irq=5
# --- END: Generated by ALSACONF, do not edit. ---

Does this look right to you? Confused
Back to top
View user's profile Send private message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Sun 13 Sep 2009, 23:26    Post subject: An error report, maybe there's a new clue?  

This is an error report from running alsaconf after adding some code to etc/rc.d/rc.local. The report may be incidental to the code, but here it is any way:

modprobe -v cs4232 io=0x530 irq=5 dma=1 dma2=0

Here's the error report:

Loading driver...
Shutting down sound driver: amixer: Mixer attach default error: No such device
amixer: Mixer attach default error: No such device
/usr/sbin/alsactl: save_state:1497: No soundcards found...
ERROR: Module snd_cs4232 is in use
ERROR: Module snd_opl3_lib is in use by snd_cs4232
ERROR: Module snd_hwdep is in use by snd_opl3_lib
ERROR: Module snd_cs4231_lib is in use by snd_cs4232
ERROR: Module snd_pcm is in use by snd_cs4231_lib
ERROR: Module snd_timer is in use by snd_opl3_lib,snd_cs4231_lib,snd_pcm
ERROR: Module snd_mpu401_uart is in use by snd_cs4232
ERROR: Module snd_rawmidi is in use by snd_mpu401_uart
ERROR: Module snd_seq_device is in use by snd_opl3_lib,snd_rawmidi
ERROR: Module snd is in use by snd_cs4232,snd_opl3_lib,snd_hwdep,snd_cs4231_lib,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
Starting sound driver: snd-cs4232

If you can explain what's wrong, and/or what to try, sure appreciate it.

Thanks

Eth
Back to top
View user's profile Send private message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Mon 14 Sep 2009, 09:10    Post subject:  

Sorry, I'm out of tips/knowledge on this one....

Have PM'd tempestuous

Aitch Smile
Back to top
View user's profile Send private message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Mon 14 Sep 2009, 10:44    Post subject: Aitch: thanks for the time you spent with me.
Subject description: I know more about a lot of linux from your replies.
 

I'll keep putting stuff up about my problem... hopefully somebody will spot what's wrong.
Back to top
View user's profile Send private message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Tue 15 Sep 2009, 14:55    Post subject: tried a couple things, nothing worked...
Subject description: Anybody's input is welcome at this time :)
 

I tried to other things:

214x11
Puppy 3.1

Could not get either one to even load no matter what I tried.

So I figured, maybe the new Puppy 4.3 (425) will have good backward compatibility, so I tried it:

Puppy 4.3 is OUTSTANDING. Everything is good as far as functionality, and substantially better than 4.2, particularly the internet connection wizard. One complaint, the appearance is not as attractive as 4.2 (but I'll make some changes).

Audio:
Still no audio. However, the Alsaconf Wizard now recognizes cs4236 as it's own category instead of finding it under 'probe legacy' stuff. Also, the Alsa Mixer now loads and can be played with (just doesn't make sound). So, I think I'm closer, but not there yet.

Currently I think the problem is not Puppy. I think my other OS (Win2k) is protecting an asset, or I have overlooked something in the bios (Dell A12), although I can't imagine what.

Anybody's input is welcome. Wink

Eth
Back to top
View user's profile Send private message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Tue 15 Sep 2009, 21:54    Post subject: SO HERE'S HOW I FIXED IT
Subject description: Special thanks to Aitch who spent a lot of time helping me, by the way.
 

So it started when I decided to try a different version from 4.2.

Aitch encouraged me to try ttuuxxx's 214x11, which I didn't really want to do since everything was working so well in 4.2 except the sound. He thought it might have a better time recognizing the old sound card for my antique latitude cpi.

I erased 4.2, burned 214x11 on my host, then stuck it into my laptop... and it wouldn't load! Crap! A bunch of boot options, I tried more of them then I can remember, and nothing!!!

Okay, so I started looking at the other releases, and found Puppy Retro 3.1., which is supposed to be compatible with the old kernels. I burned it, tried it out... and nothing!!! Damn!!!

So then, contemplating going back to 4.2, the thought occurred to me that maybe 4.3 (425) would have good backward compatibility. So I burned it and loaded it up, and, aside from being less attractive visually, it worked like a dream. Everything about the performance is better, especially the network interface. Much, much better.

But still no sound. However, some things were working that hadn't been before in 4.2. Alsaconf was now recognizing cs3246 instead of calling it cs3242. I loaded it and reloaded it several times, but no sound. However, the Alsa Mixer was now able to open whereas it wouldn't under 4.2.

Most of my previous torture and sweat had been about the bio settings and getting 4.2 to recognize the correct sound card. But I only played with it a little because I was still thinking it was a driver (because my bios says the audio is 3247, not 3246, and I didn't really believe Puppy since it had been wrong about 3242).

So then I happened on a reply from tempestuous to somebody else, about using hitting 'm' to mute and unmute the mixer. I tried it... nothing. So I fiddled with something else, the multiple sound card wizard. It gave me two options...
1. cs3246 as my primary card... or...
2. cs3246 as my primary card... nice.
I clicked it and left.

Then I went back to the mixer, and all the settings were gone. Crap.

I rebooted, went back to Alsaconf, reloaded cs3246, went back to the mixer, opened a music file...

HOLY CRAP... IT WORKS!!!!!!!!!!!!!!!!!!!!!!!!!
AHAHAHAHAHAHAHAHAHAHAHAHAHAHAHAHA!!!!
I AM A LINUX SUCCESS!!!!!!!!!!!!!

Conclusions:

1. 4.3 is better than 4.2 for an older laptop like mine.

2. A lot of little things contributed to my success like upgrading bios and changing bio settings.

3. Catching that note from tempestuous' to somebody else about the Mixer's mute function was shear luck, and proves the importance of reading and searching the forums... and reading, and searching, and reading, searching, reading some more... searching more...

4. A hidden conflict was inadvertently corrected by using the multiple sound card wizard to force puppy to make cs3246 its primary choice even though it was the only choice, for Pete's sake! Why did that work? I have no idea. It's ridiculous!

Thanks to Aitch who helped me personally, and a couple others, tempestous who helped some other people, which inadvertently helped me, and to everybody who kept posting stuff about linux audio. I've read a couple book's worth of posts in the last week trying to figure it out.

I am a linux success story. I have audio. I don't need windows anymore. Hooray for me!!!!!

Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy Very Happy
Back to top
View user's profile Send private message 
Bligh

Joined: 08 Jan 2006
Posts: 484
Location: California

PostPosted: Wed 16 Sep 2009, 00:30    Post subject:  

Good news, maybe I will give 4.3 a go on that box.
Cheers
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Wed 16 Sep 2009, 02:04    Post subject:  

Quote:
I am a linux success story. I have audio. I don't need windows anymore. Hooray for me!!!!!


Read and enjoyed this whole thread and the process.
You are now tuxified.
Soon you will be hardcore
http://www.dedoimedo.com/computers/linux_commands.html

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7082
Location: Perth, Western Australia

PostPosted: Wed 16 Sep 2009, 06:50    Post subject:  

Fascinating!

I wonder what I could do in 4.3, well no it will have to be 4.3.1 as 4.3 is now "frozen", so that anyone else in the same situation won't have to go through such a lengthy process?

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Wed 16 Sep 2009, 09:44    Post subject:  

Eathray

Bonus points for perseverence!! Very Happy

Well Done - You are an encouragement to other noobies like yourself

I did actually post about the mute thing....in amongst loads of other stuff, it probably got overlooked, - no problem

Thanks.....And to BarryK, too, for whatever you do to continually improve an already outstanding OS

Another Puppified customer Laughing

Eathray - where you added "!!fixed!!" to your first post, would you add - "Used Puppy 4.3" to the subject description line so others get a preview of the solution? - thanks

Aitch Smile
Back to top
View user's profile Send private message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Wed 16 Sep 2009, 10:34    Post subject: Aitch, noted 4.3 in the subject description.  

I made a note in the subject line that I switched to 4.3.
Back to top
View user's profile Send private message 
Bligh

Joined: 08 Jan 2006
Posts: 484
Location: California

PostPosted: Mon 28 Sep 2009, 05:46    Post subject:  

Thanks to all, I now have sound on that box with the sb 24 bit card. 4.3 seems fast also, even on this old box.
Cheers
Edit, I didn't have to do anything, 4.3 just automagically configured my sound card correctly.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 4 [57 Posts]   Goto page: Previous 1, 2, 3, 4
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1003s ][ Queries: 12 (0.0115s) ][ GZIP on ]