Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Feb 2019, 13:05
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
SCIM not working with Java apps
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message

PostPosted: Thu 01 Oct 2009, 16:48    Post subject:  SCIM not working with Java apps
Subject description: Some progress, but need further help

I would like to get Scim working with Java applications in Puppy. It is possible in other distros, so I think it should be possible in Puppy as well.

After months of saying that Scim won't respond at all to Java, I've found that this is only half the story.

I can now get the Scim panel to pop up when I press cntrl-space, under the following circumstances:

* This text needs to be added to the .xinitrc file

export XIM=SCIM
export XIM_PROGRAM=/usr/bin/scim
export XIM_ARGS="-d -c socket -f X11 -e socket"

Actually, the third line doesn't seem to make much difference, and I'm not sure that both of the last two lines are needed. I copied it from another wiki.

* The locale must not be a utf-8 locale
* The locale must not previously have been set to a utf-8 locale

It is fine to add stuff like
export LC_ALL="en_NZ.UTF-8"
export LC_CTYPE="en_NZ.UTF-8"
export LC_MESSAGES="en_NZ.UTF-8"
export LOCALE="en_NZ.UTF-8"
export LANG="en_NZ.UTF-8"
export LANGUAGE="en_NZ.UTF-8"

to the .xinitrc file.

I've tested this in Puppy 2.17 (my main compiling version) and the latest 4.30 with the new kernel. I'm assuming that all the intervening versions will behave in the same way.

So far, so good. BUT, and this is the big BUT, none of the IM engines are available to Java apps. That is, no pinyin, hangul, chewing, anthy, canna and all the other engines which are the reason one uses Scim in the first place.

I installed uim (see http://murga-linux.com/puppy/viewtopic.php?p=346646#346646) and the same thing applies - no engines available to uim.

So, I appeal to those of you with greater expertise and more detailed knowledge of Puppy's underlying structure. Is there a library that needs to be added, an existing one that needs to be compiled with other options, or an environment variable that needs to be set? Or something I haven't thought of?

Thanks in anticipation
Back to top

PostPosted: Tue 20 Oct 2009, 18:42    Post subject: Solved, I think  

Solved, I think.

See here: http://www.murga-linux.com/puppy/viewtopic.php?p=352479#352479
Back to top
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0244s ][ Queries: 11 (0.0028s) ][ GZIP on ]