Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 20:46
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Transmission 2.31 pets - Peer-to-Peer connector
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 9 [129 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Author Message
sikpuppy


Joined: 29 Mar 2009
Posts: 433

PostPosted: Mon 09 Nov 2009, 03:25    Post subject:  

sketchman wrote:
Doesn't work for me in 4.1.2. I get the following error.

Code:
transmission: symbol lookup error: transmission: undefined symbol: gdk_threads_add_timeout_seconds


Someone else had the same problem, but I didn't see a solution in the thread.
http://murga-linux.com/puppy/viewtopic.php?t=47394&search_id=20023137

EDIT: If it helps, installing libidn.so.11 fixed a problem with version 1.22, so I do have that one now.


It looks like a GLIB problem. If the older puppies use a version of GLIB that is older than the version that Transmission was compiled with then this sort of thing happens.

I could post a copy of the updated GLIB I use, but this might break other things on peoples systems. It shouldn't, but it might. Updating GLIB often requires updating GTK and PANGO as well. This wasn't an issue for me, but it does mean that any further compiles that are attempted on an GLIB updated machine may not work on a clean install/Live CD.

_________________
ASUS A1000, 800Mhz PIII Coppermine!, 192Mb RAM, 10Gb IBM Travelstar HDD, Build date August 2001.
Back to top
View user's profile Send private message MSN Messenger 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Wed 18 Nov 2009, 16:20    Post subject:  

*placeholder*
Last edited by panzerpuppy on Wed 18 Nov 2009, 16:50; edited 2 times in total
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Wed 18 Nov 2009, 16:38    Post subject:  

The latest build of Transmission doesn't work in any version of Puppy older than 4.3 Sad

I get the same $#@%^* error in Puppy 4.21 and Turbopup:
Code:
transmission: symbol lookup error: transmission: undefined symbol: gdk_threads_add_timeout_seconds


And that's not all - Transmission is now extra bloated if you're using Puppy 4.21 or older:
Now it requires an additional dependency (libgio-2.0.so.0) that's almost the same size as the Transmission binary

Michalis,did you compile this build in Puppy 4.3 or later?
If that's the case, could you do another compile of Transmission 1.76 in Puppy 4.2 (to produce a package with less dependencies that's compatible with the older Puppies as well)?

Do you still keep an archive of your old Transmission packages? I need the last working builds (v1.72, v1.74 and v1.75).



----------
panzerpuppy
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Thu 19 Nov 2009, 07:21    Post subject:  

Does anyone have a copy of the previous release (v1.75)?

(the last one i've tried in Puppy 4.21 was v1.72 and it worked great)
Back to top
View user's profile Send private message 
jayargent

Joined: 01 Feb 2009
Posts: 11

PostPosted: Thu 19 Nov 2009, 08:33    Post subject:  

Here you go panzerpuppy

http://www.4shared.com/file/155243963/b339f006/transmission-174-i486-small.html
http://www.4shared.com/file/155243987/2ad71991/transmission-175-i486-small.html
Back to top
View user's profile Send private message 
T_B

Joined: 08 Apr 2007
Posts: 154

PostPosted: Sun 06 Dec 2009, 14:16    Post subject:  

Hi Michales,

Thanks for 1.76, after installing 1.76 my torrents were not connecting anymore.

After that installing 1.74 didn't help solving it...

In the message log this message is being repeated:

Sun Dec 6 19:38:25 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:39:11 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:39:32 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:39:37 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:39:43 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:39:44 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:39:46 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:40:38 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:41:05 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:41:09 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:41:10 2009 Saved "/root/.config/transmission/settings.json"
Sun Dec 6 19:41:11 2009 Saved "/root/.config/transmission/settings.json"

Solved:

I deleted all files and directories in /root/.config/transmission/ and started again.

So it appears 1.76 works fine in 4.3.1 Smile
Back to top
View user's profile Send private message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Sat 23 Jan 2010, 18:12    Post subject: update to version 1.82  

Transmission updated to version 1.82
Back to top
View user's profile Send private message 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Fri 12 Feb 2010, 16:41    Post subject:  

1.82 doesn't work for me...I'm on puppies 4.31, it continuosly starts downloading for some 10-15 seconds, then stops, as if it loses connection, then starts again...I've tried 1.83 on ubuntu (lucid) it works fine...btw I've switched back to 1.76, it works fine
Back to top
View user's profile Send private message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Mon 15 Feb 2010, 16:43    Post subject: Transmission updated to version 1.83  

Transmission updated to version 1.83


=== Transmission 1.83 (2010/01/23) ===

==== All Platforms ====
* Fix 1.80 announce error that caused uploads and downloads to periodically freeze
* Fix 1.80 announce timeout error that caused "no response from tracker" message
* Fix 1.80 "file not found" error message that stopped some torrents
* Fix 1.82 crash when adding new torrents via their ftp URL
* Fix 1.80 crash when receiving invalid request messages from peers
* Fix 1.82 error when updating the blocklist


@eden6000 check whether this 1.83 fixes your problem.
Back to top
View user's profile Send private message 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Wed 17 Feb 2010, 03:55    Post subject:  

Thanks Michalis...i'm not at home these days...when I come back I'll try your new pet
Back to top
View user's profile Send private message 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Wed 17 Feb 2010, 16:56    Post subject:  

Everything ok Michalis, 1.83 works fine, thanks!
Back to top
View user's profile Send private message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Sat 06 Mar 2010, 09:42    Post subject: Transmission updated to version 1.91  

Transmission updated to version 1.91


What's new:

=== Transmission 1.91 (2010/02/21) ===
==== All Platforms ====
* Fix 1.90 crash-on-startup bug that affected some users
* Fix 1.90 bug that caused the "turtle mode" state to be forgotten between sessions
* Fix 1.83 crash when adding a torrent by URL from an ftp source via the web client
* For the BitTorrent spec's "downloaded=X" passage, use the de facto standard



=== Transmission 1.90 (2010/02/16) ===
==== All Platforms ====
* Add an option to disable the .part suffix for incomplete files
* Add priority selector to GUI clients' add torrent windows
* Fix 1.81 bug that broke HTTP requests to sites that gave HTTP 301 redirects
* Fix 1.8x bug in announcing "finished downloading" and "stopping" at the same time
* Fix 1.8x bug in announcing partial seeds
* Try harder to make announces finish, even if the tracker responds slowly
* Fix bug that didn't honor download speed limits of 0
* Use fallocate64() for fast file preallocation on systems that support it
* Magnet link improvements
* Don't let "Disk is full" errors cause loss of configuration files
* Faster parsing of bencoded data, such as torrent files

==== GTK+ ====
* Give more helpful error messages if "Set Location" or "Add Magnet Link" fail
* Add optional support for libappindicator
* Minor build fixes

==== Daemon ====
* Add transmission-remote support for port testing and blocklist updating
* Add transmission-daemon support for incomplete-dir, dht, and seedratio
* If settings.json is corrupt, give an error telling where the problem is
* Add option to specify where log messages should be written

==== Web Client ====
* Add a tracker tab to the inspector
* Fix 1.8x display error when showing magnet link information
Back to top
View user's profile Send private message 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Sat 06 Mar 2010, 09:53    Post subject:  

Thank you very much from us all Transmission users! Smile
Back to top
View user's profile Send private message 
Michalis

Joined: 08 Jan 2008
Posts: 237
Location: Greece

PostPosted: Sat 20 Mar 2010, 14:00    Post subject: Transmission updated to version 1.92  

Thank you eden6000 hope you like it and works perfectly Very Happy


Transmission updated to version 1.92



What's new:
=== Transmission 1.92 (2010/03/11) ===
==== All Platforms ====
* Fix possible data corruption issue caused by data sent by bad peers during endgame
* Fix potential buffer overflow when adding maliciously-crafted magnet links
* Fix announces to IPv6 trackers
* Fix DNS problems on some platforms, including Debian
* Fix issues with the incomplete directory functionality
* Fix port forwarding error on some routers by updating libnatpmp and miniupnp

==== GTK+ ====
* Fix directory selection error in GTK+ 2.19
* Small GUI improvements: HIG correctness, remove deprecated GTK+ calls, etc.

==== Daemon ====
* Fix 1.91 build error on Mac and FreeBSD
* Standardize the daemon's watchdir feature to behave like the other clients'

==== Web Client ====
* Statistics dialog
* Fix error in "trash data & remove from list" that didn't trash all data
* Fix display of ratios and time
* Update to jQuery 1.4.2

*one small note, I haven't tested it because didn't had time but most likely it will be working well as it's compiled the same way with the previous.
Back to top
View user's profile Send private message 
eden6000

Joined: 08 Apr 2007
Posts: 259

PostPosted: Sat 20 Mar 2010, 17:37    Post subject:  

I'm testing it now, seems everything is fine....one thing I noticed, the packages have grown up, haven't them?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 9 [129 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0947s ][ Queries: 13 (0.0105s) ][ GZIP on ]