Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 19:23
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Want straight up access to all Ubuntu/Debian packages?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Author Message
tgp1994

Joined: 23 Sep 2009
Posts: 23
Location: C:/Documents and Settings/*******/My Documents/VMWare/Puppy Linux/Puppy Linux.vmdk//./root

PostPosted: Sun 22 Nov 2009, 21:07    Post_subject:  Want straight up access to all Ubuntu/Debian packages?
Sub_title: A success story
 

Well guys, I know several people here were speculating on the idea of apt-get working on Puppy linux, and I bet several more have gotten it working. I just wanted to post my success story on getting it working.

Basically, I went to Debian's website, then to their package section, and then I went on ahead and downloaded apt-get from there. (You have to scroll down to the bottom in order to get compiled downloads per processor type.) Fortunately, puppy supports .deb archives all the way up to the point of installing them and making them accessible from the "start" menu, if applicable, but apt-get is command line only. So open up the terminal, then type apt-get. If you get a reply with available options, then you are pretty much all set! Go ahead and type apt-get update, and it should then update your database of available packages. Now type apt-get -f install, which should go through and download+install any missing or broken dependencies. Finally, if you want some gui management, go ahead and apt-get install synaptic, which should download, install, and place it in the same menu that contains puppy's version of synaptic. (It won't actually launch from there though, you'll have to open a terminal and type synaptic.) I seem to recall having some trouble getting it to work off the bat, so try and improvise from there.

If you have any trouble getting anything to work, or are being prompted with an error message, post it exactly as is here and I will help you.

If you have a problem, go here first to see if it hasn't all ready been posted!
debianizationflowchart.zip
Description  The XMind project file for the flow chart. Follow it from bottom right to top left. If you make a change, please notify me!
zip

 Download 
Filename  debianizationflowchart.zip 
Filesize  61.99 KB 
Downloaded  454 Time(s) 
debianizationflowchartimg.jpg
Description  My FlowChart, detailing what packages you need in order to get a Debian system going.
jpg

 Download 
Filename  debianizationflowchartimg.jpg 
Filesize  86.29 KB 
Downloaded  1823 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
WireWulf


Joined: 20 Sep 2009
Posts: 98
Location: somewhere

PostPosted: Sun 22 Nov 2009, 21:13    Post_subject:  

WOOF!!!
nice work yay i can apt-get

_________________
are we who we think we are? or is this all a lie thought up by people whom we can not see?
Back to top
View user's profile Send_private_message 
tgp1994

Joined: 23 Sep 2009
Posts: 23
Location: C:/Documents and Settings/*******/My Documents/VMWare/Puppy Linux/Puppy Linux.vmdk//./root

PostPosted: Sun 22 Nov 2009, 21:41    Post_subject:  

No problem Smile

This is actually my first and probably will be my best linux contribution.
Back to top
View user's profile Send_private_message 
flydr2

Joined: 20 Nov 2009
Posts: 1

PostPosted: Mon 23 Nov 2009, 08:12    Post_subject:  

Problem...

I'm running puppy 4.6

When I type apt-get I get E: Unable to determine a suitable packaging system type.
Back to top
View user's profile Send_private_message 
pri


Joined: 09 Oct 2009
Posts: 330
Location: Bandung Indonesia

PostPosted: Mon 23 Nov 2009, 12:49    Post_subject: me too  

flydr2 wrote:
Problem...

I'm running puppy 4.6

When I type apt-get I get E: Unable to determine a suitable packaging system type.


not work for me to!!!!

how its work?

if manualy using searching on debian package, it was often doing by me.

_________________
Learning by Doing
Back to top
View user's profile Send_private_message Visit_website YIM 
tgp1994

Joined: 23 Sep 2009
Posts: 23
Location: C:/Documents and Settings/*******/My Documents/VMWare/Puppy Linux/Puppy Linux.vmdk//./root

PostPosted: Mon 23 Nov 2009, 16:31    Post_subject:  

Hmmm... I do not remember getting those errors. So I'm assuming you guys both got apt-get from debian's website, and you installed them correctly, right? (And you got the i386 versions?)

A short google search seems to come up saying that sources.list may be a culprit, could both of you please post yours here? (Use PSearch to find it.)

EDIT: After thinking about it for a bit, DPKG generally puts up errors starting with "E:", so go here and download dpkg and install it.
Back to top
View user's profile Send_private_message 
Gorilla no baka


Joined: 26 Oct 2008
Posts: 234
Location: UK

PostPosted: Wed 02 Dec 2009, 14:20    Post_subject: Apt-get  

Right....

I am back again... Rolling Eyes Running Jaunty Puppy version 4.7.6.

As i told you sometime ago the only thing that still keeps me tied to Windows is the videoconferencing in Skype and Yahoo and that fact that get better download speeds in Win without havin` to go Axel -n 100 Razz

So thrilled by the prospect of having the power apt-get under my hands Rolling Eyes i went to this site
http://packages.debian.org/lenny/i386/apt/download and downloaded

apt_0.7.20.2+lenny1_i386.deb installed it nicely no problem





But when i actually tried to install something it it gave me the following error


SO what do we do now? Any ideas...??

Cheers

_________________


I'M IN MY OWN WORLD.
IT'S OK, THEY KNOW ME HERE..!!!
Back to top
View user's profile Send_private_message Visit_website 
John Lewis

Joined: 03 Dec 2007
Posts: 148
Location: Albany West Australia

PostPosted: Sun 06 Dec 2009, 00:45    Post_subject:  

I have to admit not knowing much about apt-get other than having used it in other distros.

I wonder if it is a repository thing. I don't know how it would be done or checked but do you have the right repositoy?

Also had you done an apt-update?

Probably of no help but might spark other ideas.

John Lewis
Back to top
View user's profile Send_private_message 
tgp1994

Joined: 23 Sep 2009
Posts: 23
Location: C:/Documents and Settings/*******/My Documents/VMWare/Puppy Linux/Puppy Linux.vmdk//./root

PostPosted: Sun 06 Dec 2009, 01:55    Post_subject:  

You are actually lucky enough to have come across an easy to solve problem Wink

Simple go to /var/lib/dpkg and create a blank file named "status". If it gives you a similar error, repeat, except with the file name requested.

Enjoy, and I will add this to the wiki!
Back to top
View user's profile Send_private_message 
stevesr0

Joined: 24 Jun 2007
Posts: 169

PostPosted: Sat 19 Dec 2009, 19:31    Post_subject: didn't work  

I downloaded and extracted the file with pupzip.

After it failed to work in terminal (err - bash no such command), I read your Debianization instructions and moved the .deb archive to / (not the root directory) and again extracted. No go.

I looked at the list of files supposed to be in the package and can't find them on my system so I don't know what I am doing wrong.

I am running puppy 4.2.1 on a Fujitsu T4220 convertible tablet.

Appreciate any advice/assistance.

Steve
Back to top
View user's profile Send_private_message 
tgp1994

Joined: 23 Sep 2009
Posts: 23
Location: C:/Documents and Settings/*******/My Documents/VMWare/Puppy Linux/Puppy Linux.vmdk//./root

PostPosted: Sat 19 Dec 2009, 22:41    Post_subject:  

Hmmm... I'm more used to terminal extracting now, so give these a try:

Code:

ar -dv (Archive name here)

then...

tar -xvf data.tar.gz (It will always be named data.tar.gz)


That should then exract everything to the current folder, hopefully you will do this in the root of the hd.

And if that does not work, try searching for apt, and see what you get.

I'm almost betting that it's extracting the binary to a place that is not yet in the path.
Back to top
View user's profile Send_private_message 
stevesr0

Joined: 24 Jun 2007
Posts: 169

PostPosted: Sun 20 Dec 2009, 00:10    Post_subject: follow up to doesn't work when I type apt-get  

After following your instructions for extracting from terminal (in root directory), I see progress.

I now obtained E: msg seen by two other respondents, namely "E: Unable to determine a suitable packaging system type."

I followed your advice and instructions to download and install dpkg. Same error msg.

I realized that you only told me to extract the data.tar.gz and not the control.tar.gz, so I used the same commands in terminal to extract that file as well.

This didn't change the error msg.

Not clear how to analyze this - appreciate comments.
BTW, do I need to RTFM?

Thanks again.

Steve
Back to top
View user's profile Send_private_message 
tgp1994

Joined: 23 Sep 2009
Posts: 23
Location: C:/Documents and Settings/*******/My Documents/VMWare/Puppy Linux/Puppy Linux.vmdk//./root

PostPosted: Sun 20 Dec 2009, 17:08    Post_subject:  

Since I'm a nicer person I would just say Read the Manual rather than Read The F***ing Manual Wink

But I should probably do the same myself...

After googling around a little more, here is what I can conclude on the error: In some way certain files are missing, since google brings back results from a project called "scratchbox". Unfortunately, none of the issues brought up have solutions, so let's give this a try:

If you could download, manually extract, and install all depend packages found here, that would help me and everyone else out very much. If you could install one, then see if it's working, that would be great as well. (And report which one fixed it, too.) As a side note, you only need to extract the data archive, since the other ones only contain info for dpkg as in how to install the package, etc.

I don't really understand why other users have been getting this, whereas I didn't, has there been a recently release of puppy?
Back to top
View user's profile Send_private_message 
stevesr0

Joined: 24 Jun 2007
Posts: 169

PostPosted: Sun 20 Dec 2009, 23:30    Post_subject: Second response to tgp1994  

I tried the additional downloads and...

Wow, what a mess that caused!

First, I selected coreutils...deb and lib6...deb to the / directory and then tried extracting manually as before. However, no tar.gz files were generated and so I did two things.

I renamed the files extracted from the previous deb file (the new deb files contained files with the same names). Then, I used the pupzip application with the coreutils....deb and produced a new data.tar.gz file and then in terminal manually ran tar -xvf data.tar.gz.

The screen responded with a string of files.

However, after this the apt-get command did not work any better and then I attempted to recheck the files in / prior to installing the lib6...deb files. The ls command produced and error that involved libselinux.so.1. I had noted that selinux files were in another dependency that I had not downloaded and extracted and installed.

After this, I no longer had an internet connection.

I closed the terminal and reopened it, but it still had the previous messages and problem doing an ls command. With TAB, I found that in theory there were 1601 commands available to the shell (including ls), but the failure to find the libselinux.so.1 file blocked its display.

I rebooted and now could not boot into X, because of a similar error message.

Somewhat desperate, I looked for a backup save file and found one (512 megabytes vs the new one with 3581 megabytes).

I renamed the new save file as bad and moved the backup to the /mnt/home/puppy421 directory and renamed it as pupsave-live421.2fs.

My system now rebooted into an X windowed environment and seems to be normal.

I think I will wait a bit before trying again.

Hope that helps <g>.

Steve
Back to top
View user's profile Send_private_message 
tgp1994

Joined: 23 Sep 2009
Posts: 23
Location: C:/Documents and Settings/*******/My Documents/VMWare/Puppy Linux/Puppy Linux.vmdk//./root

PostPosted: Mon 21 Dec 2009, 00:33    Post_subject:  

Heh, sorry about your troubles Sad

Hopefully someone else will discover the solution to this, or I'll be able to get working on puppy again.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0910s ][ Queries: 13 (0.0056s) ][ GZIP on ]