Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 01:12
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
How to force Java Sound to use ALSA not OSS?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
soundman

Joined: 16 Dec 2009
Posts: 1

PostPosted: Wed 16 Dec 2009, 07:08    Post_subject:  How to force Java Sound to use ALSA not OSS?  

Hi All, my first post here so keeping my fingers crossed.

Normally I can find everything I need thru Google, but now I need help from the experts! I have a Java Sound application running under Puppy 4.0 (and JRE1.6.0_07), but now I want to implement 5.1 surround sound. I've configured my .asoundrc file so that part is all working well.

Here's the issue - Java always uses /dev/dsp as the driver. I've read in a few other linux distro forums that all you need to do is uninstall OSS to force Java to use ALSA /dev/snd/ drivers, but nobody says how this is done. It is not listed in PETget so I assume it's part of the core kernel, and I'm not at the level of building my own Puppy.

Is there any easy way this can be done?

TIA.
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6448
Location: Auckland, New Zealand

PostPosted: Wed 16 Dec 2009, 14:42    Post_subject:  

I don't think Puppy includes oss - it just has Alsa's "oss emulation". Maybe you can configure it to disable that, but if Java really uses oss unless it is not present, then I'd say it is a stupid program Smile Surely it can be configured to use Alsa...
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 16 Dec 2009, 16:42    Post_subject:  

Hmmm .....


disciple is correct ... puppy only have alsa installed with oss-emulation layer ... To try removing the oss emulation layer, you'll need to unload the modules ... all that has snd_seq*, snd_*_oss and snd_pcm ... example:

#lsmod | grep -e '_oss|_seq'

#rmmod [one module name]

Frankly, I'm not a fan of Java and I have no idea how Java can bork like this ... a little googling does seem to indicate a problematic library ...


Rgds
Back to top
View user's profile Send_private_message 
WB7ODYFred


Joined: 13 Dec 2008
Posts: 104
Location: Oregon & Washington

PostPosted: Sat 13 Feb 2010, 20:26    Post_subject: Recreate /dev/dsp
Sub_title: Getting USB Headset Audio to work again
 

mknod /dev/dsp 14 3
mknod /dev/dsp1 14 19
mknod /dev/dsp2 14 35
mknod /dev/dsp3 14 51

chmod 777 /dev/dsp*

if needed mknod /dev/mixer 14 0
chmod 777 /dev/mixer

Fora USB Headset audio setup
rmmod snd-usb-audio
modprobe snd-usb-audio

Then try to play audio using the alsaplayer or vlc or gzine

vi /etc/modprobe.conf
# --- ALSACONF version 1.0.22 ---
alias snd-card-0 snd-usb-audio
alias sound-slot-0 snd-usb-audio
alias snd-card-1 snd-es1938
alias sound-slot-1 snd-es1938

/etc/rc.d/rc.alsa status
/etc/rc.d/rc.alsa stop
/etc/rc.d/rc.alsa start
/etc/rc.d/rc.alsa status


I have an ess esonic sound chip es1938 in my PC an plugged in a USB Headset for my audio use
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0668s ][ Queries: 12 (0.0261s) ][ GZIP on ]