Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 02:28
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Suggestions
TEA editor
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Tue 21 Jun 2005, 13:06    Post_subject:  TEA editor  

TEA doesn't work properly with Puppy's GTK 2.2 ... but it might work if Puppy upgrades to GTK 2.4

(it almost works with 2.2 ... it crashes if you open an Open or Save As window)

http://tea.linux.kiev.ua/

http://tea.linux.kiev.ua/downloads.html
The latest stable release (ver. 10.0) - 367 kbytes
RPM's for Fedora - tea-10.0-0.fc3.i586.rpm (390 Kb)

(i renamed ispell.h or aspell.h when i compiled it, so it would compile without spelling support, because Puppy doesn't have ispell)
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Wed 22 Jun 2005, 06:52    Post_subject:  

Yes, thanks for the suggestion.
Pup 1.0.4 will have GTK 2.4.0, so I'll go take a look at TEA
-- do recall that problem with the GTK version when I last looked,
and I tried an old version but it had problems.

Interesting, I'm running Puppy with GTK 2.4 right now, and all the GTK2 apps that were compiled on Mandrake with GTK 2.2, are all working okay ... no complaints about missing symbols or anything.
That's Abiword, Mozilla, Dia, Sodipodi, Leafpad ...so, I'm not in any hurry to recompile them on Vector.
Back to top
View user's profile Send_private_message Visit_website 
papaschtroumpf


Joined: 17 Jun 2005
Posts: 250

PostPosted: Wed 22 Jun 2005, 22:19    Post_subject:  

The news item is unclear: is TEA available as a pupget for 1.0.3 or will it only be available for 1.0.4?

I'm still looking for a good alternative to Beaver for when leafpad is "not enough"

includes Morse Code Translator and ugly syntax highlighting, what else could you want Very Happy

_________________
Mandriva LE 2005 user and puppy newbie
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Thu 23 Jun 2005, 05:42    Post_subject:  

papaschtroumpf wrote:
The news item is unclear: is TEA available as a pupget for 1.0.3 or will it only be available for 1.0.4?


TEA will be available for 1.0.4.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Taking the Puppy out for a walk » Suggestions
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0413s ][ Queries: 12 (0.0028s) ][ GZIP on ]