Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 03 Aug 2015, 21:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Would someone make a .PET package of Minitube?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Wed 27 Jan 2010, 18:43    Post subject:  Would someone make a .PET package of Minitube?
Subject description: (With all its dependencies) for Puppy 4.2 and Quirky
 

Can anyone make a working .PET package of this app (complete package including all dependencies):

http://flavio.tordini.org/minitube



It needs Qt >= 4.5, Phonon and GStreamer

Preferably a .PET package that works on Puppy 4.2 / Turbopup Xtreme (k2.6.25.16)

I don't like to install a bloated distro (e.g. Ubuntu) just for this awesome little app.
I prefer to use Puppy Smile

_________________
Turbopup Tech Support
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 11069

PostPosted: Wed 27 Jan 2010, 21:01    Post subject:  

Yeah but once you spend a week adding all the dependancies it will be as bloated as Ubuntu.....
Back to top
View user's profile Send private message 
GrumpyWolfe


Joined: 26 Nov 2006
Posts: 496

PostPosted: Thu 28 Jan 2010, 10:32    Post subject:  

Hi panzerpuppy

I looked into putting this into a package for you but I am not that good at compiling and get a lot of my libs from the Debian libs. Right now the OT4.5 is just not in common use and that would mean that all the libs needed by the QT4.5 would have to be compiled against QT4.5 that would be a lot of work so you may have to what a bit no this one.

update

Just an update I did manage to get qt4.5.3 and have even been able to get it to run to some degree just one problem remains and if someone know an answer I may have it working soon. It seams that QT 4.5.3 and libphonon do not want to work together. Have to get some sleep so can work tonight and will look for the QT 4.5.0 libs the are suppose to work but did not find them just yes.

_________________
Live and Let Live

Acer Aspire One N450 1.66GHz

MyWolfe at Sourceforge
MyWolfe Blog
MyWolfe Groups
Back to top
View user's profile Send private message Visit poster's website 
sindi

Joined: 16 Aug 2009
Posts: 469

PostPosted: Fri 31 Jul 2015, 22:03    Post subject: Minitube 2.4 - package for puppy please  

I downloaded the binary from the author's site then attempted to add all the required libraries. libphonon 4, and a phonon-backend. I tried vlc, which required a vlc library, and did not work. I tried the xine backend, which required a libxine.so.1 which I could not even find. I downloaded debs (dpkg-deb -x filename . to extract[/url] and rpms (click to extract, and choose the file you want). Minitube loads but will not play videos.

Tahr 6.02. I found minitube packages for older Ubuntus. You need version 2.4 to deal with the latest changes in Youtube.
I also gave up on smtube. gkt-youtube-viewer got broken by Youtube in April.

Is there any puppy package of any post-April-2015 standalone youtube player? I am resorting to a search engine, and the URL after youtube-dl and playing with mplayer (in X or framebuffer console). Tahr lacks mplayer but I can copy it from lupu. My Pentium III can play at 480p that way but a combination search-engine and player would be helpful.

movgrab also broke. It used to work with a 1999 linux.

youtube-dl -F http://.... to list available modes, choose a mode (flv, mp4)
youtube-dl -f 36 (for mode 36) .....[/url]
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 4004
Location: Everybody knows this is nowhere...

PostPosted: Sat 01 Aug 2015, 00:27    Post subject:  

siindi, libxine.so.1 is (or should be!) a symlink to libxine.so.[version] -- you need a libxine package... make the symlink (relative, always!) if the package does not make it for you...
_________________

Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 471
Location: N.E. USA

PostPosted: Sat 01 Aug 2015, 05:38    Post subject:  

I also highly doubt you will get this up and running. You should check the Author's forum at the website you provided. Google has limited BW... resulting in needing a googleapi. And no one to the best of my knowledge has asked for a dependency list.

Yeah the D/L is small 3/4 Mb but its dependency hell neediing an api. GL

_________________
Linux user #498913
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 469

PostPosted: Yesterday, at 19:29    Post subject: phonon backends  

I tried vlc first because it was already on the Tahr menu.
You can use also xine, gstreamer, or mplayer, says minitube site (or one of the links I was following).

I would prefer to use mplayer in lupu, not vlc or xine.
The site where I was downloading from did not have an mplayer phonon-backend. Does this simply refer to the mplayer binary and libraries?

I don't understand some of the vocabulary in people's replies - BW? googleapi?

is smtube easier to get going? It is used in Windows with smplayer/mplayer and I am familiar with the keyboard controls.

All I really want is some sort of youtube search engine, preferably command-line. No thumbnails of results.
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 5322
Location: World_Hub

PostPosted: Yesterday, at 19:44    Post subject:  

YT's a moving target. See here..
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0658s ][ Queries: 12 (0.0096s) ][ GZIP on ]