Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Aug 2014, 06:50
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Canon MP/MX/MG Scanner Drivers - Updated 2014
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 8 Posts_count   Goto page: 1, 2, 3, ..., 6, 7, 8 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9027
Location: Stratford, Ontario

PostPosted: Fri 22 May 2009, 09:12    Post_subject:  Canon MP/MX/MG Scanner Drivers - Updated 2014  

Update: When this thread was started, it applied to Canon's original MP series. These scanners worked with SANE, so no vendor driver package was required.

But most of the recent MX and MG models are not SANE-compatible. They require their own drivers and use Canon's ScangearMP scanning program.

In the following pages, you will find ready-made PETs for some models. To install a scanner on your own, go to the Canon printer section and read about candi.

Please provide feedback.

---------------------------------------

The scanning units in Canon multi-purpose printers need two things: libusb-1.0 and the correct SANE backend.

All recent Puppies have libusb-1.0. Look for it in /usr/lib. But the Puppy 4 series and some early Quirky/Wary/Lupu versions do not. For those, install either the libusb_4xx-1.0.pet or libusb_5xx-1.0.pet attached below.

--------------------------

The SANE scanner driver package in Puppy uses a backend for Canon called pixma. Look for it in /usr/lib/sane. You can see the list of supported devices here.

Some early Canon models like the MP160 will work OOTB with pixma-1.0.20. So you can scan using Xsane or Peasyscan without installing any additional drivers.

But newer MP and MX models need pixma-1.0.21 or higher. (Lupu has 1.0.20. Slacko has 1.0.21.) Attached below are packages for 4-series and 5-series Puppies. For many users, pixma_backend_5xx-1.0.23.pet should be enough to get their scanner working.

-------------------

Some Canon models, like the MG series, do NOT work with the SANE driver. But they can use Canon's own scanning program called scangearmp. Each scangearmp setup requires several packages. For example, an MP490 needs the scangearmp_490series-1.40.pet and the matching scangearmp_common-1.40.pet. Older Puppies also need libusb-1.0.

Scangearmp has a GIMP plugin. Some models, like the MP250 and MP490, require the libgimp2.0-2.6.8.pet. However, if you already have Gimp installed, do NOT install it. This avoids a possible conflict with your version of libgimp.

Please note that some scangear-common packages posted farther down this thread have eliminated the libgimp requirement.

-------------------------------

For information about running your Canon scanner across a network, read here.

-------------------------------
pixma_backend_5xx-1.0.23.pet
Description 
pet

 Download 
Filename  pixma_backend_5xx-1.0.23.pet 
Filesize  147.68 KB 
Downloaded  769 Time(s) 
scangearmp_common-1.40.pet
Description 
pet

 Download 
Filename  scangearmp_common-1.40.pet 
Filesize  240.85 KB 
Downloaded  698 Time(s) 
pixma_backend_4xx-1.0.21.pet
Description 
pet

 Download 
Filename  pixma_backend_4xx-1.0.21.pet 
Filesize  55.32 KB 
Downloaded  622 Time(s) 
libusb_5xx-1.0.pet
Description 
pet

 Download 
Filename  libusb_5xx-1.0.pet 
Filesize  33.41 KB 
Downloaded  710 Time(s) 
libusb_4xx-1.0.pet
Description 
pet

 Download 
Filename  libusb_4xx-1.0.pet 
Filesize  30.53 KB 
Downloaded  619 Time(s) 
scangearmp-locale-1.40.pet
Description 
pet

 Download 
Filename  scangearmp-locale-1.40.pet 
Filesize  68.39 KB 
Downloaded  1216 Time(s) 
scangearmp-490series-1.40.pet
Description 
pet

 Download 
Filename  scangearmp-490series-1.40.pet 
Filesize  262.83 KB 
Downloaded  1112 Time(s) 
scangearmp-250series-1.40.pet
Description 
pet

 Download 
Filename  scangearmp-250series-1.40.pet 
Filesize  263.5 KB 
Downloaded  1189 Time(s) 
libgimp2.0-2.6.8.pet
Description 
pet

 Download 
Filename  libgimp2.0-2.6.8.pet 
Filesize  538.74 KB 
Downloaded  1307 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1002
Location: South of Belgium

PostPosted: Mon 25 May 2009, 03:13    Post_subject:  

Hi rcsrn51,
again, many thanks for your efforts and time !
my MP160 runs on sane at now !
Cheers
Charlie

outside post subject:
I also have been looking for running the scanner...(maybe am I dreaming?..never knows!) ...with empty ink cartridges ...but as now no result (aargh!..damned chips!) I have bought and installed new ones to get use of it!
(I should better have bought a separate scanner)
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9027
Location: Stratford, Ontario

PostPosted: Mon 25 May 2009, 08:38    Post_subject:  

Quote:
also have been looking for running the scanner...(maybe am I dreaming?..never knows!) ...with empty ink cartridges ...but as now no result (aargh!..damned chips!) I have bought and installed new ones to get use of it!


So you can't run the scanner part of your printer once it runs out of ink? Unbelievable!

I was thinking of buying some used Canon all-in-ones for testing purposes on the scanners, but I guess there is no point in doing that.
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1002
Location: South of Belgium

PostPosted: Wed 12 Aug 2009, 03:35    Post_subject:
Sub_title: Canon MP160 on Puppy 4.1.2
 

Hi rcrsn51,
...reinstalling my system,
I installed both "...1.10..pet" and the "pixma-mp150.pet", these last one to get /usr/local/bin/pixmascan installed.
Before installing "pixma-mp150.pet", I also had to manually insert "canon_mfp" into dll.conf.
Works nice on toutou412 (french translation of puppy412)
Thanks
Cheers
Charlie
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1002
Location: South of Belgium

PostPosted: Wed 09 Sep 2009, 02:59    Post_subject:
Sub_title: How to setup XSane for black and white saved copy ?
 

Hi rcrsn51 !
Would you have any idea about how to setup XSane for black and white saved copy ?
" grey " scanmode leads indeed to rather huge MBytes-sized files, whereas B&W setting needs only a few 100KB-sized.
Cheers
Charlie
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6678
Location: lisbon

PostPosted: Wed 09 Sep 2009, 05:15    Post_subject:  

Charlie,

forget my post...I must have been in zombie mode, as I see you're not after gray scan, but B&W.
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1002
Location: South of Belgium

PostPosted: Sun 07 Feb 2010, 02:53    Post_subject:
Sub_title: using MP160 on puppy 4.3.1
 

Hi,
now using puppy 4.3.1
libsane-pixma.so.1.0.20 is already installed in usr/lib/sane on a fresh puppy 4.3.1;
I have only installed pixma-mp150.pet
canon_mfp is present in dll.conf
Sane freezes till I get now this message:
"I/O error input"

nb: I tried also installing the scangearmp_common-1.10-1.i386.pet and modified the symlink to get libsane-pixma.so.1.0.19 activated; but in this case sane answers "there is no USB peripheral connected and "libsub" seems to be outdated.
Back to libsane-pixma.so.1.0.20 gets the MP160 again recognized but not working...see above paragraph.

edited:
I went to accidentaly erase /usr/lib/sane/libsane-canon_mfp.so...ooops!
I reinstalled scangearmp_common-1.10-1.i386.pet to and modify the link to activate libsane-pixma.so.1.0.19. Restarted X and now the SCANNER WORKS!
Sorry if all this looks a bit confused!

thanks in advance for any advice
Cheers, charlie
Back to top
View user's profile Send_private_message 
ronaldg3

Joined: 02 Apr 2009
Posts: 2

PostPosted: Wed 14 Apr 2010, 12:09    Post_subject: MP210 on Puppy421  

Thanks for the pets rcsrn51, all systems are now GO whereas before I could not get the darn thing to work.
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1002
Location: South of Belgium

PostPosted: Mon 10 May 2010, 07:34    Post_subject:
Sub_title: « I/O error while reading on peripheral »
 

Hi rcrsn51,
-Using now turbopup_Xtreme-v1.0 (= pup420 derivative) frugall-

I had like tu use Canon MP160 (usb connected) both scanner and printer features.
I have installed:
mp150_sane-0.14.4.pet and
scangearmp_common-1.10-1.i386.pet

and got rid of cups1.4b2 using
cups-1.3.9-i486.pet and
cupsd.conf.zip
according to your instructions (many thanks to you and Patriot!)

1.Printer : works fine

2.Scanner :
2.1. works only from command line like this one:
Code:
pixmascan -m gray -r 150 -g 1.2 -p A4 -1 -W -f tiff,p file.tif


2.2. From Xsane gui: I cannot get anything to save; when scanning is finished, the following message is displayed:
Code:
 I/O error while reading on peripheral

Only the »preview» works.

Before installing the printer, the scanner was working OK from Xsane gui.

I have searched the forum for relevant posts about this but found none.

Thanks for any suggestion

Cheers, Charlie
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9027
Location: Stratford, Ontario

PostPosted: Mon 10 May 2010, 09:47    Post_subject:
Sub_title: « I/O error while reading on peripheral »
 

charlie6 wrote:
Before installing the printer, the scanner was working OK from Xsane gui.

Hmmmm (to quote Patriot). The CUPS 1.3.x installers also modify the permissions of USB printer devices. Maybe that's what has caused your scanner to fail after upgrading CUPS.

You might be stuck using the command line.

My HP scanner works with the CUPS upgrade, so it's not a problem for everyone.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Sun 18 Jul 2010, 23:38    Post_subject:  

Thankyou, thankyou, thankyou Mr rcrsn51kind sir!

Got the mp490 printing and scanning way faster than in windows Smile (in luci-213)

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9027
Location: Stratford, Ontario

PostPosted: Mon 19 Jul 2010, 00:03    Post_subject:  

Glad to help.
Back to top
View user's profile Send_private_message 
jockjunior

Joined: 29 Jan 2008
Posts: 145
Location: Lancashire,U.K.

PostPosted: Wed 28 Jul 2010, 09:11    Post_subject:  

Hi,
jusr installed my mp250 using Patriot's pets. Using Puppy 5.01 and with the quirky backend installed can access the scanner with xsane but scangear refuses to se it.Have uninstalled the scangearmp-1.40.pet and re installed it. The scangear entry shows up in Gimp 2.6 but cant find the scanner.

Am I doing som'at wrong?
Jock
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9027
Location: Stratford, Ontario

PostPosted: Wed 28 Jul 2010, 09:42    Post_subject:  

Open a terminal and type the command
Code:
scangearmp

Do you get any error messages?
Back to top
View user's profile Send_private_message 
jockjunior

Joined: 29 Jan 2008
Posts: 145
Location: Lancashire,U.K.

PostPosted: Thu 29 Jul 2010, 08:19    Post_subject:  

sorry for delay in replying, proud owner of 2 fractured elbows and its slowing me up.

error message cannot find available scanners and gtk warning unable to locate theme clearlooks

cheers

Jock
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 8 Posts_count   Goto page: 1, 2, 3, ..., 6, 7, 8 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0855s ][ Queries: 13 (0.0051s) ][ GZIP on ]