Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 08:11
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Lib, Libs, Libraries Get Them Hot !!! Data base
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 8 [119 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
Q5sys


Joined: 11 Dec 2008
Posts: 1048

PostPosted: Sun 13 Dec 2009, 17:51    Post subject:  

ttuuxxx wrote:
I'm uploading the libs right now, this time they are tar.gz and that way the system links don't get broken, another user tar.gz them all like a year ago, which will save a lot of server space and makes it quick to upload 583 packages, about 30 mins worth of uploads
ttuuxxx


You sir are a gentleman and a scholar. Smile
Appreciate the effort, and im sure im not the only one.
Back to top
View user's profile Send private message 
sindi

Joined: 16 Aug 2009
Posts: 395

PostPosted: Mon 25 Jan 2010, 11:01    Post subject: Include link to libraries in puppy package manager please  

Inkscape (Pet-4 package) wanted python installed. There is no Python pet package (2 3 or 4). I finally found reference to the extra libraries at the forum. Do these libraries work with Puppy 4.31?
(Also fotoxx wants printoxx to print with - where do I find it?).
Back to top
View user's profile Send private message 
AF Branden


Joined: 15 Sep 2009
Posts: 175
Location: United States, WA

PostPosted: Thu 04 Mar 2010, 07:46    Post subject:  

I need the pango library I think, I installed
frozen-bubble-2.2.0-i686-1as.pet and the
only lib missing is libSDL_Pango.so.1, any
ideas where I can get this lib?

I believe I need SDL_Pango-0.1.2-i486.pet but cannot locate it.

Nevermind, I found it here:
http://www.puppyrus.org/pub/%23users/azlk/SDL/

All I had to do was google for it.

_________________

Back to top
View user's profile Send private message 
AF Branden


Joined: 15 Sep 2009
Posts: 175
Location: United States, WA

PostPosted: Thu 04 Mar 2010, 09:34    Post subject:  

Now I need SDL_ttf-2.0.9-i386.pet to play S.C.O.U.R.G.E,
googling didn't work this time Sad

The source is here if somebody knows how to compile it and .pet it, not sure how easy that is: http://www.libsdl.org/projects/SDL_ttf/

Edit: nevermind, found it

_________________

Back to top
View user's profile Send private message 
ReverendHolmes

Joined: 17 Mar 2010
Posts: 1

PostPosted: Wed 17 Mar 2010, 04:16    Post subject:  

I am a complete newb. I checked the link posted on the first page and the following libs seem to be missing:
libmpcdec.so.3
libts-0.0.so.0
libsqlite3.so.0

Any help would be greatly appreciated.
Back to top
View user's profile Send private message 
AF Branden


Joined: 15 Sep 2009
Posts: 175
Location: United States, WA

PostPosted: Wed 17 Mar 2010, 05:49    Post subject:  

The first one is there, it is called libmpcdec-3.1.1.tar.gz
The third one is also there, it is called libsqlite3-0.8.6.tar.gz

I'm not sure about the second one though.

_________________

Back to top
View user's profile Send private message 
amsk98

Joined: 20 Feb 2010
Posts: 23

PostPosted: Thu 01 Apr 2010, 01:30    Post subject:    

how can i install pet file
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Thu 01 Apr 2010, 06:15    Post subject: missing libs libxcb-xxxxx  

When using the pidgin 2.6.1 sfs in my frugal install (lucid 001-003 and quirky 013, I get following libs missing.
Code:
libxcb-aux.so.0
libxcb-event.so.1
libxcb-atom.so.1
I don't find them in ttuuxxx libs.
Where else can I find them?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Reaperz
Guest


PostPosted: Wed 14 Apr 2010, 07:45    Post subject:  

I can't connect to the internet in Linux. (No drivers)

Is there a way I can access the link to the libs through Windows?
Back to top
rys61

Joined: 07 May 2009
Posts: 8

PostPosted: Mon 07 Jun 2010, 09:51    Post subject: gconv libs for CP437 and CP850  

I need to use iconv for converting from text files using CP437 and CP850. It seems the directory /usr/lib/gconv/ has been minimized and doesn't contain the needed files IBM437.so and IBM850.so. I am using 4.1.2 - libc used is libc-2.6.1.so. Are the complete set of .so files available anywhere (if someone needs some other conversion someday)?

Ronny
Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Mon 07 Jun 2010, 12:23    Post subject: Re: missing libs libxcb-xxxxx  

Béèm wrote:
When using the pidgin 2.6.1 sfs in my frugal install (lucid 001-003 and quirky 013, I get following libs missing.
Code:
libxcb-aux.so.0
libxcb-event.so.1
libxcb-atom.so.1
I don't find them in ttuuxxx libs.
Where else can I find them?
Yes I could do with them to.
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4367
Location: Southeast Georgia, USA

PostPosted: Wed 23 Jun 2010, 23:42    Post subject:  

I am in Wary 030 and used Puppy Package Manager to load Gimp.

It came up short a couple of library files:

/usr/local/lib/gimp/2.0/plug-ins/file-wmf missing

libwmf-0.2.so.7
libwmflite-0.2.so.7

I downloaded them from here (thanks!) and then copied them to /usr/local/lib/

GIMP still fails to show in Menu even after an X restart and from Console I still get the same missing library error.

Questions:

1. Do I need to somehow manually link file-wmf to these libraries?
2. How, please?
3. Why were these missing from Gimp?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Sat 26 Jun 2010, 22:59    Post subject:  

edoc


hmm west Florida ? I spent 25 years in Central Florida in " kow town" if you know what that means





Quote:

libwmf-0.2.so.7
libwmflite-0.2.so.7

I downloaded them from here (thanks!) and then copied them to /usr/local/lib/

GIMP still fails to show in Menu even after an X restart and from Console I still get the same missing library error.




I posted once in this thread explaining that packages are needed not stray libs
anyway this package will fill your lib request
if nothing else is broken

http://carroll.cac.psu.edu/pub/linux/distributions/slackware/slackware-12.2/slackware/l/libwmf-0.2.8.4-i486-3.tgz

contains and the other support files needed
libwmf-0.2.so.7.1.0
libwmf.la
libwmflite-0.2.so.7.0.1
libwmflite.la



this makes the symlinks for you
Code:


( cd usr/lib ; rm -rf libwmf.so )
( cd usr/lib ; ln -sf libwmf-0.2.so.7.1.0 libwmf.so )
( cd usr/lib ; rm -rf libwmf-0.2.so.7 )
( cd usr/lib ; ln -sf libwmf-0.2.so.7.1.0 libwmf-0.2.so.7 )
( cd usr/lib ; rm -rf libwmflite.so )
( cd usr/lib ; ln -sf libwmflite-0.2.so.7.0.1 libwmflite.so )
( cd usr/lib ; rm -rf libwmflite-0.2.so.7 )
( cd usr/lib ; ln -sf libwmflite-0.2.so.7.0.1 libwmflite-0.2.so.7 )



Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7797
Location: qld

PostPosted: Sat 26 Jun 2010, 23:15    Post subject:  

http://packages.ubuntu.com/en/lucid/libs/

Béèm and abushcrafter,

If you are chasing Lucid compatible libs then the link above is very good place to start.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4367
Location: Southeast Georgia, USA

PostPosted: Sat 26 Jun 2010, 23:33    Post subject:  

Cool! Thanks!

Will test this out tomorrow and report back.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 6 of 8 [119 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0871s ][ Queries: 13 (0.0063s) ][ GZIP on ]