Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Jul 2014, 16:13
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
Webcam Logitech USB on Puppy 4.2.1
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Henk-Jan

Joined: 15 Apr 2010
Posts: 11
Location: Amsterdam

PostPosted: Thu 15 Apr 2010, 07:57    Post_subject:  Webcam Logitech USB on Puppy 4.2.1
Sub_title: USB problem with camera
 

The USB-bus does not recognize the Logitech C120 cam.
However another USB-device such as a USB-stick is fully recognized.

HardInfo says: OHCI Host Controller - Unknown USB 2.00 Device (class 239)

dmesg -l |grep uvc says:
uvcvideo: Found UVC 1.00 device <unnamed> (046d:080f)
uvcvideo: No valid video chain found

Kernel: Linux 2.6.30.5

Who can help?
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Thu 15 Apr 2010, 09:20    Post_subject:  

Your Logitech C200 requires a very recent version of the uvcvideo driver, available with the latest kernel 2.6.33.
The most recent Quirky or Wary test release should have this driver.
Back to top
View user's profile Send_private_message 
Henk-Jan

Joined: 15 Apr 2010
Posts: 11
Location: Amsterdam

PostPosted: Fri 16 Apr 2010, 02:47    Post_subject:  

Thanks, in Quicky I do not see the 'no video chain' error message. Unfortunately there is another one: I cannot connect via the wireless card.

After selecting the driver, the card does not become active.

The same for Wary
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Fri 16 Apr 2010, 03:27    Post_subject:  

EDIT
Modified version of uvcvideo driver for Puppy 4.3.x now removed.

Edited_time_total
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Fri 16 Apr 2010, 03:31    Post_subject:  

Henk-Jan wrote:
in Quirky
...
I cannot connect via the wireless card.

Details? Wifi card - manufacturer, model, revision?

Henk-Jan wrote:
After selecting the driver, the card does not become active.

Which driver, specifically?
Back to top
View user's profile Send_private_message 
Henk-Jan

Joined: 15 Apr 2010
Posts: 11
Location: Amsterdam

PostPosted: Fri 16 Apr 2010, 05:04    Post_subject:  

Quicky does not do anything with the airo_cs driver for the Cisco Aironet 350 pcmcia.

In puppy 4.2.1 everything was fine. No problems with the Network Whizzard.

Thanks, HJ.
Back to top
View user's profile Send_private_message 
Henk-Jan

Joined: 15 Apr 2010
Posts: 11
Location: Amsterdam

PostPosted: Fri 16 Apr 2010, 05:39    Post_subject:  

'No valid video chain found'

And: 'OHCI Host Controller - Unknown USB 2.00 Device (class 239).'

I think something goes wrong at the USB.
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Sat 17 Apr 2010, 05:45    Post_subject:  

OK, it seems that hacked device detection is not good enough, your device needs updated driver code.
I have just deleted the test driver for 4.3.x in the earlier post.

Henk-Jan wrote:
Quirky does not do anything with the airo_cs driver for the Cisco Aironet 350 pcmcia.

There's nothing exotic about the old airo_cs driver, you should diagnose the problem.
First check that the PCMCIA system recognises your device with these 2 commands -
Code:
pccardctl status
pccardctl ident

If your wifi device is listed, run this command
Code:
dmesg

and look for information about how the airo_cs driver loaded.

If you cannot see your device listed, refer to this information about how to reset the Cardbus interface -
http://www.murga-linux.com/puppy/viewtopic.php?p=31707#31707
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8906
Location: Stratford, Ontario

PostPosted: Sat 17 Apr 2010, 10:36    Post_subject:  

Quote:
In puppy 4.2.1 everything was fine. No problems with the Network Whizzard.

Are we now starting to see situations where users assume that Quirky is a general-purpose Puppy when it really isn't?
Back to top
View user's profile Send_private_message 
Henk-Jan

Joined: 15 Apr 2010
Posts: 11
Location: Amsterdam

PostPosted: Sat 17 Apr 2010, 13:37    Post_subject:  

Thanks for your help so far.
Most important now is the get the cam working, if it can.

I leave it now for a while.
Back to top
View user's profile Send_private_message 
jairomacon

Joined: 21 Apr 2010
Posts: 3

PostPosted: Fri 23 Apr 2010, 14:24    Post_subject:  

As the Logitech C120 cam provides the Hi-Speed USB 2.0 certified.The standard drivers are provided by the Operating System and will only provide minimal camera support whith the USB. Your device needs update drivers to have compatibility with the puppy Linux.and For updates on compatibility issues and driver support, please continue to check the Support C120.
_________________
Where there is will there is way.
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Fri 23 Apr 2010, 23:59    Post_subject:  

Wha?

jairomacon wrote:
Your device needs update drivers to have compatibility with the puppy Linux.

Which drivers? As we have been discussing, the only driver for the Logitech C120 compatible under Linux is the uvcvideo kernel module,
and as Henk-Jan has indicated, albeit unclearly, this driver appears to work under the 2.6.33 kernel -
Henk-Jan wrote:
Thanks, in Quirky I do not see the 'no video chain' error message.


jairomacon wrote:
For updates on compatibility issues and driver support, please continue to check the Support C120.

Where? Who? What are you talking about? The Logitech website? That's no help, they only provide Windows drivers.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0636s ][ Queries: 12 (0.0037s) ][ GZIP on ]