Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 21:33
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Problem with N64 games in Puppy arcade
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
bowserevilking

Joined: 11 Jul 2009
Posts: 43

PostPosted: Thu 22 Apr 2010, 20:04    Post subject:  Problem with N64 games in Puppy arcade  

I recently got Puppy Arcade 7, and LOVE it. But configuring everything is a pain. For example: In mupen64plus, whenever I start up any rom, it says "The core thread crashed with a SIGSEGV fault. This means it tried to access protected memory. Maybe you have the wrong ucode set for one of the plugins." I have tried fiddling with it's configuration but can't find any way to get it to work. I know it runs in root, so I don't think that's a problem. Any help?

Also, I can't find a way to adjust the volume in Puppy Arcade. I need it for some games, you know?
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1724
Location: Out wandering... maybe.

PostPosted: Thu 22 Apr 2010, 22:48    Post subject:  

You probably should've posted this in the Puppy Arcade 7 topic - that way, sc0ttman would have a better chance of seeing it. Smile

I don't know if PA7 has it installed by default, but do you have OpenGL support installed? (sc0ttman would probably be able to better answer that, though.) I believe the N64 and PSX emulators require it. Also, are you certain your game images are correct?

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2363
Location: UK

PostPosted: Fri 23 Apr 2010, 01:31    Post subject:  

N64 requires OpenGL to run...

The error message you are receiving is because you don't have OpenGL enabled..
Enable it by installing the correct drivers for your gfx card..

There's a long list of drivers and links in the puppy arcade thread and in the help file in /root

BTW, PSX does not require OpenGL..

Adjust the volume using the sgmixer in Menu->Multimedia

And next time, if you post in the Puppy Arcade thread, I'll find this faster...

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
bowserevilking

Joined: 11 Jul 2009
Posts: 43

PostPosted: Fri 23 Apr 2010, 16:08    Post subject:  

Thanks, sc0ttman, next time I'll post in the Puppy Arcade thread.Embarassed I'm afraid I don't know which PET to install. I have an integrated VIA ProSavage8, apparently. Thanks in advance.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0403s ][ Queries: 12 (0.0059s) ][ GZIP on ]