Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 23:51
All times are UTC - 4
 Forum index » Off-Topic Area » Programming
wget failing in script [solved]
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 11 Oct 2008
Posts: 7956
Location: qld

PostPosted: Sat 24 Apr 2010, 00:21    Post_subject:  wget failing in script [solved]
Sub_title: only for some

Hi Any wget gurus out there?

I have written a script which grabs pets for Lucid Puppy. It mostly works but forum member aarf has reported it fails grabbing a file from puppylinux.asia, Caneri's site. Aarf has tried a way suggested by Eric but that failed too. Perplexing.

Here is the discussion http://www.murga-linux.com/puppy/viewtopic.php?p=412560#412560 and for several posts on the next 2 pages.

Note the weird IP that aarf is getting from puppylinux.asia, nothing like the one I get. Works fine for me.

Little help?


Woof Mailing List | keep the faith Cool |

Back to top
View user's profile Send_private_message Visit_website 
Official Crustacean

Joined: 04 May 2005
Posts: 15121
Location: Paradox Realm

PostPosted: Sat 24 Apr 2010, 01:04    Post_subject:  

there may be a difference between busybox wget

and the full version
Not sure which is being used?

Either modify existing to busybox wget
or install full version

Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 

Joined: 03 Apr 2007
Posts: 3422
Location: Oregon

PostPosted: Sun 25 Apr 2010, 12:10    Post_subject:  

It might not be a script problem, but an internet problem.
As to what I am trying to say, let me give you an example.
I try to access an internet site from a link in my browser.
I see a message of "looking up blah blah" with blah blah being the site.
Half the time anymore, I then get a page of site not found with a try again message box.
Since wget does not return that type of error messages that could be the problem in itself.
My internet connection comes and goes and I am NOT talking about it being a Puppy problem.
It is a service provider problem with them not wanting to make sure the customer has a consistently stable line connection.
I have my DSL modem where I can see it and I can watch the connection degrade, disappear, and return.
I have had download speeds of 20kps when I am paying for a 1.5mbs line.
I also have a temporary phone line, replacing a supposedly bad buried one that is laying on top of the ground that Quest was supposed to bury and they have not now in over 6 months.
My download speeds go from nonexistent to 20kps to 1600kps and that stinks.
I can be logged on to the forum, go to post a messsage and am told I am not logged in even though I had just logged in.
So those of you with good internet connections and providers be thankful.
Back to top
View user's profile Send_private_message 

Joined: 04 Sep 2007
Posts: 1580
Location: Canada

PostPosted: Sun 25 Apr 2010, 14:04    Post_subject:  

I googled ip and found a problem with ipv6 with this solution


Connecting can be solved in two ways.

First GO to Network settings and remove IPv6 protocol and you can start surfing.

Secondly for MOZILLA Type in address bar as about:config

and find network.dns.disableIPv6 set the value to TRUE by double click..

This has at least worked for me. HOpe it works for you also

The link is http://www.dslreports.com/forum/remark,14757298

There are also mentions of the being assigned to the Asian networks.

Wget works here....hth EDIT: I added a wget howto in html format.


@Micko....I use the -np (no parent) and --cut-dirs="X" switches most of the time...it may be able to replace "root" in your lines but I'm not great with wget and fall back on what works for me. Thombh knew wget well but your usage may need your setup...not sure.

Filename  wget.tar.gz 
Filesize  67.12 KB 
Downloaded  324 Time(s) 

Be not afraid to grow slowly, only be afraid of standing still.
Chinese Proverb

Back to top
View user's profile Send_private_message 

Joined: 11 Oct 2008
Posts: 7956
Location: qld

PostPosted: Sun 25 Apr 2010, 20:15    Post_subject:  


Thanks for that.

So it looks like an IP6 issue. I added -4 (explained in the manual, Wink ) and tried a few small downloads and no problems. I wasn't getting a problem anyway, but it may well solve aarf's problem. I'll add it to the program, shouldn't break anything.

It's academic really, as .asia wont be used in the final of lupu, everything official will be available from ibiblio.

8-bit, I'm hearing you there mate.. mostly my con is superfast, but some days it's as flakey as a bowl of cornflakes. One problem here in Australia is that one telco owns all the phonelines, we are at their mercy. Monopoly is not good. Wink


EDIT: Yep, the -4 option fixed it for aarf, thanks guys.

Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Off-Topic Area » Programming
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0564s ][ Queries: 13 (0.0052s) ][ GZIP on ]