Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 18:35
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
USB sound issue
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
tubeguy


Joined: 28 Aug 2009
Posts: 1326
Location: Park Ridge IL USA

PostPosted: Sat 24 Apr 2010, 17:48    Post_subject:  USB sound issue
Sub_title: Turtle Beach Audio Advantage seen but not heard
 

I've spent a few hours on this on and off, thought I would post the issue as a last resort. dpup beta 4 on Toshiba laptop, trying to use Turtle Beach Audio Advantage. Hardinfo sees the device (see attachment) but Alsa Wizard does not (see other attachment). That third line saying usb-audio is always there whether the Turtle Beach is plugged in or not.

I have tried replacing lines in /etc/modprobe.conf:

alias snd-card-0 snd-usb-audio
alias sound-slot-0 snd-usb-audio

and adding the following line to /etc/rc.d/rc.local:
modprobe snd-usb-audio

This did not help. I've had the same problem with Puppy 4.3.1 also, same exact symptoms. Should I just give up on this? I know Linux sound ain't what it should be yet, I don't think it's just a Puppy thing.
usbdevice.png
 Description   
 Filesize   49.39 KB
 Viewed   923 Time(s)

usbdevice.png

alldevices.png
 Description   
 Filesize   7.76 KB
 Viewed   1731 Time(s)

alldevices.png


_________________
Toshiba M115-S1061: PupServer |HP/Compaq D330ST: Dpup 486
Back to top
View user's profile Send_private_message Visit_website 
dialeddown

Joined: 25 Apr 2010
Posts: 20

PostPosted: Mon 26 Apr 2010, 02:30    Post_subject:  

I found this udev script to make a *.rule file in /etc/udev/rules.d.

I know it works in linux but have not tried it in puppy.

Code:
# Default to using additional (USB) sound cards when they are available.
KERNEL=="pcmC[D0-9cp]*", ACTION=="add", PROGRAM="/bin/sh -c 'K=%k; K=$${K#pcmC}; K=$${K%%D*}; echo defaults.ctl.card $$K > /etc/asound.conf; echo defaults.pcm.card $$K >>/etc/asound.conf'"
KERNEL=="pcmC[D0-9cp]*", ACTION=="remove", PROGRAM="/bin/sh -c 'echo defaults.ctl.card 0 > /etc/asound.conf; echo defaults.pcm.card 0 >>/etc/asound.conf'"


http://kitenet.net/~joey/blog/entry/random_tip_redirecting_alsa_to_usb_sound_card/

You might have to modprobe a usb audio module.
Back to top
View user's profile Send_private_message 
tubeguy


Joined: 28 Aug 2009
Posts: 1326
Location: Park Ridge IL USA

PostPosted: Mon 26 Apr 2010, 07:40    Post_subject:  

dialeddown wrote:
I found this udev script to make a *.rule file in /etc/udev/rules.d.

I know it works in linux but have not tried it in puppy.

Code:
# Default to using additional (USB) sound cards when they are available.
KERNEL=="pcmC[D0-9cp]*", ACTION=="add", PROGRAM="/bin/sh -c 'K=%k; K=$${K#pcmC}; K=$${K%%D*}; echo defaults.ctl.card $$K > /etc/asound.conf; echo defaults.pcm.card $$K >>/etc/asound.conf'"
KERNEL=="pcmC[D0-9cp]*", ACTION=="remove", PROGRAM="/bin/sh -c 'echo defaults.ctl.card 0 > /etc/asound.conf; echo defaults.pcm.card 0 >>/etc/asound.conf'"


http://kitenet.net/~joey/blog/entry/random_tip_redirecting_alsa_to_usb_sound_card/

You might have to modprobe a usb audio module.


Thanks dialeddown, will give this a try.

_________________
Toshiba M115-S1061: PupServer |HP/Compaq D330ST: Dpup 486
Back to top
View user's profile Send_private_message Visit_website 
cammy85

Joined: 27 Mar 2011
Posts: 4

PostPosted: Sun 27 Mar 2011, 14:31    Post_subject:  

dialeddown wrote:
I found this udev script to make a *.rule file in /etc/udev/rules.d.

I know it works in linux but have not tried it in puppy.

Code:
# Default to using additional (USB) sound cards when they are available.
KERNEL=="pcmC[D0-9cp]*", ACTION=="add", PROGRAM="/bin/sh -c 'K=%k; K=$${K#pcmC}; K=$${K%%D*}; echo defaults.ctl.card $$K > /etc/asound.conf; echo defaults.pcm.card $$K >>/etc/asound.conf'"
KERNEL=="pcmC[D0-9cp]*", ACTION=="remove", PROGRAM="/bin/sh -c 'echo defaults.ctl.card 0 > /etc/asound.conf; echo defaults.pcm.card 0 >>/etc/asound.conf'"


http://kitenet.net/~joey/blog/entry/random_tip_redirecting_alsa_to_usb_sound_card/

You might have to modprobe a usb audio module.


It's been almost a year since a response, but I will confirm that it does indeed work with Lucid Puppy 5.2. Thank you!!!

Yes, a modprobe is also needed after adding this script. Now if only I can get my Sentinel HASP to work with this and Wine. Smile Thanks again!!!
Back to top
View user's profile Send_private_message 
Disco Makberto

Joined: 07 Aug 2011
Posts: 135

PostPosted: Sat 16 Nov 2013, 04:46    Post_subject:  

As it pertains to this script, one important issue is left out: this script must be called "00_local.rules" (without the quotes) as explained on the external blog. One way or another, I would like to know, how do I modprobe this? I suppose I need to execute some commands, so please let me know, which commands do I need to input on the console?

Carlos Albert
D-Mak

P.S.: I am using Lucid 5.2.5 if that helps in any way.
Back to top
View user's profile Send_private_message 
Disco Makberto

Joined: 07 Aug 2011
Posts: 135

PostPosted: Thu 21 Nov 2013, 23:02    Post_subject:  

Update (on Lucid 5.25): The command to use is "modprobe snd-usb-audio" (without quotes). Likewise, "modprobe snd_usb_audio" (without quotes) seems to work as well. I am not sure why using either hypens (-) or underscores (_) makes no difference, but one way or the other does the job. On a related note, some websites mention the command "sudo modprobe snd-usb-audio" (or "sudo modprobe snd_usb_audio") [again, no quotes], but for some reason, adding sudo makes the process inoperative.

I hope this helps.

Carlos Albert
D-Mak
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2452
Location: near here

PostPosted: Sun 01 Dec 2013, 10:26    Post_subject:  

In sound modules it seems optional to hyphens - or underscores _ in the module names. Odd considering Linux makes a big deal about upper and LOWER case.

The sudo command prefix isn't really used in Puppy because you are root by default.

It means super user do <command>

In many linux distributions using a commands such as modprobe without sudo (or being the root account) with result in an errors - insufficient permissions

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
mikeb


Joined: 23 Nov 2006
Posts: 8253

PostPosted: Sun 01 Dec 2013, 11:42    Post_subject:  

For reference these particular chips CM106 / CM6206 are not fully supported in the kernels of this time. .... even it it loaded there would be no sound output only inputs. The updates can be patched in and I built a working driver for the 4.12 2.6.25.x kernel ... not 100% if 4.31 is the same kernel or not.,..but either way its available if anyone wants it..just shout.

mike
Back to top
View user's profile Send_private_message 
darkcity


Joined: 23 May 2010
Posts: 2452
Location: near here

PostPosted: Sun 01 Dec 2013, 13:19    Post_subject:  

thanks for the heads up, I've added a page on the wiki where people can record which cards are working-
http://puppylinux.org/wikka/SupportedSoundcards

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0763s ][ Queries: 13 (0.0121s) ][ GZIP on ]