Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 21 Apr 2014, 08:14
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
pygtk add-on to python
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Thu 27 Nov 2008, 10:08    Post subject:  pygtk add-on to python  

http://www.puppylinux.ca/tpp/big_bass/pygobject-2.14.1.pet
http://www.puppylinux.ca/tpp/big_bass/pycairo-1.4.12.pet
http://www.puppylinux.ca/tpp/big_bass/pygtk-2.12.pet


you need this python then add the above packages for the GUI gtk
support
http://www.murga-linux.com/puppy/viewtopic.php?t=31558


big_bass
Back to top
View user's profile Send private message 
hlpancho

Joined: 24 Mar 2009
Posts: 1

PostPosted: Tue 24 Mar 2009, 13:23    Post subject:  Meld 1.2.1 on Puppy 4.1.2 w/ pygtk  

I've been trying to get Meld 1.2.1 to run on my Puppy 4.1.2 installation, but I get the following error message:

Quote:
No module named pygtk
Meld requires pygtk 2.8.0 or higher.


After discovering this post, I installed your PET for pygtk 2.12... Unfortunately, I still get the same error message from Meld.

I'm pretty new to Puppy, Python, Gnome, etc., so any pointers would be much appreciated... Thank you!
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Fri 03 Apr 2009, 17:43    Post subject: Re: Meld 1.2.1 on Puppy 4.1.2 w/ pygtk  

hlpancho wrote:
I've been trying to get Meld 1.2.1 to run on my Puppy 4.1.2 installation, but I get the following error message:

Quote:
No module named pygtk
Meld requires pygtk 2.8.0 or higher.


After discovering this post, I installed your PET for pygtk 2.12... Unfortunately, I still get the same error message from Meld.

I'm pretty new to Puppy, Python, Gnome, etc., so any pointers would be much appreciated... Thank you!


Hey I haven't tried meld but on puppy you could install tlc/tk
and use tkdiff

that's what I use
http://www.puppylinux.ca/tpp/big_bass/TclTk-patched4py-8.4.pet

ftp://ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-3/tkdiff-4.1.3.pet

thats the same tlc/tk I patched for python
big_bass

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
patm

Joined: 21 Feb 2009
Posts: 2

PostPosted: Sun 31 Jan 2010, 14:01    Post subject:  TclTk-patched4py-8.4.pet not installing  

In the hope of finding a better file and directory comparison tool (Xfdiff drives me completely nuts..!!), I tried to install the tlc/tk and tkdiff pets linked in the previous post. tkdiff installed OK but tlc/tk did not. I got the following message from Puppy Package Manager - "Error, package TclTk-patched4py-8.4.pet failed to install"

Any ideas on what the issue might be? I'm running Puppy 4.3.1

Thanks, patm
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3285
Location: Oregon

PostPosted: Sun 31 Jan 2010, 18:05    Post subject:  

Bad download?
Back to top
View user's profile Send private message 
aragon

Joined: 15 Oct 2007
Posts: 1696
Location: Germany

PostPosted: Mon 01 Feb 2010, 05:04    Post subject: Re: TclTk-patched4py-8.4.pet not installing  

patm wrote:
In the hope of finding a better file and directory comparison tool (Xfdiff drives me completely nuts..!!)


i don't know what you're looking for but maybe you want to try xrecursediff: http://www.murga-linux.com/puppy/viewtopic.php?t=37632

aragon

_________________
PUPPY SEARCH: http://wellminded.com/puppy/pupsearch.html
Back to top
View user's profile Send private message 
raregold_armor

Joined: 17 Apr 2010
Posts: 2

PostPosted: Sun 25 Apr 2010, 01:23    Post subject:  

por que razon no puedo descargar los archivos?? me pide usuario y password!!

i can't download!! why? (creo asi se escribe jejeje)
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Sun 25 Apr 2010, 20:56    Post subject:  

raregold_armor wrote:
por que razon no puedo descargar los archivos?? me pide usuario y password!!

i can't download!! why? (creo asi se escribe jejeje)


si hay clave aqui esta
Code:
puppy
linux



o puedes usar esta link es mejor para mas cosas de python
http://www.murga-linux.com/puppy/viewtopic.php?t=41298&start=317




Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
mardon86

Joined: 23 Dec 2010
Posts: 18
Location: Bandung, Indonesia

PostPosted: Tue 04 Jan 2011, 01:35    Post subject: Need pygtk  

The pygtk download link above is broken. Need PyGTK please.. Wink
Thx.
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4134

PostPosted: Tue 04 Jan 2011, 19:34    Post subject:  

Python and Pygtk and dependencies all in one 4.5Mb pet
http://code.google.com/p/puppy-development/downloads/detail?name=Python%2B-2.6.4-i486.pet

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
mardon86

Joined: 23 Dec 2010
Posts: 18
Location: Bandung, Indonesia

PostPosted: Tue 04 Jan 2011, 21:21    Post subject:  

Ow, Thanks for that,,

I intend to install pytube. It require pygtk. It really useful app for saving flash video cache generated from an internet browser. but i can only find it in archlinux repository. is there a way to convert archlinux packages to pet ? sorry oot. Smile

Last edited by mardon86 on Tue 04 Jan 2011, 21:47; edited 1 time in total
Back to top
View user's profile Send private message 
mardon86

Joined: 23 Dec 2010
Posts: 18
Location: Bandung, Indonesia

PostPosted: Tue 04 Jan 2011, 21:23    Post subject:  

Sorry, Double post.
Back to top
View user's profile Send private message 
mardon86

Joined: 23 Dec 2010
Posts: 18
Location: Bandung, Indonesia

PostPosted: Wed 05 Jan 2011, 09:10    Post subject:  

Ahhh,, solved. I've extracted the packages then create a .pet using pet maker.
Thx... Very Happy
Back to top
View user's profile Send private message 
mcewanw

Joined: 16 Aug 2007
Posts: 2013
Location: New Zealand

PostPosted: Sat 15 Jan 2011, 02:06    Post subject: Python, txt2tags.py and RedNoteBook  

technosaurus wrote:

Python and Pygtk and dependencies all in one 4.5Mb pet
http://code.google.com/p/puppy-development/downloads/detail?name=Python%2B-2.6.4-i486.pet


I'm wanting to run the following two Python based programs in Wary 5 and in Puppy 4.3.1:

1. txt2tags from http://txt2tags.org/ which is a "document generator" for converting simple markup to various other doc formats, and

2. RedNoteBook from http://rednotebook.sourceforge.net which is a journal program which utilises txt2tags markup language.

[EDIT: The following attempts are in Wary 5. (Note that there is a http://www.portableapps.com version of RedNoteBook available for win32 and that works under wine, but I'd prefer to run the program natively on Wary].

As far as txt2tags.py is concerned:

I first installed the above Python pet and found that txt2tags.py works fine in commandline mode, but in trying to run it with its --gui option it complains that it can't find Tkinter as follows:

txt2tags: Error: Sorry. I can't run my Graphical Interface - GUI
-Check if Python Tcl/Tk module is installed (Tkinter)
. . .


I also tried Redbook:

Rednotebook won't run because it complains it needs PyYAML. I thus downloaded pyyaml.py (ver 3.09) from [url]PyYAML.com[/url] but trying to run it from a console with its installation script (setup.py):
Code:
python setup.py install

comes up with the error message:
Code:
error: invalid Python installation: unable to open /usr/include/python2.6/pyconfig.h


I couldn't find any pyconfig.h anywhere when I searched for it. I don't have a clue about Python installation unfortunately though I have a feeling that it might just be something simple needing to be added or set up. Any ideas?[/quote]

_________________
Non enim propter gloriam, diuicias aut honores pugnamus set propter libertatem solummodo quam Nemo bonus nisi simul cum vita amittit.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0767s ][ Queries: 12 (0.0045s) ][ GZIP on ]