Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 15:24
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Skype -static sfs
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Tue 27 Apr 2010, 03:43    Post subject:  Skype -static sfs
Subject description: should work in most late pups
 

Hi there

This an sfs I made from the most recent Skype static Linux build, it should work on most Puppies. I tested it on the latest Lupu, but it is static, I tested the same package (before I made the sfs) on Stardust and 431, however I always modify my system slightly so I can't say for sure that I'd guarantee it will work out of the box.

http://www.skype.com/intl/en/ Skype website

http://www.dpup.org/01Micko/skype/skype_static-2.1.0.81.sfs The sfs, 27 MB (from dpup.org)

http://distro.ibiblio.org/pub/linux/distributions/quirky/sfs/skype_static-2.1.0.81.sfs The sfs from Ibiblio

http://dokupuppylinux.co.cc/programs:internet_phone Thanks Dingo for mirror on dokupuppy

It might pay to use wget to down load from dpup.org

Code:
wget -t 0 -c http://www.dpup.org/01Micko/skype/skype_static-2.1.0.81.sfs


checksum dc42bca2b61c7a01daafa1782e9c671a

It should create a menu entry in "Internet" on installation. For some strange reason I had to symlink the "sounds" directory to /root/sounds for the ringing and other weird skype sounds to work.

Make sure you configure you sound, mic and webcam correctly, it might pay to make sure your mic works with alsa first to save some frustration.

Enjoy.

Cheers

Note Latest Quirky and probably Wary need libXss..

I compiled LibScreenSaver (libXss) and installed in Quirky and skype now works. It's probably fine in Wary too, I didn't test with Wary.

Note2: You only need the the first pet, not the DEV one, unless you want to compile against it then grab both.

Note3: As of Quirky greater than 022, Barry is including those libs as they are tiny.
Note4: As of Quirky 1, this skype sfs is working for me ootb Smile

Note5: Puppy431, this skype sfs is working for me ootb Smile
libXScrnSaver-1.2.0-i486.pet
Description 
pet

 Download 
Filename  libXScrnSaver-1.2.0-i486.pet 
Filesize  10.06 KB 
Downloaded  609 Time(s) 
libXScrnSaver_DEV-1.2.0-i486.pet
Description 
pet

 Download 
Filename  libXScrnSaver_DEV-1.2.0-i486.pet 
Filesize  26.45 KB 
Downloaded  533 Time(s) 
skype.jpg
 Description   
 Filesize   26.08 KB
 Viewed   4015 Time(s)

skype.jpg


_________________
Woof Mailing List | keep the faith Cool |

Last edited by 01micko on Wed 05 May 2010, 03:48; edited 6 times in total
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Thu 29 Apr 2010, 01:51    Post subject:  

If you tried to download this please try again, the file's permissions were set wrong on the server.. Embarassed
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Dingo


Joined: 11 Dec 2007
Posts: 1422
Location: somewhere at the end of rainbow...

PostPosted: Thu 29 Apr 2010, 08:43    Post subject:  

mirrored on dokupuppy

http://dokupuppylinux.co.cc/programs:internet_phone

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3458
Location: West Lothian, Scotland, UK

PostPosted: Thu 29 Apr 2010, 08:56    Post subject:  

So far I haven't made use of SFS files; stick to using PET's.

Any info available on how to use SFS files?
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Thu 29 Apr 2010, 23:47    Post subject:  

Hi Sylvander

Here a useful guide. Don't be put off that it is for Lucid Puppy, the principle is the same in all frugal installations of Puppy.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3458
Location: West Lothian, Scotland, UK

PostPosted: Fri 30 Apr 2010, 02:40    Post subject:  

Your link leads me to an [almost] empty page. Sad

As you were...
Got there at the 3rd attempt after allowing scripts for that page in NoScript. Very Happy
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3458
Location: West Lothian, Scotland, UK

PostPosted: Fri 30 Apr 2010, 04:29    Post subject:  

Reading that page:

1. Running "Lupu-113->Quickpet-v1.2"...
And...
There's no SFS tab! Sad Confused

2. "NOTE: These procedures work only with a frugal installation."
Is that strictly true?

3. "and the individual files placed in the proper directories"
(a) What would constitute a "proper directory"?
"Now, download an SFS and save it to /mnt/home"
Must they be saved in /mnt/home?
Not sure I understand the significance of mnt/home.
Where the pupsave file is being held?
On a partition on a Flash Drive?
And it's auto-mounted by the Puppy using it?
So it's a good place to locate the SFS files?
But not necessarily the only place?
I could use Startmount to mount some other partition holding the SFS's?

(b) Can they be placed on any [seen by Puppy and] auto-mounted partition?
I'd be inclined to hold SFS files on some handy storage partition along with all the other stored files.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Fri 30 Apr 2010, 19:48    Post subject:  

Quote:
There's no SFS tab!


Not in the version your using, the page is updated for the next version, we can get away with this still being in alpha and development is at a brisk pace.

Quote:
"NOTE: These procedures work only with a frugal installation."
Is that strictly true?


Yes and no. A frugal install strictly is one booting off the hard drive/flash drive, but a live cd install is still considered a "frugal" install. Won't work with full or live save back to cd.


Quote:
"and the individual files placed in the proper directories"
(a) What would constitute a "proper directory"?


I'll change it to "corresponding" Wink

Quote:
Must they be saved in /mnt/home?


Yes or "bootmanager" won't find the sfs.

If you want to store them elsewhere then you need to use jrb's sfs_linker or some other method to mount the sfs.

________________________________

Now, where were we? Skype I believe.

Any reports?

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Snail

Joined: 18 Oct 2009
Posts: 238

PostPosted: Tue 04 May 2010, 20:39    Post subject: Skype client internet links  

Thank you 01micko for all your work on this and other puppy stuff.

I have already downloaded and installed 2.1.0.81 directly from Skype's site and only thought to search for Skype in this forum when I ran into a bug. I am running the static download on 4.3.2. I am only testing the audio, no camera, and everything seems to work just fine so far, except that none of the internet links from the client work. For example, when I try to log into my account or click one of the "more info" links in the setup panels, the blinky flashes briefly and nothing else happens. Does this happen with your sfs? I am trying to isolate it down to whether this is a problem with the binary, my installation of it, puppy generally, or just 432. I can't see anything about it on the Skype bug page.

Another problem is that there seems no way to save your password. Ticking the "login when Skype starts" box in the client has no effect. I believe that this is a Skype bug, there is something about it on the Skype pages. Did earlier versions have the same problem? Is there a work around for it?

I am a total novice with Linux, as well as Puppy. I wonder if someone could clarify something for me? I can understand the utility of an sfs for Skype, given the added flexibility it gives. However, previously there have been .pets made for Skype. Given how easily I installed the binary from Skype site, what is the advantage of the .pet form? I gather that binaries may be stripped to reduce size in Puppy. Is that the advantage, or are other things also possible to make the binary work better with Puppy?

01micko, I browsed off this thread to your Lupu page about sfs usage. You provided a link to jrb's dynamic sfs loader. You make the comment that it is still under devellopment. Is that still the case or does your page need to be updated in that respect? Following your link, it seemed to my uneducated eye that jrb has cracked it and it is now in 4.4. It seems a good development. Now if we could only load pupsave and sfs's into ram!
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Wed 05 May 2010, 03:04    Post subject:  

Hi Snail

I haven't tried this sfs in 431 or 432 but I did try the package and I had success with it, I will try this sfs with a clean install and see what I can do.

I would say the login bug is related to the first bug, skype is not seeing your net connection.

I tried jrb's sfs_linker in lupu a while ago and had failure, but otheres have reported success in lupu. Really all apps in Puppy are under development of some sort, always improving. Cool I had great succes with sfs_linker in 4.4 alpha.

Cheers

EDIT: I just tried this actual sfs in a brand new frugal of puppy 431 and it works out if the box. Smile

Snail, try the sfs.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Snail

Joined: 18 Oct 2009
Posts: 238

PostPosted: Wed 05 May 2010, 07:31    Post subject: Test in 432  

01Micko, I have tested your sfs in a clean pupsave. It now remembers my password and connects whenever I load skype from the menu, which didn't happen with my previous install from the static binary downloaded from skype to "my applications" . The skype test phonecall works well with both the sfs and with the "my Applications" method. (I don't use video at present).

However, I get exactly the same fault with your sfs as I was having with my method. Clicking on theSkype Credit button at the top right of the initial Skype window and then clicking on "Visit account page" results in a brief burst of flashes in the Network connection blinky and nothing else. Subsequent clicking doesn't even disturb blinky.

Opening the menu and clicking on Options/SMS/Learn more about SMS or Options........CallForwarding/Voicemail likewise does nothing.

I can get into my account page via Seamonkey, but that's a hassle.

Have you checked these actions in 431?
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7835
Location: qld

PostPosted: Wed 05 May 2010, 08:04    Post subject:  

Snail

That is a 'bug' in skype, it won't open a default browser in puppy, sorry about that. Other things that skype internally needs a browser for won't work either. Unfortunately, skype being proprietary it can't be hacked legally, so we need to put up with it until they decide to fix it. Perhaps make a report to Skype.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
jimmyhan

Joined: 17 Aug 2009
Posts: 8

PostPosted: Fri 22 Oct 2010, 03:33    Post subject:  

I'm able to log in and serach for contact, enteres them into my contact. Did not do any test call, but what I love to use skype for is chat. Is my sfs having the problem or it is another bug?
Thank you.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0843s ][ Queries: 13 (0.0044s) ][ GZIP on ]