Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 13:58
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
where can i find the wifi driver for Marvell sd8686?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
mkdir

Joined: 03 May 2010
Posts: 4

PostPosted: Mon 03 May 2010, 02:37    Post subject:  where can i find the wifi driver for Marvell sd8686?  

Hi at all,

Where can i find the wifi driver for Marvell sd8686?
Thanks
Back to top
View user's profile Send private message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Mon 03 May 2010, 05:33    Post subject:  

Hi
There are reported problems with firmware for this device on *buntu forums

Marvell here, if you know device numbers

http://www.marvell.com/support.html

Or try ndiswrapper with windoze driver

possible here, though not tried

http://www.x-drivers.com/catalog/drivers/wireless_networks/companies/marvell/models/sd8686_wireless_lan_sdio/14951.html

Else ask tempestuous

Aitch Smile
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Fri 07 May 2010, 11:51    Post subject:  

Out the outset it's important, and courteous, to reveal the exact details of your wifi device, and the exact Puppy version you're using when asking for help.

The Marvell SD8686 SDIO wifi device is already supported in Puppy versions 4.2.x and 4.3.x (with 2.6.30.5 kernel) by the libertas_sdio Linux driver. The firmware, which I repackaged from wireless.kernel.org, is also included as standard.

If your device fails to work, you should do some diagnosis so we can fix the problem for you.
Once Puppy 4.2/4.3 is loaded, you should run this command -
Code:
dmesg

and look for anything relating to "Marvell", "Libertas" or "libertas_sdio". Report the exact details.
If there's nothing relevant, run this command -
Code:
lspci -n

and report the results. This will help us identify the device ID of your SDIO wifi device, and hopefully learn why the driver is not automatically loading.
Back to top
View user's profile Send private message 
mkdir

Joined: 03 May 2010
Posts: 4

PostPosted: Fri 07 May 2010, 21:28    Post subject:  

Thanks relies
MY puppy vrsion info is:
kernel:k2.6.30.5
xorg:7.3; xorg-server:1.3.0
glibc:2.6.1
gtk:2.14.7
x windows version 1.3.x

My mid's wifi is Marvell sd8686 sdio.

By using lspci and dmesg,the result is below:
# lspci -n
00:00.0 Class 0600: 8086:8101 (rev 06)
00:02.0 Class 0300: 8086:8109 (rev 06)
00:1a.0 Class 0c03: 8086:8118 (rev 06)
00:1b.0 Class 0403: 8086:811b (rev 06)
00:1d.0 Class 0c03: 8086:8114 (rev 06)
00:1d.1 Class 0c03: 8086:8115 (rev 06)
00:1d.2 Class 0c03: 8086:8116 (rev 06)
00:1d.7 Class 0c03: 8086:8117 (rev 06)
00:1e.0 Class 0805: 8086:811c (rev 06)
00:1e.1 Class 0805: 8086:811d (rev 06)
00:1f.0 Class 0601: 8086:8119 (rev 06)
00:1f.1 Class 0101: 8086:811a (rev 06)
# dmesg
rq 0 global_irq 2 high edge)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode: Flat. Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
ACPI: HPET id: 0x8086a201 base: 0xfed00000
SMP: Allowing 1 CPUs, 0 hotplug CPUs
nr_irqs_gsi: 24
Allocating PCI resources starting at 30000000 (gap: 20000000:c0000000)
NR_CPUS:4 nr_cpumask_bits:4 nr_cpu_ids:1 nr_node_ids:1
PERCPU: Embedded 10 pages at c13f2000, static data 20428 bytes
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 127577
Kernel command line: BOOT_IMAGE=vmlinuz initrd=initrd.gz pmedia=usbflash
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
NR_IRQS:384
PID hash table entries: 2048 (order: 11, 8192 bytes)
Extended CMOS year: 2000
Fast TSC calibration using PIT
Detected 798.110 MHz processor.
Console: colour VGA+ 80x25
console [tty0] enabled
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Initializing HighMem for node 0 (00000000:00000000)
Memory: 503224k/514752k available (3179k kernel code, 11028k reserved, 1231k data, 336k init, 0k highmem)
virtual kernel memory layout:
fixmap : 0xfff82000 - 0xfffff000 ( 500 kB)
pkmap : 0xff800000 - 0xffc00000 (4096 kB)
vmalloc : 0xdfeb0000 - 0xff7fe000 ( 505 MB)
lowmem : 0xc0000000 - 0xdf6b0000 ( 502 MB)
.init : 0xc0556000 - 0xc05aa000 ( 336 kB)
.data : 0xc041ad14 - 0xc054ebe8 (1231 kB)
.text : 0xc0100000 - 0xc041ad14 (3179 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
hpet clockevent registered
HPET: 3 timers in total, 0 timers will be used for per-cpu timer
Calibrating delay loop (skipped), value calculated using timer frequency.. 1596.22 BogoMIPS (lpj=3192440)
Mount-cache hash table entries: 512
CPU: L1 I cache: 32K, L1 D cache: 24K
CPU: L2 cache: 512K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
using mwait in idle threads.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 15k freed
ACPI: Core revision 20090320
..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
CPU0: Intel(R) Atom(TM) CPU Z500 @ 800MHz stepping 02
Brought up 1 CPUs
Total of 1 processors activated (1596.22 BogoMIPS).
net_namespace: 948 bytes
NET: Registered protocol family 16
EISA bus registered
ACPI: bus type pci registered
PCI: MCFG configuration 0: base e0000000 segment 0 buses 0 - 255
PCI: MCFG area at e0000000 reserved in E820
PCI: Using MMCONFIG for extended config space
PCI: Using configuration type 1 for base access
bio: create slab <bio-0> at 0
ACPI: EC: Look up EC in DSDT
ACPI: BIOS _OSI(Linux) query ignored
ACPI: Interpreter enabled
ACPI: (supports S0 S3 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: EC: non-query interrupt received, switching to interrupt mode
ACPI: EC: GPE = 0xd, I/O: command/status = 0x66, data = 0x62
ACPI: EC: driver started in interrupt mode
ACPI: No dock devices found.
ACPI: PCI Root Bridge [PCI0] (0000:00)
pci 0000:00:02.0: reg 10 32bit mmio: [0xc8080000-0xc80fffff]
pci 0000:00:02.0: reg 14 io port: [0x1800-0x1807]
pci 0000:00:02.0: reg 18 32bit mmio: [0xd0000000-0xd7ffffff]
pci 0000:00:02.0: reg 1c 32bit mmio: [0xc8000000-0xc801ffff]
pci 0000:00:1a.0: reg 10 32bit mmio: [0xc8020000-0xc8020fff]
pci 0000:00:1b.0: reg 10 64bit mmio: [0xc8024000-0xc8027fff]
pci 0000:00:1b.0: PME# supported from D0 D3hot
pci 0000:00:1b.0: PME# disabled
pci 0000:00:1d.0: reg 20 io port: [0x1820-0x183f]
pci 0000:00:1d.1: reg 20 io port: [0x1840-0x185f]
pci 0000:00:1d.2: reg 20 io port: [0x1860-0x187f]
pci 0000:00:1d.7: reg 10 32bit mmio: [0xc8021000-0xc80213ff]
pci 0000:00:1d.7: PME# supported from D0 D3hot D3cold
pci 0000:00:1d.7: PME# disabled
pci 0000:00:1e.0: reg 10 32bit mmio: [0xc8021400-0xc80214ff]
pci 0000:00:1e.1: reg 10 32bit mmio: [0xc8021800-0xc80218ff]
pci 0000:00:1f.1: reg 20 io port: [0x1810-0x181f]
pci_bus 0000:00: on NUMA node 0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 5 6 *7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 5 6 7 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 1 *3 5 6 7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 *5 6 7 11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 1 3 5 6 7 10 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 1 3 5 6 7 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKG] (IRQs 1 3 5 6 7 10 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKH] (IRQs 1 3 5 6 7 11 12 14 15) *10
SCSI subsystem initialized
libata version 3.00 loaded.
PCI: Using ACPI for IRQ routing
hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
hpet0: 3 comparators, 64-bit 14.318180 MHz counter
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 11 devices
ACPI: ACPI bus type pnp unregistered
PnPBIOS: Disabled by ACPI PNP
system 00:01: iomem range 0xfd000000-0xfd003fff has been reserved
system 00:01: iomem range 0xe0000000-0xefffffff has been reserved
system 00:01: iomem range 0xfed00000-0xfed3ffff could not be reserved
system 00:01: iomem range 0xfed40000-0xfed44fff has been reserved
system 00:01: iomem range 0xfed45000-0xfed4bfff has been reserved
system 00:04: iomem range 0xfed00000-0xfed003ff has been reserved
system 00:06: ioport range 0x680-0x69f has been reserved
system 00:06: ioport range 0x8080-0x8080 has been reserved
system 00:06: ioport range 0x1000-0x107f has been reserved
system 00:06: ioport range 0x1180-0x11bf has been reserved
system 00:06: ioport range 0x1640-0x164f has been reserved
system 00:06: ioport range 0x374-0x375 has been reserved
system 00:06: ioport range 0x3f4-0x3f5 has been reserved
pci_bus 0000:00: resource 0 io: [0x00-0xffff]
pci_bus 0000:00: resource 1 mem: [0x000000-0xffffffff]
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
NET: Registered protocol family 1
Trying to unpack rootfs image as initramfs...
Freeing initrd memory: 1393k freed
Simple Boot Flag at 0x35 set to 0x1
NTFS driver 2.1.29 [Flags: R/W].
msgmni has been set to 985
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler cfq registered (default)
pci 0000:00:02.0: Boot video device
isapnp: Scanning for PnP cards...
Switched to high resolution mode on CPU 0
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12b
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
floppy0: no floppy controllers found
brd: module loaded
loop: module loaded
Driver 'sd' needs updating - please use bus_type methods
Driver 'sr' needs updating - please use bus_type methods
pata_sch 0000:00:1f.1: version 0.2
pata_sch 0000:00:1f.1: setting latency timer to 64
scsi0 : pata_sch
scsi1 : pata_sch
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x1810 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x1818 irq 15
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
cpuidle: using governor ladder
cpuidle: using governor menu
TCP cubic registered
NET: Registered protocol family 17
Using IPI No-Shortcut mode
input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
ata1.00: ATA-5: Intel_SSD, 20080506, max UDMA/66
ata1.00: 3768912 sectors, multi 2: LBA
ata1.01: ATA-5: Intel_SSD, 20080506, max UDMA/66
ata1.01: 3768912 sectors, multi 2: LBA
ata1.00: configured for UDMA/66
ata1.01: configured for UDMA/66
scsi 0:0:0:0: Direct-Access ATA Intel_SSD 2008 PQ: 0 ANSI: 5
scsi 0:0:1:0: Direct-Access ATA Intel_SSD 2008 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 3768912 512-byte hardware sectors: (1.92 GB/1.79 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sda: sda1
sd 0:0:1:0: [sdb] 3768912 512-byte hardware sectors: (1.92 GB/1.79 GiB)
sd 0:0:1:0: [sdb] Write Protect is off
sd 0:0:1:0: [sdb] Mode Sense: 00 3a 00 00
sd 0:0:1:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1 <<5>sd 0:0:0:0: [sda] Attached SCSI disk
sdb5 >
sd 0:0:1:0: [sdb] Attached SCSI disk
Freeing unused kernel memory: 336k freed
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci_hcd 0000:00:1d.7: PCI INT D -> GSI 21 (level, low) -> IRQ 21
ehci_hcd 0000:00:1d.7: setting latency timer to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:1d.7: debug port 1
ehci_hcd 0000:00:1d.7: cache line size of 32 is not supported
ehci_hcd 0000:00:1d.7: irq 21, io mem 0xc8021000
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
uhci_hcd: USB Universal Host Controller Interface driver
uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
uhci_hcd 0000:00:1d.0: setting latency timer to 64
uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.0: irq 23, io base 0x00001820
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
uhci_hcd 0000:00:1d.1: setting latency timer to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.1: irq 19, io base 0x00001840
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
uhci_hcd 0000:00:1d.2: setting latency timer to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.2: irq 18, io base 0x00001860
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
aufs 2-standalone.tree-30-20090831
fuse init (API version 7.11)
usb 1-1: new high speed USB device using ehci_hcd and address 2
usb 1-1: configuration #1 chosen from 1 choice
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 1-4: new high speed USB device using ehci_hcd and address 3
usb 1-4: configuration #1 chosen from 1 choice
usb 1-1.2: new high speed USB device using ehci_hcd and address 5
usb 1-1.2: configuration #1 chosen from 1 choice
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
usb 1-1.4: new low speed USB device using ehci_hcd and address 6
usb 1-1.4: configuration #1 chosen from 1 choice
input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1.4/1-1.4:1.0/input/input1
generic-usb 0003:046D:C019.0001: input: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:1d.7-1.4/input0
usb 4-1: new full speed USB device using uhci_hcd and address 2
usb 4-1: configuration #1 chosen from 1 choice
input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input2
scsi 2:0:0:0: Direct-Access Generic USB SD Reader 1.00 PQ: 0 ANSI: 0 CCS
usb-storage: device scan complete
sd 2:0:0:0: [sdc] 997888 512-byte hardware sectors: (510 MB/487 MiB)
sd 2:0:0:0: [sdc] Write Protect is off
sd 2:0:0:0: [sdc] Mode Sense: 4b 00 00 08
sd 2:0:0:0: [sdc] Assuming drive cache: write through
sd 2:0:0:0: [sdc] Assuming drive cache: write through
sdc: sdc1
sd 2:0:0:0: [sdc] Attached SCSI removable disk
aufs test_add:242:mount[1764]: uid/gid/perm /pup_ro2 0/0/0777, 0/0/01777
udevd version 124 started
ACPI: AC Adapter [ACAD] (off-line)
Monitor-Mwait will be used to enter C-1 state
Monitor-Mwait will be used to enter C-2 state
Monitor-Mwait will be used to enter C-3 state
Monitor-Mwait will be used to enter C-3 state
Marking TSC unstable due to TSC halts in idle
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3] C4[C3])
processor ACPI_CPU:00: registered as cooling_device0
ACPI: Processor [CPU0] (supports 8 throttling states)
input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
ACPI: Power Button [PWRF]
ACPI Error (evxfevnt-0193): Could not enable PowerButton event [20090320]
ACPI Warning (evxface-0146): Could not enable fixed event 2 [20090320]
button: probe of LNXPWRBN:00 failed with error -22
input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input4
ACPI: Lid Switch [LID0]
input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input5
ACPI: Power Button [PWRB]
ACPI: Battery Slot [BAT1] (battery present)
input: PC Speaker as /devices/platform/pcspkr/input/input6
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pci 0000:00:1e.0: SDHCI controller found [8086:811c] (rev 6)
sdhci-pci 0000:00:1e.0: enabling device (0004 -> 0006)
sdhci-pci 0000:00:1e.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
sdhci-pci 0000:00:1e.0: setting latency timer to 64
Registered led device: mmc0::
mmc0: SDHCI controller on PCI [0000:00:1e.0] using DMA
sdhci-pci 0000:00:1e.1: SDHCI controller found [8086:811d] (rev 6)
sdhci-pci 0000:00:1e.1: enabling device (0004 -> 0006)
sdhci-pci 0000:00:1e.1: PCI INT B -> GSI 20 (level, low) -> IRQ 20
sdhci-pci 0000:00:1e.1: setting latency timer to 64
Registered led device: mmc1::
mmc1: SDHCI controller on PCI [0000:00:1e.1] using DMA
mmc0: new high speed SD card at address 1234
mmcblk0: mmc0:1234 SA02G 1.83 GiB
mmcblk0:
cdc_acm 4-1:1.0: ttyACM0: USB ACM device
usbcore: registered new interface driver cdc_acm
cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64
hda_codec: Unknown model for ALC262, trying auto-probe from BIOS...
Clocksource tsc unstable (delta = -475905171 ns)
mtrr: type mismatch for 1ffc0000,10000 old: write-back new: write-combining
mtrr: type mismatch for 1ff80000,40000 old: write-back new: write-combining
mtrr: type mismatch for 1ff00000,80000 old: write-back new: write-combining
mtrr: type mismatch for 1fe00000,100000 old: write-back new: write-combining
mtrr: type mismatch for 1fc00000,200000 old: write-back new: write-combining
mtrr: type mismatch for 1f800000,400000 old: write-back new: write-combining
hda-intel: Invalid position buffer, using LPIB read method instead.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Fri 07 May 2010, 22:23    Post subject:  

Well your lspci results show the SDIO controller (Intel 8086:811c and 8086:811d)
but there's nothing from dmesg to indicate the presence of a wifi card.

I suggest you go ahead and load the driver manually. The SDIO wifi card must be in place, then do this
Code:
modprobe libertas_sdio

Now run "dmesg" again and see if there's something reported about the wifi card.
Back to top
View user's profile Send private message 
mkdir

Joined: 03 May 2010
Posts: 4

PostPosted: Fri 07 May 2010, 23:07    Post subject:  

ok,by advice above,the result is below:

# modprobe libertas_sdio
# dmesg
d=initrd.gz pmedia=usbflash
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
NR_IRQS:384
PID hash table entries: 2048 (order: 11, 8192 bytes)
Extended CMOS year: 2000
Fast TSC calibration using PIT
Detected 797.841 MHz processor.
Console: colour VGA+ 80x25
console [tty0] enabled
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Initializing HighMem for node 0 (00000000:00000000)
Memory: 503224k/514752k available (3179k kernel code, 11028k reserved, 1231k data, 336k init, 0k highmem)
virtual kernel memory layout:
fixmap : 0xfff82000 - 0xfffff000 ( 500 kB)
pkmap : 0xff800000 - 0xffc00000 (4096 kB)
vmalloc : 0xdfeb0000 - 0xff7fe000 ( 505 MB)
lowmem : 0xc0000000 - 0xdf6b0000 ( 502 MB)
.init : 0xc0556000 - 0xc05aa000 ( 336 kB)
.data : 0xc041ad14 - 0xc054ebe8 (1231 kB)
.text : 0xc0100000 - 0xc041ad14 (3179 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
hpet clockevent registered
HPET: 3 timers in total, 0 timers will be used for per-cpu timer
Calibrating delay loop (skipped), value calculated using timer frequency.. 1595.68 BogoMIPS (lpj=3191364)
Mount-cache hash table entries: 512
CPU: L1 I cache: 32K, L1 D cache: 24K
CPU: L2 cache: 512K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
using mwait in idle threads.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 15k freed
ACPI: Core revision 20090320
..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
CPU0: Intel(R) Atom(TM) CPU Z500 @ 800MHz stepping 02
Brought up 1 CPUs
Total of 1 processors activated (1595.68 BogoMIPS).
net_namespace: 948 bytes
NET: Registered protocol family 16
EISA bus registered
ACPI: bus type pci registered
PCI: MCFG configuration 0: base e0000000 segment 0 buses 0 - 255
PCI: MCFG area at e0000000 reserved in E820
PCI: Using MMCONFIG for extended config space
PCI: Using configuration type 1 for base access
bio: create slab <bio-0> at 0
ACPI: EC: Look up EC in DSDT
ACPI: BIOS _OSI(Linux) query ignored
ACPI: Interpreter enabled
ACPI: (supports S0 S3 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: EC: non-query interrupt received, switching to interrupt mode
ACPI: EC: GPE = 0xd, I/O: command/status = 0x66, data = 0x62
ACPI: EC: driver started in interrupt mode
ACPI: No dock devices found.
ACPI: PCI Root Bridge [PCI0] (0000:00)
pci 0000:00:02.0: reg 10 32bit mmio: [0xc8080000-0xc80fffff]
pci 0000:00:02.0: reg 14 io port: [0x1800-0x1807]
pci 0000:00:02.0: reg 18 32bit mmio: [0xd0000000-0xd7ffffff]
pci 0000:00:02.0: reg 1c 32bit mmio: [0xc8000000-0xc801ffff]
pci 0000:00:1a.0: reg 10 32bit mmio: [0xc8020000-0xc8020fff]
pci 0000:00:1b.0: reg 10 64bit mmio: [0xc8024000-0xc8027fff]
pci 0000:00:1b.0: PME# supported from D0 D3hot
pci 0000:00:1b.0: PME# disabled
pci 0000:00:1d.0: reg 20 io port: [0x1820-0x183f]
pci 0000:00:1d.1: reg 20 io port: [0x1840-0x185f]
pci 0000:00:1d.2: reg 20 io port: [0x1860-0x187f]
pci 0000:00:1d.7: reg 10 32bit mmio: [0xc8021000-0xc80213ff]
pci 0000:00:1d.7: PME# supported from D0 D3hot D3cold
pci 0000:00:1d.7: PME# disabled
pci 0000:00:1e.0: reg 10 32bit mmio: [0xc8021400-0xc80214ff]
pci 0000:00:1e.1: reg 10 32bit mmio: [0xc8021800-0xc80218ff]
pci 0000:00:1f.1: reg 20 io port: [0x1810-0x181f]
pci_bus 0000:00: on NUMA node 0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 5 6 *7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 5 6 7 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 1 *3 5 6 7 10 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 *5 6 7 11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 1 3 5 6 7 10 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 1 3 5 6 7 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKG] (IRQs 1 3 5 6 7 10 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKH] (IRQs 1 3 5 6 7 11 12 14 15) *10
SCSI subsystem initialized
libata version 3.00 loaded.
PCI: Using ACPI for IRQ routing
hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
hpet0: 3 comparators, 64-bit 14.318180 MHz counter
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 11 devices
ACPI: ACPI bus type pnp unregistered
PnPBIOS: Disabled by ACPI PNP
system 00:01: iomem range 0xfd000000-0xfd003fff has been reserved
system 00:01: iomem range 0xe0000000-0xefffffff has been reserved
system 00:01: iomem range 0xfed00000-0xfed3ffff could not be reserved
system 00:01: iomem range 0xfed40000-0xfed44fff has been reserved
system 00:01: iomem range 0xfed45000-0xfed4bfff has been reserved
system 00:04: iomem range 0xfed00000-0xfed003ff has been reserved
system 00:06: ioport range 0x680-0x69f has been reserved
system 00:06: ioport range 0x8080-0x8080 has been reserved
system 00:06: ioport range 0x1000-0x107f has been reserved
system 00:06: ioport range 0x1180-0x11bf has been reserved
system 00:06: ioport range 0x1640-0x164f has been reserved
system 00:06: ioport range 0x374-0x375 has been reserved
system 00:06: ioport range 0x3f4-0x3f5 has been reserved
pci_bus 0000:00: resource 0 io: [0x00-0xffff]
pci_bus 0000:00: resource 1 mem: [0x000000-0xffffffff]
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
NET: Registered protocol family 1
Trying to unpack rootfs image as initramfs...
Freeing initrd memory: 1393k freed
Simple Boot Flag at 0x35 set to 0x1
NTFS driver 2.1.29 [Flags: R/W].
msgmni has been set to 985
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler cfq registered (default)
pci 0000:00:02.0: Boot video device
Switched to high resolution mode on CPU 0
pci 0000:00:1d.7: EHCI: BIOS handoff failed (BIOS bug?) 01010001
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12b
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
floppy0: no floppy controllers found
brd: module loaded
loop: module loaded
Driver 'sd' needs updating - please use bus_type methods
Driver 'sr' needs updating - please use bus_type methods
pata_sch 0000:00:1f.1: version 0.2
pata_sch 0000:00:1f.1: setting latency timer to 64
scsi0 : pata_sch
scsi1 : pata_sch
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x1810 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x1818 irq 15
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
cpuidle: using governor ladder
cpuidle: using governor menu
TCP cubic registered
NET: Registered protocol family 17
Using IPI No-Shortcut mode
input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
ata1.00: ATA-5: Intel_SSD, 20080506, max UDMA/66
ata1.00: 3768912 sectors, multi 2: LBA
ata1.01: ATA-5: Intel_SSD, 20080506, max UDMA/66
ata1.01: 3768912 sectors, multi 2: LBA
ata1.00: configured for UDMA/66
ata1.01: configured for UDMA/66
scsi 0:0:0:0: Direct-Access ATA Intel_SSD 2008 PQ: 0 ANSI: 5
scsi 0:0:1:0: Direct-Access ATA Intel_SSD 2008 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 3768912 512-byte hardware sectors: (1.92 GB/1.79 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sda: sda1
sd 0:0:1:0: [sdb] 3768912 512-byte hardware sectors: (1.92 GB/1.79 GiB)
sd 0:0:1:0: [sdb] Write Protect is off
sd 0:0:1:0: [sdb] Mode Sense: 00 3a 00 00
sd 0:0:1:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1 <<5>sd 0:0:0:0: [sda] Attached SCSI disk
sdb5 >
sd 0:0:1:0: [sdb] Attached SCSI disk
Freeing unused kernel memory: 336k freed
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci_hcd 0000:00:1d.7: PCI INT D -> GSI 21 (level, low) -> IRQ 21
ehci_hcd 0000:00:1d.7: setting latency timer to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:1d.7: debug port 1
ehci_hcd 0000:00:1d.7: cache line size of 32 is not supported
ehci_hcd 0000:00:1d.7: irq 21, io mem 0xc8021000
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
uhci_hcd: USB Universal Host Controller Interface driver
uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
uhci_hcd 0000:00:1d.0: setting latency timer to 64
uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.0: irq 23, io base 0x00001820
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
uhci_hcd 0000:00:1d.1: setting latency timer to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.1: irq 19, io base 0x00001840
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
uhci_hcd 0000:00:1d.2: setting latency timer to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.2: irq 18, io base 0x00001860
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
aufs 2-standalone.tree-30-20090831
fuse init (API version 7.11)
usb 1-1: new high speed USB device using ehci_hcd and address 2
usb 1-1: configuration #1 chosen from 1 choice
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 1-4: new high speed USB device using ehci_hcd and address 3
usb 1-4: configuration #1 chosen from 1 choice
usb 1-1.2: new high speed USB device using ehci_hcd and address 5
usb 1-1.2: configuration #1 chosen from 1 choice
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
usb 1-1.4: new low speed USB device using ehci_hcd and address 6
usb 1-1.4: configuration #1 chosen from 1 choice
input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1.4/1-1.4:1.0/input/input1
generic-usb 0003:046D:C019.0001: input: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:1d.7-1.4/input0
usb 4-1: new full speed USB device using uhci_hcd and address 2
usb 4-1: configuration #1 chosen from 1 choice
input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input2
scsi 2:0:0:0: Direct-Access Generic USB SD Reader 1.00 PQ: 0 ANSI: 0 CCS
usb-storage: device scan complete
sd 2:0:0:0: [sdc] 997888 512-byte hardware sectors: (510 MB/487 MiB)
sd 2:0:0:0: [sdc] Write Protect is off
sd 2:0:0:0: [sdc] Mode Sense: 4b 00 00 08
sd 2:0:0:0: [sdc] Assuming drive cache: write through
sd 2:0:0:0: [sdc] Assuming drive cache: write through
sdc: sdc1
sd 2:0:0:0: [sdc] Attached SCSI removable disk
aufs test_add:242:mount[1764]: uid/gid/perm /pup_ro2 0/0/0777, 0/0/01777
udevd version 124 started
ACPI: EC: GPE storm detected, transactions will use polling mode
Monitor-Mwait will be used to enter C-1 state
Monitor-Mwait will be used to enter C-2 state
Monitor-Mwait will be used to enter C-3 state
Monitor-Mwait will be used to enter C-3 state
Marking TSC unstable due to TSC halts in idle
ACPI: AC Adapter [ACAD] (off-line)
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3] C4[C3])
processor ACPI_CPU:00: registered as cooling_device0
ACPI: Processor [CPU0] (supports 8 throttling states)
input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
ACPI: Power Button [PWRF]
ACPI Error (evxfevnt-0193): Could not enable PowerButton event [20090320]
ACPI Warning (evxface-0146): Could not enable fixed event 2 [20090320]
button: probe of LNXPWRBN:00 failed with error -22
input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input4
ACPI: Lid Switch [LID0]
input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input5
ACPI: Power Button [PWRB]
ACPI: Battery Slot [BAT1] (battery present)
input: PC Speaker as /devices/platform/pcspkr/input/input6
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pci 0000:00:1e.0: SDHCI controller found [8086:811c] (rev 6)
sdhci-pci 0000:00:1e.0: enabling device (0004 -> 0006)
sdhci-pci 0000:00:1e.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
sdhci-pci 0000:00:1e.0: setting latency timer to 64
Registered led device: mmc0::
mmc0: SDHCI controller on PCI [0000:00:1e.0] using DMA
sdhci-pci 0000:00:1e.1: SDHCI controller found [8086:811d] (rev 6)
sdhci-pci 0000:00:1e.1: enabling device (0004 -> 0006)
sdhci-pci 0000:00:1e.1: PCI INT B -> GSI 20 (level, low) -> IRQ 20
sdhci-pci 0000:00:1e.1: setting latency timer to 64
Registered led device: mmc1::
mmc1: SDHCI controller on PCI [0000:00:1e.1] using DMA
mmc0: new high speed SD card at address 1234
mmcblk0: mmc0:1234 SA02G 1.83 GiB
mmcblk0:
cdc_acm 4-1:1.0: ttyACM0: USB ACM device
usbcore: registered new interface driver cdc_acm
cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64
hda_codec: Unknown model for ALC262, trying auto-probe from BIOS...
Clocksource tsc unstable (delta = -221785105 ns)
mtrr: type mismatch for 1ffc0000,10000 old: write-back new: write-combining
mtrr: type mismatch for 1ff80000,40000 old: write-back new: write-combining
mtrr: type mismatch for 1ff00000,80000 old: write-back new: write-combining
mtrr: type mismatch for 1fe00000,100000 old: write-back new: write-combining
mtrr: type mismatch for 1fc00000,200000 old: write-back new: write-combining
mtrr: type mismatch for 1f800000,400000 old: write-back new: write-combining
mtrr: type mismatch for 1ffc0000,10000 old: write-back new: write-combining
mtrr: type mismatch for 1ff80000,40000 old: write-back new: write-combining
mtrr: type mismatch for 1ff00000,80000 old: write-back new: write-combining
mtrr: type mismatch for 1fe00000,100000 old: write-back new: write-combining
mtrr: type mismatch for 1fc00000,200000 old: write-back new: write-combining
mtrr: type mismatch for 1f800000,400000 old: write-back new: write-combining
lib80211: common routines for IEEE802.11 drivers
lib80211_crypt: registered algorithm 'NULL'
libertas_sdio: Libertas SDIO driver
libertas_sdio: Copyright Pierre Ossman
#
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Fri 07 May 2010, 23:47    Post subject:  

It seems to me that your SDIO wifi card is not detected on the SDIO interface.
Just a guess - maybe the core SD driver (sdhci) needs to be loaded?
After a fresh boot, do this
Code:
modprobe sdhci

Now run dmesg and check if any improvement.
Now load the wifi driver
Code:
modprobe libertas_sdio

check dmesg again.

If no success, I suggest you try the latest kernel in Quirky or Lupu.
Back to top
View user's profile Send private message 
mkdir

Joined: 03 May 2010
Posts: 4

PostPosted: Sat 08 May 2010, 01:10    Post subject:  

I tried to modprobe sdhci & libertas_sdio,seemed it don't work.

A user (superxx008) has posted a Ubuntu 7.10 mobile install for the Aigo P8860,and seem to actived the wifi.

I now can't confirm that my mid has the hard or software driver problem.


thanks everyone's help.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Sat 08 May 2010, 02:39    Post subject:  

Now that I know what device you're using (Aigo P8860) I Googled again and got this useful piece of information -
http://lists.infradead.org/pipermail/libertas-dev/2009-June/002496.html
You will see from the "lsmod" results that the sdhci-pci module is loaded ... this might be the important linking module.

It's probably worth one more try. After a fresh reboot, do this
Code:
modprobe sdhci-pci

This will automatically load the other modules it depends upon, namely;
sdhci, mmc_core, led-class.
Run "lsmod" to check. If you're lucky, you may also see the libertas_sdio module listed. If not, load it manually -
Code:
modprobe libertas_sdio

Hopefully dmesg will now show something positive.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1771s ][ Queries: 12 (0.0126s) ][ GZIP on ]