Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 09:58
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
Display Link and Touchscreens
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
pixelblip

Joined: 23 Aug 2008
Posts: 79

PostPosted: Mon 05 Apr 2010, 10:50    Post_subject:  Display Link and Touchscreens  

Afternoon. Hope everyone is having a relaxing Easter.

Can anyone please tell me if they have got a Display Link monitor working with Puppy Linux? I was looking at the Samsung U70. It's nice it just uses USB only.

Has anyone got a touchscreen working - I am looking for something small that is compatible.

Thanks for your advice.
Back to top
View user's profile Send_private_message 
dazbert

Joined: 22 Nov 2009
Posts: 3

PostPosted: Mon 03 May 2010, 18:17    Post_subject: Display Link and Touchscreens  

Hi,

I'm working on this at the moment, after a hiatus of a few months. I've had trouble installing the drivers, but that's because I don't know much about Linux Embarassed I seem to remember tripping up over that whole 'make' not being a command thing. So then I think I had to install 'make', and that didn't work either.

If anyone has any tips on this I'd really love to hear them, otherwise I'll keep plugging away at it and let you know if I get anywhere.
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11121
Location: Arizona USA

PostPosted: Tue 04 May 2010, 00:41    Post_subject:  

The basic Puppy doesn't come with compiling software. You have to add it by adding a certain devx file (and be sure you get the right devx file for your version of Puppy. Here's the one for 4.3.1. Be advised, it's a 90 MB file.) I'm afraid I've never done it, so I really can't help much more than that.

How you add the .dev file depends on how you installed Puppy.

From about 2/3 down this page, under "Useful links":
Quote:
Compile source packages. Puppy is a cutdown tiny distro but it is super-easy to add everything needed to turn Puppy into a complete C/C++/Vala/Genie compile environment -- download 'devx_430.sfs' to /mnt/home, run the BootManager, then reboot.
Back to top
View user's profile Send_private_message 
dazbert

Joined: 22 Nov 2009
Posts: 3

PostPosted: Sun 16 May 2010, 12:38    Post_subject:  

Thanks for the steer, Flash - it's certainly got me moving. I managed to install the compiling sofware, and then after a whole heap of head-scratching I found that I needed kernel_src-2.6.30.5-patched.sfs4.sfs too (which I added using SFS Linker). To my surprise and relief, I was then able to compile and install UDLFB.

Then I tried to compile the DisplayLink driver, according to the instructions here:
http://mulchman.org/blog/?tag=displaylink
and that's where I tripped up. The ./configure seemed to work ok, but when I ran make it came back with a whole heap of errors, beginning with:

Quote:
make all-recursive
make[1]: Entering directory `/xf86-video-displaylink'
Making all in src
make[2]: Entering directory `/xf86-video-displaylink/src'
/bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I -I/usr/X11R7/include -g -O2 -MT displaylink.lo -MD -MP -MF .deps/displaylink.Tpo -c -o displaylink.lo displaylink.c
libtool: compile: gcc -DHAVE_CONFIG_H -I. -I.. -I -I/usr/X11R7/include -g -O2 -MT displaylink.lo -MD -MP -MF .deps/displaylink.Tpo -c displaylink.c -fPIC -DPIC -o .libs/displaylink.o
In file included from displaylink.c:31:
../config.h:4:25: error: xorg-server.h: No such file or directory
In file included from displaylink.c:37:
displaylink.h:5:18: error: xf86.h: No such file or directory
displaylink.h:6:23: error: xf86Modes.h: No such file or directory
displaylink.h:8:22: error: xf86Crtc.h: No such file or directory
displaylink.h:10:21: error: xf86DDC.h: No such file or directory
displaylink.h:12:18: error: edid.h: No such file or directory
displaylink.h:14:20: error: damage.h: No such file or directory......



Any ideas?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0500s ][ Queries: 12 (0.0047s) ][ GZIP on ]