Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 22:57
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
[Filled]Mangler.pet or Ventrillo
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Trip[ABK]

Joined: 12 Jun 2010
Posts: 29

PostPosted: Sun 13 Jun 2010, 14:35    Post_subject:  [Filled]Mangler.pet or Ventrillo  

Well, i've read around on the puppy forums, and there are a few ppl who are trying to get it working on puppy linux.
…now…what i have seen is that when ppl attempt to get mangler working with puppy its only missing a few libs– libgtkmm-2.4.so.1 — libgiomm-2.4.so.1

so im sure some 1 who knows wtf they are doing...should be able to compile a version in no time.

www.mangler.org

source:
http://www.mangler.org/downloads/mangler-1.2.0beta1.tar.gz




EDIT

So you have 2 choices if you want/need ventrillo

First one:(which i have working)

Install WINE:
http://www.murga-linux.com/puppy/viewtopic.php?t=37783
(several different versions..i ASSUME...any will work)
then get:
Uncompressed Ventrillo (installed to a folder):
http://www.mediafire.com/?koj1moutmid
then just open the ventrillo.exe ...done.
will be slightly buggy but very useable.

OR:
Try to get the libs for the mangler.pet made by scottman

Manger.pet
http://www.multiupload.com/8Q08Y0310V

Edited_times_total
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2385
Location: UK

PostPosted: Mon 14 Jun 2010, 12:30    Post_subject:  

I made a pet file for you, hunted for a lot of libs..

I didn't use the source files you posted.. Don't have a compile environment..

Anyway, I made it with a binary from somewhere.. (I think you posted it)

But I think it won't work anyway, it says you need GLIBC 2.7... Maybe Dpup of KDEpup or Lupu can run it, I don't know..

http://www.multiupload.com/8Q08Y0310V

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
Trip[ABK]

Joined: 12 Jun 2010
Posts: 29

PostPosted: Mon 14 Jun 2010, 14:09    Post_subject:    

awesome

thx very much man

im a try it out...hope it works..i'll let u know...hate to have to put a diff version of pup..just for one program.

uhh menu entry????

and ye says its missin these:

[13:14] <&Trip[ABK]> libspeex.so.1 libcelt0.so.0 libgiomm-2.4.so.1 libg15daemon_client.so.1 libasyncns.so.0 usr/lib/mangler
[13:15] <&Trip[ABK]> usr/lib/libpulse.so.0.4.1 nussbg kuv <---typen when i wasnt lookin at screen... libasyncsns.so.0
[13:15] <&Trip[ABK]> usr/lib/libpulse-simple.so.0.0.1 missing lib.. libasyncns.so.0

how2can fix Crying or Very sad

edit..started in terminal...

it wants that libspeex.so.1

Sad((((((((((((((( i will try to find


edit...
got the libspeex...tmk..from a deopsitory

now it wants the libcelt0.so.0 but that u can only get from an rpm....i installed a unrpm .petfrom ttuuxxx...i terminal to the directory..right...unrpm filename.rpm...and i get some..rpm2cpio invalid gzip magic
cpio premature end of archive....

....


so...

now i stuck once again...lol
Back to top
View user's profile Send_private_message 
Trip[ABK]

Joined: 12 Jun 2010
Posts: 29

PostPosted: Mon 14 Jun 2010, 19:40    Post_subject:    

downloaded lupu..5. w/e ....ran live cd...installed the mangler.pet...it gave me same error bout libspeex....got that again..installed it...and back to the same thing it wants the libcelt0 that i cant get to unrpm...


ragen...

edit

Tried to put the unrpm on lupu...it said it installed..tried it...said fu its not installed..try installin it.....reinstalled it...restarted X...tried to run it again..said nah.it aint installed...terminal'ed to the directory..tried unrpm filename.rpm again...it gave me the same..u practice black magic stpasdgas apisdhag error.... -_- Evil or Very Mad


i need this to work.... Confused


im startin to think..it might be easier to figuire out why ventrillo ...i assume crashes when i click next on the final step in the installer...where it actually installs....i know i had it workin b4....with wine..on a few different distros..
Back to top
View user's profile Send_private_message 
Trip[ABK]

Joined: 12 Jun 2010
Posts: 29

PostPosted: Mon 14 Jun 2010, 21:08    Post_subject:  

ok...

im a genious...

looooooooool


thx for the mangler...

but..

WINE BABEH WINE

i had tried a 98/me version of ventrilo..bam..crashed when i tried to install...so..im sittin here thinkin...WTF!$!#$@% right....then i was like hmmmmmm vent doesnt NEEEED to be installed....so....i had it installed on winblowz... went to the folder...zip'ed it..uploaded it...downloaded it..unzipped it..opened the .exe....BAM VENT WORKIN CHEA....put my server info in...and bam..connects...its slightly buggy with wine...i knew it would be..as i ran it b4..like...when u switch channels..the channel lists gets smashed up.. ez to fix..join another channel..go back...till the channels re-align lol...umm i can hear wut ppl say..they cant hear me...which doesnt really matter i use other pc to talk with..this one just is just the output anyway..i'll prolly mess with it later and get the mic to work..(but...on a side note..scott....why u made puparcade boot with the sound off and no sound display in tray......smack urself for that....i know how to get sound ofc..but..chea bad plan son) but chea..vents workin w/e...if someone wants to get this mangler.pup working then u should for the next person who wants to use it...and thx again scott for maken it.

but if someone has stumbled upon this...and is tryna get vent to work...
heres the ventrillo.zip ..just extract it inside pup anywhere...and open it with wine.
http://www.mediafire.com/?koj1moutmid <--ventrillo --for wine..go to google..type wine puppy linux -_-

proof yo lool

^not my normal ping btw lol some 1 was prolly downloading -_-
Back to top
View user's profile Send_private_message 
Nooblet0218

Joined: 21 May 2010
Posts: 103

PostPosted: Thu 08 Jul 2010, 01:27    Post_subject:  

I got this working!!!!!!



Smile

only thing is, i went down the compile from source route a long time ago, and after clearing all of the dependency problems, i would end up with some strange error while compiling... (I remember it being something like "Can't find undefined external variable "G_assert"" or something. So i decided to try to go down the debian package route. and i was able to eventually get it working! I think i had to make a symlink for one of the libraries from /usr/lib to /lib... I forget which one though :$.

pretty much though i installed the mangler.deb from their website, and then went to a terminal and kept typing 'mangler' then seeing that dependency error it would give me and then satisfying that one, rinse and repeat until it ran.

I was able to get a lot of the debians from the puppy package manager, but the ones i wasn't able to get I'll package up into a .tar.gz and attach to this post.

pretty much go to the package manager, and search and install the following debians:


if you can't find it easily searching the puppy package manager, it should be in my .tar attached to this file. There is one lib which after you install it, it won't be detected when you try to run mangler and it'll give you the same error, so just go to /usr/lib and find the name of the lib its asking for, symlink it into /lib and rename it exactly as mangler says

sorry that isn't the best way to install it but i don't know too much about compiling, and i don't think (or know) how to make a .pet out of debian files, if someone can toss me a link or tell me i'll do it.

but hey! it works

obviously this'll only work in Lucid puppy or dpup or any puppy that can install debian packages

edit: also after you're done you'll have to change the sound system in the mangler settings to ALSA (obviously, since puppy uses alsa Smile)
ManglerDebianPackages.tar.gz
Description 
gz

 Download 
Filename  ManglerDebianPackages.tar.gz 
Filesize  896.85 KB 
Downloaded  378 Time(s) 
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0650s ][ Queries: 13 (0.0051s) ][ GZIP on ]