Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 12:38
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
VirtualBox 3.1 for kernel 2.6.30.5 (puppy 4.3)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Thu 01 Jul 2010, 01:13    Post_subject:  

cosworth88 wrote:
thanks for the password!
when i try to start the virtual box i receive an error message

Code:
RTR3Init failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/etc/init.d/vboxdrv setup'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.


what i have to do?? i'm using lucid puppy
someone could help me please? ;(

That's most likely because the VirtualBox packages in this thread are built for Puppy 431 and its kernel version 2.6.30.5. Lucid Puppy (500 or 501) uses a newer kernel, so it can't use these particular packages.
I'll look around a bit, and see if there's already a package for Lucid Puppy or not, and then I'll edit this post accordingly.

EDIT: Well, I can't find a package for Lupu, but if you want there is one for Lighthouse Pup 500. It has the same kernel version as Lupu, but is an Spup (I think), so I don't know if the package would work with Lupu, but it definitely works with LightousePup (as intended). Just something to consider.
There was mention in one of the main Lupu threads that a VBox package might be developed. I've no idea when that'll happen, though.
Otherwise, Oracle distributes a *.run installer for VBox that you can try out. It's over here.

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Thu 01 Jul 2010, 01:15    Post_subject:  

Sorry. Accidentally double-posted.
Back to top
View user's profile Send_private_message Visit_website 
gronos04

Joined: 30 Dec 2006
Posts: 54
Location: Radfordia QLD

PostPosted: Thu 01 Jul 2010, 03:33    Post_subject:  

You will need the correct devx and kernel sources for your puppy version.
For lupu there is no kernel sources at this point.
There is a "wary kernel sources" for the same kernel but there is a disparity in the gcc version that it was compiled on and it doesn't work with VBox in lupu.
So if you would like to run VBox then you will need to choose another puppy version.
Download the latest .run version from VBox
Load devx
Load kernel souces for your kernel
to find kernel version, in terminal [ uname -r ]
SDL pet
QT pet
ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_dri-7.3-1.pet
in terminal [ adduser -D -H vboxusers ]
run the VBox.run.
That should do it.
Good luck
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Thu 01 Jul 2010, 09:46    Post_subject:  

gronos04 wrote:
You will need the correct devx and kernel sources for your puppy version.
For lupu there is no kernel sources at this point.

No, there is a kernel source SFS for Lucid Puppy. It's right here.
Quote:
Download the latest .run version from VBox
Load devx
Load kernel souces for your kernel
to find kernel version, in terminal [ uname -r ]
SDL pet
QT pet
ftp://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/xorg_xorg_dri-7.3-1.pet
in terminal [ adduser -D -H vboxusers ]
run the VBox.run.
That should do it.
Good luck

Point is, the packages in this thread still won't work, as they were made on and for Puppy 430 and 431 with kernel 2.6.30.5.
Back to top
View user's profile Send_private_message Visit_website 
gronos04

Joined: 30 Dec 2006
Posts: 54
Location: Radfordia QLD

PostPosted: Thu 01 Jul 2010, 12:37    Post_subject:  

That was the one I was referring to.
The VBox install log is helpful.
Go vanilla and get it working might be a good approach. Then go back and have another go on lupu.
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Thu 01 Jul 2010, 15:33    Post_subject:  

gronos04 wrote:
That was the one I was referring to.

Oops. Sorry. I wasn't aware that the SFS wasn't actually for Lupu.
Back to top
View user's profile Send_private_message Visit_website 
cosworth88

Joined: 29 Jun 2010
Posts: 3

PostPosted: Fri 02 Jul 2010, 10:59    Post_subject:  

mmm i can't use puppy 4,3 becouse i have problem with the graphic card...
can i use another program if virtualbox doesn't work on kernel 2.6.33?
sorry i'm a noob this is the first time i use linux
thanks
Back to top
View user's profile Send_private_message 
gronos04

Joined: 30 Dec 2006
Posts: 54
Location: Radfordia QLD

PostPosted: Fri 02 Jul 2010, 15:47    Post_subject:  

@cosworth88
You can use slaxer_pup which is a very solid base to build on.
http://minipc.org/slaxer/
Everything you need for VBox is at that site.(except the latest VBox.run)
The devx and the kernel sources can be installed directly.
Any problems Big_Bass is very helpful.
Also you can use the 'slackware' package repositories.
Back to top
View user's profile Send_private_message 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Fri 16 Jul 2010, 06:23    Post_subject:  

Hi everybody,

VirtualBox 3.2.6 seems to work with Luci Very Happy
Tested with luci-212 (till now only up to the Welcome screen of VBox).

Downloaded luci_devx_212.sfs, the kernel source (181MB) which 01micko provided
here (puppy, linux) and VirtualBox-3.2.6-63112-Linux_x86.run from here (all distributions, 386).
Installed the first 2 in Boot Manager.

Then :
Code:
adduser -D -H vboxusers
.
From the dir where the file is:
Code:
./VirtualBox-3.2.6-63112-Linux_x86.run


That's all Very Happy

Starting from a terminal with:
Code:
VirtualBox


Hope this helps

Rolf

Edit: 01Micko provided new kernel source with only 84MB, look here.

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.

Edited_time_total
Back to top
View user's profile Send_private_message 
rhadon


Joined: 27 Mar 2008
Posts: 1293
Location: Germany

PostPosted: Fri 16 Jul 2010, 17:11    Post_subject:  

I installed luci-212 and VirtualBox on a usb stick. Seems to work but installing XP stops because xp expects to be installed on a hd drive Evil or Very Mad

Has anybody a idea how to tell xp that my usb stick is a hard drive?
Or maybe a virtual harddrive in a virtual box (sounds good to me Wink )

Every hint appreciated.

~ Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send_private_message 
Atrum

Joined: 03 Sep 2010
Posts: 2

PostPosted: Tue 07 Sep 2010, 06:54    Post_subject: Virtualbox Problem
Sub_title: Can anyone see where I have made a mistake
 

Hello

I would like to ask for some advice as i have tried a few times to get my Virtualbox to actually work.
First of all I need to explain that I am quite new to Puppy and perhaps have missed something quite obvious for that I will apologise in advance.
The Puppy file versions are as follows
devx_431.sfs
Kernel_src/6.30.5-patched.sfs4.sfs
qt4-4.3.2.pet
SDL-1.2.13.pet
Xorg_xorg_dri-7.3-1.pet


and finally Virtualbox-3.2.8-k2.6.332-q1.pet

and now the problem, once I install and then click on the Menu Item, Virtualbox starts up and when I trz to run a virtual Machine I get the error

Failed to open a session for the virtual machine Puppy XP.
The virtual machine 'Puppy XP' has terminated unexpectedly during startup with exit code 1.


A more detailed error is
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

*I have seen this error in a previous post in this forum but did not see a solution.

When I do as the prompt suggests which is to

# sh vboxdrv setup

Stopping VirtualBox kernel module ...done.
Recompiling VirtualBox kernel module ...failed!

When I look to the LOG I see the following

vboxdrv: line 302: /opt/VirtualBox/src/vboxdrv/build_in_tmp: No such file or directory


I looked and could not find an src directory where it should be.

Phew, long text, but can anyone see where I am going very wrong?


Also> if I try to install a .run file example
VirtualBox-3.2.8-64453-Linux_x86.run

Puppy then complains

Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.........
VirtualBox Version 3.2.8 r64453 (2010-08-05T11:57:18Z) installer
Please install GNU make.
Please install the GNU compiler.
Problems were found which would prevent VirtualBox from installing.
Please correct these problems and try again.
Press Return to close this window...


Is that Normal?

Kind Regards Atrum
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Wed 15 Sep 2010, 11:27    Post_subject: Re: Virtualbox Problem
Sub_title: Different Puppy Versions
 

Atrum wrote:
The Puppy file versions are as follows
devx_431.sfs
Kernel_src/6.30.5-patched.sfs4.sfs
qt4-4.3.2.pet
SDL-1.2.13.pet
Xorg_xorg_dri-7.3-1.pet

From the devx and kernel source packages I assume you're running Puppy 431? Please correct me if I am mistaken.
Quote:
and finally Virtualbox-3.2.8-k2.6.332-q1.pet

This VirtualBox package is made for the wrong kernel, assuming you are in fact running Puppy 431.
431 uses kernel version 2.6.30.5- you can see that in the name of the kernel source SFS you listed above- but this VirtualBox package requires kernel 2.6.33.2- that can also be seen in the package name, with the string of number following a lower-case "k".

There are packages listed earlier in the thread for Puppy 431, for its kernel version, which you can use.

Alternatively, to use the specific VBox package named above, you'll need to use one of the newer Puppy versions. I'm guessing, but the -q1 near the end of the package name probably means it's made for Quirky or a puplet based on Quirky. If memory serves, gray (the OP and packager of many VBox PETs) made just such a puplet, and probably even the VBox package in question, if you want to try that. Search the forums if it interests you.
Back to top
View user's profile Send_private_message Visit_website 
Atrum

Joined: 03 Sep 2010
Posts: 2

PostPosted: Wed 15 Sep 2010, 12:14    Post_subject: Virtualbox Problem revealed  

Hi Asterisk

Thank you kindly for the reply. Your assumption is correct I am using 431.
I did not recognise the the numbers at the end of the Vbox file, but now that you have explained them it seems pretty obvious. Thank you again for the time you spent writting the reply. I will now search for the correct Puppy for that particular package.

Atrum
Back to top
View user's profile Send_private_message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Fri 17 Sep 2010, 10:21    Post_subject: Re: Virtualbox Problem revealed  

Atrum wrote:
Thank you kindly for the reply.

No problem.
Quote:
I will now search for the correct Puppy for that particular package.

Like I said, I think that would be Quirky. If you go to puppylinux.com, and follow the download links, you can get its ISO CD image.

If you want, though, there's yet another version of Puppy you can use: 511, the latest Lucid Puppy. Over in this thread, another user (vanchutr) was kind enough to post links to a binary and install script for VBox version 3.2.4. It worked in my installation of Lucid 511, so I made it into a PET and have uploaded it.
For details and a download link, head over to the thread I mentioned above, if you want.
Back to top
View user's profile Send_private_message Visit_website 
DanYHKim


Joined: 14 Sep 2008
Posts: 103

PostPosted: Thu 02 Dec 2010, 12:29    Post_subject: Unable to find files at http://www.puppylinux.asia/
Sub_title: subdirectory /tpp/* returns 404
 

Is there another location for the .pet files? I cannot get beyond
http://www.puppylinux.asia/ and into the /tpp/* directories.

I am using SeaMonkey from Puppy 4.3.1

I am not challenged for a login and password when I try to open the direct link. Am I doing this wrong?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1037s ][ Queries: 13 (0.0134s) ][ GZIP on ]