Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 21:56
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use Samsung ML-1660 printer?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Fri 02 Jul 2010, 05:52    Post subject:  How to use Samsung ML-1660 printer?  

This is quite a nice cheap laser printer with reasonable cost of consumables.

I actually did some research before I bought it as I wanted to make sure it came with linux drivers.

The CD that was in the box was blank, not a lot of use.

I had already downloaded the PPD file so I was confident I could get it working.

Anyway the printer arrived today. I used CUPS and added the PPD file and it didn't work. I was quite disappointed as this time I was prepared and it still didn't work.

I do think the problem may be with cups though. Each time I try to print the test page it stops the printer and I have to delete the job.

If I click on the printer job that has been stopped it comes up with a connection problem.

Does anyone know how to fix this problem? Please!

See attached.
print2.jpg
 Description   
 Filesize   28.44 KB
 Viewed   5815 Time(s)

print2.jpg

print1.jpg
 Description   
 Filesize   49.85 KB
 Viewed   5793 Time(s)

print1.jpg


_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8555
Location: Stratford, Ontario

PostPosted: Fri 02 Jul 2010, 08:58    Post subject:  

Many Samsung printers are covered by the Splix driver from here.. Get item #8.

However, the ML-1660 is not listed.

Where did you get the PPD file?

If Splix doesn't work, I have a PET made from the official Samsung drivers.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8555
Location: Stratford, Ontario

PostPosted: Sat 03 Jul 2010, 15:27    Post subject: Re: How to use Samsung ML-1660 printer?  

smokey01 wrote:
Does anyone know how to fix this problem? Please!

So what happened with your printer?
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Sat 03 Jul 2010, 18:35    Post subject: Re: How to use Samsung ML-1660 printer?  

rcrsn51 wrote:
smokey01 wrote:
Does anyone know how to fix this problem? Please!

So what happened with your printer?


Hi rcrsn51, Thanks for your reply.

I downloaded the printer driver from the Samsung web site. Firstly I just installed the ML-1660spl.ppd manually into CUPS. CUPS actually recognised the correct Samsung model that was connected to the PC running lupu-500.

When I did a Print Test Page, nothing happened. I then checked the jobs and noticed the printer had been stopped. After a lot of head scratching I noticed that The unified driver that I downloaded from Samsung had an installation file called autorun, so I clicked on it. It all looked very promising until I got to the part where I had to select the driver but none were displayed. The .ppd file was in the package as that's where I had extracted a copy of it earlier.

Next time I ran CUPS all I got was Internal Server Error 500. Now CUPS won't run at all. I actually like CUPS but now and then it can really give me the s&%s when it does things like this.

Now I'm not sure why this error occurred and how to fix it. I am considering reinstalling CUPS over the existing broken one but I have read sometimes that doesn't work.

The other thing I was thinking of trying was to place the ML-1660spl.ppd file in the correct area of the cups file structure. Previously I just placed in in the /root/ directory when testing it manually.

I did consider the Splix package but I also noticed my printer model wasn't there. I did try another couple of models from the CUPS package like 1650 & 1651 as some times you can get lucky, but they didn't work either.

I would be very interested to try your pet package if it includes the correct driver and I can repair CUPS.

I have tried this neat little printer under windows and it works very well. Very good value for money at $98 and only $75 for toner cartridges which will print 1500 pages, much better that most of the inkjets I have used in the past.

Thanks for your interest and help.

Grant

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8555
Location: Stratford, Ontario

PostPosted: Sat 03 Jul 2010, 19:35    Post subject:  

It's not enough to just install the PPD file. You also need the filter program that is included in the Samsung Unified Driver package that you have.

If you need to reinstall CUPS, read here. and get CUPS 1.3.11.

I have attached my Samsung driver PET below. It contains the key components from the Unified Driver and may work for you.

[Edit] Several users have reported that this PET did not install their printer, but they were successful using the official Samsung Unified Driver. However, running the official package in Lupu KILLS CUPS! It may work better in Wary/Quirky with CUPS 1.3.11, or it may work in Lupu after a CUPS downgrade. Buyer beware.
samsung_unified-2.5.3.pet
Description 
pet

 Download 
Filename  samsung_unified-2.5.3.pet 
Filesize  565.97 KB 
Downloaded  1162 Time(s) 

Last edited by rcrsn51 on Mon 04 Apr 2011, 12:39; edited 4 times in total
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Sat 03 Jul 2010, 20:36    Post subject:  

Hmmm ...

My apologies for crashing in smokey01 ... Your CUPS web interface indicates v1.4.x ... could you verify the CUPS version in use please? ... I also would suggest using cups-1.3.11 for a more stable usb backend for the time being. If you intend to try the splix-2.0 driver set, try out the ML-1640. The ML-16xx series uses (more or less) the same ppd internal descriptions.


Rgds
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Sat 03 Jul 2010, 20:58    Post subject:  

rcrsn51 wrote:
It's not enough to just install the PPD file. You also need the filter program that is included in the Samsung Unified Driver package that you have. Unfortunately, its auto-installer script isn't designed for Puppy and it sounds like it has somehow damaged CUPS.

If you need to reinstall CUPS, I would recommend the 1.3.11 version from here. Just install items 1,2 and 5.

I have attached my Samsung driver PET below. It contains the key components from the Unified Driver and may work for you.


rcrsn51 I installed Patriot pets 1,2 and 5 as suggested. Then I installed your Samsung pet. CUPS is working perfect and so is the Samsung ML-1660 printer. Thanks so much.

Patriot it was not your CUPS packages that crashed anything, it was in fact the Samsung installation program that I used to install the the driver. By installing 1.3.11 over the top of cups-1.4.3, I think that was the version, has now fixed the problem. I just need to add my other printer which is a HP Photosmart C3180.

I have already installed the PDF printer and it works fine.

Thanks guys

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8555
Location: Stratford, Ontario

PostPosted: Sat 03 Jul 2010, 21:36    Post subject:  

The hpijs-3.10.2-dynppd.pet from here has a driver for the Photosmart c3100 series that should work with your printer.

Regarding your problem with CUPS 1.4 after installing the Samsung unified driver package: This once again confirms my opinion about the flakiness of this new CUPS release.
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Sun 04 Jul 2010, 06:14    Post subject:  

rcrsn51 wrote:
The hpijs-3.10.2-dynppd.pet from here has a driver for the Photosmart c3100 series that should work with your printer.

Regarding your problem with CUPS 1.4 after installing the Samsung unified driver package: This once again confirms my opinion about the flakiness of this new CUPS release.


Thanks.

In the past I have used just the ppd file to get my HP3180 working. I'm not sure if it was dragging info from somewhere else though.



I wasn't having any problem with the 1.4 series until I broke it. I'm a great believer in the term "If it ain't broke, don't fix it".

I just need to swap some cables around now as I only have one for my printer. The Samsung never came with a USB cable. I guess for the price I shouldn't complain.

I did have hpliplite-3.9.8-mu-p4 and libnetsnmp-15-mu-p4 installed. I guess they are still installed so my hpC3180 and built in scanner should still work.

Thanks again.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8555
Location: Stratford, Ontario

PostPosted: Sun 04 Jul 2010, 06:28    Post subject:  

Quote:
In the past I have used just the ppd file to get my HP3180 working. I'm not sure if it was dragging info from somewhere else though.

It's a popular misconception that a PPD file acts as a complete printer driver. It is simply a configuration file that sets up the actual driver.

The only time that a PPD file will work on its own is when it uses one of the basic built-in Ghostscript drivers that come with Puppy.
Back to top
View user's profile Send private message 
bc272

Joined: 23 Jul 2010
Posts: 7

PostPosted: Sat 24 Jul 2010, 00:03    Post subject: On the samsung_unified-2.5.3.pet driver
Subject description: got my samsung clp-600n to work with that
 

Maybe something helpful here, new to puppy. I got my samsung clp-600n to print using puppy 4.3.1 which I believe is using the samsung_unified-2.5.3.pet driver. Printer installed says using SPL-C driver and pretty sure it is from that pet file (maddening study over several days)--only pet file other than foo2 (whatever) I found in pet format. This last install of printer I type description as Samsung Clp-600, location as #1 usb clp-600 (which I got from description when looking in drop down for driver). Those three things might ascribe to success as in studying this never saw what to put specifically for description and location. Had installed the foo2 driver before, still shows there and recommends, but it never worked, this time chose samsung clp-600 (SPL-C) next to it. Prints, printer came to life, unbelievable, color ok, little light, not complaining. Thanks very much for that pet file.
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Sat 07 Aug 2010, 18:34    Post subject:  

princealway wrote:
The ML-1660 Print Screen button - located on the control panel of the printer - you can print the contents of your screen, quick and easy, even when you're away from your desk. Just One Touch is all it takes. A quick key prints the entire screen, as you see on your monitor. Hold the button for more than two seconds and the ML-1660 prints the last object you selected in your monitor


What version of Puppy Linux are you using to achieve this?

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
novax

Joined: 08 Oct 2010
Posts: 24
Location: Piedmont, EU

PostPosted: Sat 20 Nov 2010, 14:56    Post subject:  

Hello

I got the same difficulties, with a Samsung ML-1710P printer, using Lucid Puppy 5.1.1 Quickset Edition.
I downloaded and installed CUPS 1.3.11 (from the link posted by rcrsn51 in his third post), and the Samsung driver (from the Samsung's web page for non-US products): all works fine.

Thanks
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0738s ][ Queries: 13 (0.0062s) ][ GZIP on ]