Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Nov 2014, 19:49
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
PIdgin 2.7.1
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
RoxFox64

Joined: 31 Jul 2010
Posts: 9

PostPosted: Sat 31 Jul 2010, 03:23    Post subject:  PIdgin 2.7.1
Subject description: Application + Dependencies
 

Now, it IS a valid question as to why I'm reposting Pidgin 2.7.1.
The answer to this is that the last post doesn't link you to the Required dependencies.

Liboicl wrote:
Quote:
Pidgin is an easy to use and free chat client used by millions. Connect to AIM, MSN, Yahoo, and more chat networks all at once.

Supported chat networks:

* AIM
* Bonjour
* Gadu-Gadu
* Google Talk
* Groupwise
* ICQ
* IRC
* MSN
* MXit
* MySpaceIM
* QQ
* SILC
* SIMPLE
* Sametime
* XMPP
* Yahoo!
* Zephyr


I compiliied it in Puppy 4.3.1. I disabled tk, dbus, & avahi.

If it crashes try leaving the first shown window open. This may just be a secluded problem, but it happened to me even on 2.6.6, compiled by Wolf Pup.


[Pidgin 2.7.1]
pidgin-libxcb-deps.pet
Description  Dependencies for Pidgin 2.7.1
pet

 Download 
Filename  pidgin-libxcb-deps.pet 
Filesize  15.25 KB 
Downloaded  682 Time(s) 
Back to top
View user's profile Send private message 
noalternative

Joined: 10 Nov 2009
Posts: 43

PostPosted: Mon 09 Aug 2010, 16:15    Post subject:  

These dependencies wouldn't install. The install froze at " creating menu" even when I attempted to install several times. Then it left an entry in pet get but when I opened pidgin it still said there were dependencies missing. Then the pet wouldn't uninstall.
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
Makoto


Joined: 03 Sep 2009
Posts: 1808
Location: Out wandering... maybe.

PostPosted: Tue 10 Aug 2010, 17:01    Post subject:  

Which dependencies does it claim are missing?

I can't remember if I mentioned it in a previous reply (elsewhere) to you, but I should probably also note that Pidgin 2.7.0 and higher have increased requirements for GTK+ and glib:

Quote:
# Changed GTK+ minimum version requirement to 2.10.0.
# Changed GLib minimum version requirement to 2.12.0.


I don't know if Puppy 4.2.1 meets those minimum requirements, offhand - or whether or not they could be simply packed within a Pidgin .pet.

Just curious - I'm not saying you should upgrade, but is there a reason you don't want to at least upgrade to Puppy 4.3.1? I was with 4.2.1, myself, for quite a while, even after 4.3.1 was released... but one of the reasons I updated was because I couldn't get many .pets that specifically worked with 4.2.1, anymore, including Pidgin. Embarassed So, it was either figure out how to compile it myself (I actually did have the devx sfs installed, but the instructions for compiling Pidgin did look a little daunting), hope someone posted a 4.2.1 compatible pet, or upgrade. (oops - that makes it sound like it was the only reason I upgraded. Very Happy)

According to the Pidgin support mailing list (I haven't checked the website), 2.7.3 was just released.

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
noalternative

Joined: 10 Nov 2009
Posts: 43

PostPosted: Tue 10 Aug 2010, 20:06    Post subject:  

4,31 won't boot on my computer. I have a bad hard drive and I am booting from a flash drive. 4.31 gets picky about having a working hard drive.

Here are the missing dependencies according to pet-get

Quote:
These dependencies required by pidgin-2.7.1 package are missing:
File /usr/bin/finch has these missing library files:
libgstreamer-0.10.so.0 libgstfarsight-0.10.so.0 libgstbase-0.10.so.0 libgstinterfaces-0.10.so.0 libgstreamer-0.10.so.0
File /usr/bin/pidgin has these missing library files:
libgstreamer-0.10.so.0 libgtkspell.so.0 libgio-2.0.so.0 libgstfarsight-0.10.so.0 libgstbase-0.10.so.0 libgstinterfaces-0.10.so.0 libgstreamer-0.10.so.0
File /usr/lib/pidgin/ticker.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/vvconfig.so has these missing library files:
libgio-2.0.so.0 libgstreamer-0.10.so.0
File /usr/lib/pidgin/timestamp_format.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/pidginrc.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/history.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/sendbutton.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/iconaway.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/extplacement.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/xmppdisco.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/themeedit.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/xmppconsole.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/spellchk.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/markerline.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/convcolors.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/gestures.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/timestamp.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/gtkbuddynote.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/pidgin/notify.so has these missing library files:
libgio-2.0.so.0
File /usr/lib/purple-2/libsametime.so has these missing library files:
libmeanwhile.so.1
File /usr/lib/libpurple.so.0.7.1 has these missing library files:
libgstfarsight-0.10.so.0 libgstbase-0.10.so.0 libgstinterfaces-0.10.so.0 libgstreamer-0.10.so.0
File /usr/lib/gnt/s.so has these missing library files:
libgstfarsight-0.10.so.0 libgstbase-0.10.so.0 libgstinterfaces-0.10.so.0 libgstreamer-0.10.so.0

The PETget package manager does not know what package/s has/have these libraries.
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
Makoto


Joined: 03 Sep 2009
Posts: 1808
Location: Out wandering... maybe.

PostPosted: Tue 10 Aug 2010, 22:20    Post subject:  

Tried any of the v5 series? (Not that I have... Embarassed )

I think there are .pet or .pup installers floating around for most of those (gstreamer, gtkspell, meanwhile, farsight, etc.), but I haven't yet found them. Perhaps someone else might have a quick suggestion?

The libgio-2.0.so.0.pet I found here might help with the libgio messages.

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0735s ][ Queries: 13 (0.0150s) ][ GZIP on ]