Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 11:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
mudlet pet
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
mystmaiden

Joined: 23 Jul 2009
Posts: 93

PostPosted: Sat 31 Jul 2010, 15:08    Post_subject:  mudlet pet
Sub_title: Needing a mud client for puppy
 

I'm using puppy 4.2 and would love to have a pet package of mudlet. The source code is at http://www.mudlet.org/download/

There is also another puppy user wishing for a mud client, but I'm not sure which version of puppy he has.

thanks

mystmaiden
Back to top
View user's profile Send_private_message 
noryb009

Joined: 20 Mar 2010
Posts: 540

PostPosted: Sun 08 Aug 2010, 21:20    Post_subject:  

You can just use the installers that they offer. If you go to http://www.mudlet.org/download/, then expand the "Linux" section, it will show "Linux Mudlet 1.1.1 normal" (use "Linux Mudlet 1.1.1 64bit" if you have a 64 bit CPU). It should work. (if it doesn't, just post again).
Back to top
View user's profile Send_private_message 
mystmaiden

Joined: 23 Jul 2009
Posts: 93

PostPosted: Mon 09 Aug 2010, 20:03    Post_subject:  

Thank you for the reply, I'll give it a try. I thought it needed to be packaged differently to use with puppy.

I also stumbled across this just now, http://sourceforge.net/projects/kyndig/ which is mud magic client in a deb package in case anyone else should be looking for one.
myst
Back to top
View user's profile Send_private_message 
mystmaiden

Joined: 23 Jul 2009
Posts: 93

PostPosted: Wed 11 Aug 2010, 03:32    Post_subject:  

I downloaded it, and installed it . The installer puts it in /opt but when I open the file and click on the run.Mudlet.desktop icon, nothing happens. I'm not sure what to do next there.

So I tried the deb package of mud magic from http://sourceforge.net/projects/kyndig/ thinking maybe I'd have better luck. I get:

can't run archiver executable
failure to run child process 'ar' (no such file or directory)

Sad Any help getting one or the other of these going would be appreciated.


thanks

mystmaiden
Back to top
View user's profile Send_private_message 
sickgut


Joined: 23 Mar 2010
Posts: 1157
Location: Tasmania, Australia in the mountains.

PostPosted: Mon 20 Sep 2010, 09:42    Post_subject:  

can seem to get mudlet to work and gmud doesnt want to either. ive been using mushclient under wine for a gui client but i would also like a propper one for puppy. ill see if i can find one that works
Back to top
View user's profile Send_private_message Visit_website 
kenbanistu

Joined: 08 Jan 2009
Posts: 30

PostPosted: Mon 15 Nov 2010, 22:44    Post_subject:  

I was able to get Mudlet working. When I clicked on the run-mudlet.sh file nothing would happen. One thing I've learned on these forums is that when something won't run, running it in the terminal can sometimes give you clues as to why not. In this case, I found out that there are two missing files: libQtCore.so.4 and libQtGui.so.4

The install program did include the files libQtCore.so.4.6.0 and libQtGui.so.4.6.0 so by using symlinks I was able to get the program running. Here is how to do that: in Rox, go to /opt/mudlet-1.1.1/bin. Right click on libQtCore.so.4.6.0. Under "File 'libQtCore.so.4.6.0'" click on "Link" and name the link libQtCore.so.4

Now do the same thing with libQtGui.so.4.6.0, naming the link libQtGui.so.4

Now when you click on run-mudlet.sh it should run. It does for me, and seems to be running correctly except that the Manual button doesn't do anything. I wish it did. I need a manual because there are features that I don't know how to use, or what they are even used for. I need to go back to the site and see if there is an online manual I can look at.

There is one more thing you might want to do. In the /opt/mudlet-1.1.1 folder is a file called Run Mudlet.desktop (I didn't think file names could have a space in them under Linux, but this one has one and it doesn't seem to be hurting anything, so maybe I'm wrong). Open this up in Geany and add a line that says "Categories=Game" (without the quotes). Save the file and then move or copy it to /usr/share/applications. Refresh Menus or reboot and you should have a menu entry for mudlet under "Fun".

I am new to mud games (though I knew what they were) and look forward to trying them out. I think mudconnect.com has a good listing of games. I'll pick one that looks good to me and try it out.

--Ken
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Fri 03 Dec 2010, 09:37    Post_subject: powwow mume client  

Hi,

I made a mud client for mume (Powwow) last year. Link is here:

http://www.murga-linux.com/puppy/viewtopic.php?t=51072&sid=5409e5a9603c3a2981539577612c96f8

It was made for puppy 431, but I guess it will also work for newer 32 bit versions.

the download link probably is not working any more, I uploaded the pet to here.

I made a menu entry which auto opens mume, but you can
use the #connect command to play any mud you want.

Powwow doc file is also included.

emil
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0608s ][ Queries: 12 (0.0038s) ][ GZIP on ]