Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 04:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
CPU FREQUENCY SCALING 1.3-2 - Ondemand (dynamic) - GUI
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 5 of 6 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Mon 19 Jul 2010, 07:24    Post_subject:  

jamesbond wrote:
Hi trio,

Based on hints from rcrsn51 above, I've taken the liberty to fix up your code and bump the version to 1.3-3. The pet is attached here. It's only one line change in cpu_func file.

It will work whether or not modprobe.conf is moved to /etc/modprobe.d

cheers!
You forgot to update the version number in the GUI.
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send_private_message Visit_website 
jamesbond

Joined: 26 Feb 2007
Posts: 2227
Location: The Blue Marble

PostPosted: Wed 21 Jul 2010, 02:36    Post_subject:  

edoc, it may or may not. Just give it a try.

Chronic overheating (to the point that the laptop shutdown automatically to prevent damage) is usually caused by either faulty fan or dusty heatpipe. Replacing the fan and cleaning those heatpipes usually work better than any other software trick out there.

abushcrafter, yeah my bad. I didn't see the version number there ... just did it so quickly to get it working Smile Where is trio by the way? I would expect him to release the "official" version and update the first post :p

cheers!

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Tue 10 Aug 2010, 09:18    Post_subject:  

Hi,

I'm trying to get this working with my pentium dual-core processor, but all of the intel modules are 'not compatible' using the 1.3-2 version. Is there anything i can do here to make this work for me on my laptop?

_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send_private_message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 10 Aug 2010, 09:36    Post_subject:  

stiginge wrote:
Hi,

I'm trying to get this working with my pentium dual-core processor, but all of the intel modules are 'not compatible' using the 1.3-2 version. Is there anything i can do here to make this work for me on my laptop?


Did you follow this link http://www.murga-linux.com/puppy/viewtopic.php?p=424549#424549

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 10 Aug 2010, 09:39    Post_subject:  

stiginge wrote:
Hi,

I'm trying to get this working with my pentium dual-core processor, but all of the intel modules are 'not compatible' using the 1.3-2 version. Is there anything i can do here to make this work for me on my laptop?


Did you follow this link http://www.murga-linux.com/puppy/viewtopic.php?p=424549#424549

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Tue 10 Aug 2010, 12:06    Post_subject:  

@stiginge: If you can't find the solution buried in that thread, here it is again:

Locate the file /usr/local/cpu-freq/cpu_func and open it in a text editor.

Line 15 currently says
Code:
if [ ! "`cat /tmp/modprobe_module.tmp`" ] ; then

Change it to
Code:
if [ $? -eq 0 ] ; then

Make sure you leave spaces on either side of the [ ] characters.
Back to top
View user's profile Send_private_message 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Tue 10 Aug 2010, 22:40    Post_subject:  

That's great thanks rcrsn51, after changing that code at line 15 it allowed me to input the min anx max frequencies. The fan on my laptop seems to be coming on as frequently as before (if not more frequently), but not making as much noise as before. I'm afraid now that I might damage the hardware on my system without proper cooling Confused I set the min at 800 and reduced the max from 1600 to 1200 because it wasn't making any difference with the default of 1600.

Is there documentation on how this app works anywhere on the murga linux forums? I looked here http://www.murga-linux.com/puppy/viewtopic.php?t=45143&start=15 but didn't find any detailing of how this works and what things mean[/code]

_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send_private_message 
steve_s


Joined: 26 May 2008
Posts: 1545
Location: Austin, TX, USA

PostPosted: Tue 17 Aug 2010, 19:46    Post_subject:  

trio: love the gui. This is the second time for me to do this with a laptop and I did following the advise from the other thread last time...this gui would have made it much easier...

But right now I'm using a laptop that isn't responding to this. First I modprobed manually all those in the list, got fatal errors on all of them.

Then tried the gui, same result: none of the modules worked, all gave fatal errors.

This laptop is an Hp Pavillion N5470 that I'm running kdpup on.

Any ideas? Other module options?
Back to top
View user's profile Send_private_message Visit_website 
stiginge


Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Tue 17 Aug 2010, 21:30    Post_subject:  

Since installing cpufreq I've discovered that my laptop is freezing/crashing every day. I don't know if it's related to cpu usage or just happening at regular time intervals, but I'm definitely getting a black screen and unresponsive keyboard fairly often.
_________________
Buy silver, crash JPMorgan
Back to top
View user's profile Send_private_message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Wed 18 Aug 2010, 00:55    Post_subject:  

steve_s wrote:
trio: love the gui. This is the second time for me to do this with a laptop and I did following the advise from the other thread last time...this gui would have made it much easier...

But right now I'm using a laptop that isn't responding to this. First I modprobed manually all those in the list, got fatal errors on all of them.

Then tried the gui, same result: none of the modules worked, all gave fatal errors.

This laptop is an Hp Pavillion N5470 that I'm running kdpup on.

Any ideas? Other module options?


This might help http://www.murga-linux.com/puppy/viewtopic.php?p=424694#424694

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
cfli1688c1

Joined: 02 Aug 2010
Posts: 6

PostPosted: Tue 24 Aug 2010, 17:57    Post_subject:  

I am using the livecd, how do I get the cpu scaling to scale to the new frequency without rebooting? Thanks.
Back to top
View user's profile Send_private_message 
jogreer

Joined: 28 Sep 2010
Posts: 22

PostPosted: Tue 28 Sep 2010, 20:28    Post_subject: Can't force scaling_governor to ondemand
Sub_title: Bios problem or CPU problem?
 

EDIT: This seems to be an issue with the p4clockmod module ever since kernel 2.6.30. There is a fix at http://forum.sabayon.org/viewtopic.php?f=56&t=20313 but it has to be implemented to kernel. Can someone please compile a new kernel with this fix into next Puppy version? I'm sure it will fix a few people's problems.

Hi. I'm using a nx6110 with latest BIOS F.15 and latest Puppylinux 5.1.1.

I've been reading up a lot about the cpufreq utility and haven't figured out why I can't force /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor to use ondemand, even though scaling_available_governors tells me I can run ondemand and performance. However it is always stuck to performance, even if I run the 'echo ondemand...' command in /etc/rc.d/rc.local. If I lower the maximum allowed frequency from 1500000 to 187500, the CPU runs at only 187500, so the CPU is at least capable of switching frequency and staying there.

ACPI says that throttling is enabled (shows T0-T7 under /proc/acpi/processor/CPU0/throttling) and T0 is selected (which is 100%), I have successfully been using throttling in WinXP on this same machine with RMClock.

In a document (OLS2006-ondemand-paper.pdf) about the cpufreq option in the kernel, I quote: "Also note that if your CPU is not capable of fast switching of CPU frequency, then the above echo command may fail and you may continue to use the governor that was set before."

I can also see that the folder /sys/devices/system/cpu/cpu0/cpufreq/ondemand/ is missing, and I cannot create it using mkdir.

So should I conclude that the CPU is not capable of 'fast switching of cpu frequency'?
Is it a kernel issue, should I wait for another kernel build?
Can I regulate the throttling on demand in stead?

Regards, Jonathan
Back to top
View user's profile Send_private_message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Tue 28 Sep 2010, 22:25    Post_subject:  

According to google, that machine has a cpu that supports speedstep. Are you sure you should be using p4clockmod?
Back to top
View user's profile Send_private_message Visit_website 
jogreer

Joined: 28 Sep 2010
Posts: 22

PostPosted: Wed 29 Sep 2010, 07:23    Post_subject: No support for speedstep
Sub_title: No support for speedstep
 

No, the only working module is p4clockmod, the three speedstep modules don't load when I select them in Clock Frequency Scaling Tool. The issue is with the kernel module p4clockmod that has been changed where the cpuinfo.transition_latency should be 1000000, but has been changed in 2.6.30+ to 1000001. That breaks the ondemand function for slow CPU Frequency switching.

Dmesg tells me that "p4-clockmod: P4/Xeon(TM) CPU On-Demand Clock Modulation available ondemand governor failed, too long transition latency of HW, fallback to performance governor".

Can someone find out if this is to be fixed in future kernels or can someone make a patch to the current 2.6.33 kernel?

EDIT: p4clockmod says it has a dependancy on speedstep-lib, so yes it uses speedstep, but no it cannot load the other speedstep-modules in cpufreq.
filename: /lib/modules/2.6.33.2/kernel/arch/x86/kernel/cpu/cpufreq/p4-clockmod.ko
license: GPL
description: cpufreq driver for Pentium(TM) 4/Xeon(TM)
author: Zwane Mwaikambo <zwane@commfireservices.com>
depends: speedstep-lib
vermagic: 2.6.33.2 SMP mod_unload modversions 486

Edited_time_total
Back to top
View user's profile Send_private_message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Wed 29 Sep 2010, 09:18    Post_subject:  

Does powersave work? If you can confirm that this actually gives you a better battery life I'll patch the kernel for Puppeee and Fluppy. But tests with p4clockmod on the Eee just gave worse performance and the same battery life, so it's sort of pointless.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 5 of 6 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0910s ][ Queries: 13 (0.0061s) ][ GZIP on ]