Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 03:51
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LupQ-510s FINALIZED - Lucid Puppy Quickset edition
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 6 of 15 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 13, 14, 15 Next
Author Message
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Tue 24 Aug 2010, 19:27    Post_subject: Re: new mtpaint available  

don570 wrote:
There's a new version of mtPaint just out.
http://github.com/wjaguar/mtPaint
It opens the SVG format which can come in handy.
I made a pet and it's available
http://www.datafilehost.com/download-1ac1f5c9.html

Thanks, got it, seems working fine.
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Tue 24 Aug 2010, 20:08    Post_subject: mtpaint compile  

I compiled mtpaint on lighthouse 4.43
using configuration
Code:
./configure --bindir=/usr/bin release GIF gif jpeg tiff gtk2 staticft intl


Then I monkeyed around with the links and libraries until
I got a pet that would run on a bunch of Puppies including luci218

Also I made sure that desktop file had the same odd name that Puppy
uses in order to block the original desktop file.
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Tue 24 Aug 2010, 20:09    Post_subject: Portability of customized Lupq  

I discussed before at the topic of Lucid Puppy 5.1 development on the portability of the customized Lucid Puppy.
Of course our QuickSet edition(lupq) still keeps the portability with the customized one.

Imagine a lupq pre-installed your favourite browser, applications and language pack.
You can bring it with you to another PC, Internet café, or present it to your friends.

There are 2 options, remaster CD or USB pen drive with pupsave(lupqsave).
Remastaring is not so difficult using the remasterpup2. There can be some tips and traps, but I do not describe the detail here.

USB pen drive is so easy if the PC can boot up from it. Use frugalinstaller and grub4dosconfig both lupq has.
  1. Install lupq on a USB drive, do not make pupsave at this point of time.
    The Furugal installer with Grub4DosConfig is easy and safe. You can setup all the things accepting the defaults except at the first dialog of the Grub4DosConfig. Select the target drive and recommended to tik on the 'Search within only this drive'.

    If you find the difficulty with boot up the USB drive on your PC, try the Boot Flash.
  2. boot up from the drive.
  3. reboot and make pupsave first. install nothing before making pupsave.
  4. install browser, libflashplayer, any of your favourite applications and language pack if you need.
  5. shutdown PC. The pupsave shall be updated and powered off. Then take out the USB drive
Thats all.

TIPS:
  • Once you run xorgwizard, then the xorg.conf be sticky on the PC. Copy /etc/X11/xorg.conf1 to /etc/X11/xorg.conf to recover portability. And type next command on the virtual terminal to sync the keyboard layout.
    Code:
    keymap-set --load

  • To arise countrywizard automatically, remove /root/.config/firstsetup directory.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 25 Aug 2010, 01:34    Post_subject:  

I fail to find lupq 6 on the mirror.
_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 25 Aug 2010, 02:06    Post_subject: mirror  

nooby wrote:
I fail to find lupq 6 on the mirror.

Takes some days delay on the mirror.
Download from the primary on that case please.
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 25 Aug 2010, 05:16    Post_subject: Calling for translations  

Lupq desktop and some scripts are i18n ready but calling for translations.
See another topic Translate Lupq - QuickSet edition of Lucid Puppy

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 25 Aug 2010, 10:14    Post_subject: CPU Frequency Scaling Tool
Sub_title: cpu_freq.desktop in lupq-006 is wrong
 

The 'CPU Frequency Scaling Tool' on lupq-006 does not work.

/usr/share/applications/cpu_freq.desktop
wrong:
Code:
Exec=/usr/local/cpu-freq/cpu_freq

correct:
Code:
Exec=/usr/local/cpu-freq/cpu_freq -start


after editing cpu_freq.desktop,
Menu > Shutdown > Refresh Desktop

apologize for your inconvenience.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Thu 26 Aug 2010, 02:06    Post_subject: Refresh drive icons
Sub_title: /sbin/clean_desk_icons not executable
 

/sbin/clean_desk_icons on lupq-006 does not have the permission of executable.
The drive icons on the desktop may not be refreshed properly with 'Refresh Desktop' in some case.

Type on the terminal
Code:
chmod +x /sbin/clean_desk_icons


apologize for your inconvenience.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 26 Aug 2010, 11:12    Post_subject:  

Testing the Lupq-006 iso.

I am using FireFox 4.03 but it gives an error when trying to do Flash.

Quote:

Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-mW9NzfFzzL: Connection refused)



I was lazy and kept the pupsave file from 004 and it did an automatic update and it seems to work well. I went to the news site for Lucid Puppy and updated both FireFox to 4.x and Opera to the latest version.

Could that explain that error message and that it never start playing the file?


What is obvious is that graphics on html pages like this forum is that if one only have 500MB RAM then the rendering of the page split up to unreadable if one use the far right bar to scroll by dragging it down.

So one have to use the Page Down button instead or clear the page using F5 to refresh it.

I am lazy today so have not tested Wine and Spotfy or Flashplayer or something.

I will test BBC and CNN and youtube video later.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Thu 26 Aug 2010, 11:44    Post_subject: FireFox problem?  

Thanks for testing

nooby wrote:
What is obvious is that graphics on html pages like this forum is that if one only have 500MB RAM then the rendering of the page split up to unreadable if one use the far right bar to scroll by dragging it down.

So one have to use the Page Down button instead or clear the page using F5 to refresh it. .

How about maximum window?

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 26 Aug 2010, 16:11    Post_subject:  

How about maximum window?

I only have max looking at pictures of cars. Wink

You mean one can have max when doing html?

I never thought of doing that. I am back in Q1.0 now and have to go to bed. If I do remember I can test next day.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Thu 26 Aug 2010, 17:21    Post_subject: FireFox error message (libORBit)
Sub_title: happens the old version of libORBit contaminate
 

nooby wrote:
I am using FireFox 4.03 but it gives an error when trying to do Flash.
Quote:
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Failed to connect to socket /tmp/dbus-mW9NzfFzzL: Connection refused)

I was lazy and kept the pupsave file from 004 and it did an automatic update and it seems to work well. I went to the news site for Lucid Puppy and updated both FireFox to 4.x and Opera to the latest version.

Could that explain that error message and that it never start playing the file?


You can use the firefox to browse local and internet files even you have got such error message.
I am not sure why it happens but the issue comes from the version of libORBit.
The links shoud be:
Code:
/usr/lib/libORBit-2.so -> libORBit-2.so.0.1.0
/usr/lib/libORBit-2.so.0 -> libORBit-2.so.0.1.0
/usr/lib/libORBitCosNaming-2.so -> libORBitCosNaming-2.so.0.1.0
/usr/lib/libORBitCosNaming-2.so.0 -> libORBitCosNaming-2.so.0.1.0
/usr/lib/libORBit-imodule-2.so -> libORBit-imodule-2.so.0.0.0
/usr/lib/libORBit-imodule-2.so.0 -> libORBit-imodule-2.so.0.0.0

Correct links if they were wrong, the error shall be fixed.

P.S.
Note that lupq does not contain Adobe Flash Player. You need to install the libflashplayer PET available from here.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 27 Aug 2010, 07:57    Post_subject:  

Thanks seems to have cleared up and Flash plays too and no graphic problems anymore.

I like that one can enter a directory without having to wait for it to be indexed.

But I must have done something wrong because I don't have the Browser icon.

There is a Chose Default Browser in the tray but no icon on the Desktop.

So I need to either use that chose again or go into Menu Internet Firefox.

Would be cool to have the FF icon directly on the Desktop linked to starting that app.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
s-kami


Joined: 30 Apr 2009
Posts: 50
Location: Budapest

PostPosted: Fri 27 Aug 2010, 13:12    Post_subject: Hungarian language pack
Sub_title: for lupq-006
 

Hello !

At first congratulation for your great job on localizing and making Quickset editions.

I made a hungarian language pack for lupq-006.
Here it is[url] ftp://puppylinux.hu/puppylinux/localization/hungarian/Lupq-003-HUNpack-02.pet[/url]

Only the icewm is my problem, won't display correctly the menu items but in my SevenPuppy07 shows nice.

What to do ?
Vágólap01.jpg
 Description   
 Filesize   63.07 KB
 Viewed   913 Time(s)

Vágólap01.jpg

Back to top
View user's profile Send_private_message Visit_website MSNM 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Fri 27 Aug 2010, 19:55    Post_subject: Re: Hungarian language pack
Sub_title: for lupq-006
 

s-kami wrote:
I made a hungarian language pack for lupq-006.
Only the icewm is my problem, won't display correctly the menu items but in my SevenPuppy07 shows nice.

Szia, s-kami!
i like to express my respect to you and the hungarian community for the effort of translating puppies. i have sympathy with you because our languages japanese and magyal may have the same root from mongolian.

I am now working on a new system of translating desktop, hopefully i can offer it soon, in couple of days. The iceWM issue may be discussed on the new platform.

There is another topic for these matter. See you there next time.
Köszönöm, és viszlát.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 6 of 15 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 13, 14, 15 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1018s ][ Queries: 13 (0.0067s) ][ GZIP on ]