Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 

The time now is Sun 09 Aug 2020, 07:39
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
USB flash drives not detected as boot devices. Why?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message

Joined: 21 Jun 2010
Posts: 145

PostPosted: Tue 07 Sep 2010, 00:44    Post subject:  USB flash drives not detected as boot devices. Why?
Subject description: But USB external hard disk drives are.

I want to be able to boot up my laptop from USB flash drives. However, no matter what boot loader I try the laptop does not recognise flash drives as boot devices and just ignores them.

My most recent attempt was the Bootflash script from Wary 70. The Combo format option causes the computer to freeze when I try and run it but the other options run but don't make the flash drives any more detectable.

I have previously tried the Puppy universal installer, Unetbootin and more manual formatting and installing of different bootloaders.

I have read about Plop but I can't seem to understand the point of it. While it raves on a lot about USB booting it looks to me like that is a false description and shouldn't refer to booting at all.

If it is not possible for my laptop to boot from flash drives then okay but I need to understand why it treats USB Hard Disk Drives differently and if there is anything that that indicates about flash drives.

Thanks for any clues.
Back to top
View user's profile Send private message 

Joined: 05 Sep 2006
Posts: 13129
Location: Stratford, Ontario

PostPosted: Tue 07 Sep 2010, 08:35    Post subject:  

USB bootability varies widely among different machines and BIOS's. I have a fairly recent machine that will only boot from a USB CD-ROM drive.

Since you have tried several techniques to make a bootable flash drive and they all failed, the most likely culprit is your particular machine. You need to find some other machines to include in your testing.

but I need to understand why it treats USB Hard Disk Drives differently

That question can only be answered by the manufacturer of your BIOS.
Back to top
View user's profile Send private message 

Joined: 29 Jan 2006
Posts: 4499
Location: Sydney Australia

PostPosted: Tue 07 Sep 2010, 21:08    Post subject:  

Why it just pays to run GParted in Puppy Linux
and reformat your USB.

As usual backup your data before doing the above.


Believe it or not many USBs come out with weird Fat32 formatting.

I don't know what the agenda is but some products
show up in GParted in Puppy Linux with a strange looking triangle.


An example was an 8 gig Medion usb.

I installed Puppy to it and I the ran >> Gparted
to right click on it to >> Manage Flags.

But the USB had a strange question mark on it....
even though it was formatted in Fat32.
I have seen this behavior on some other USB brands as well.

I was trying to get the Medion usb to boot Puppy 4.3.1
Gparted refused to let me tick >> Boot ...and ....LBA.....
which are essential.

I had to reformat it in NTFS because GParted refused
to allow Fat 32 formatting on it.

After the above I closed GParted and then reformatted the USB
back to Fat32 and enabled ...Boot and LBA.

Then Puppy 4.3.1 booted after re-installing to USB.

Camera Card issues.
I bought a 2 gig camera card...for an ALDI car radio.
Featured USB or SD card option to play music.

I tried to install 2 gigs of music to it.
It would not allow more than 1.7 gigs.
I tried it in Puppy...checked that it was >> Fat32.
Yes...but there again was that strange question mark.

I downloaded a Panasonic Card formatter 4 Windows.
Reformatted it...but the same problem.

Booted Puppy...ran GParted..formatted to >> Fat 32
checked LBA and boot....copied the full 2 gigs and >> drumroll...
the card now works in the radio.

Some old laptops have power issues >>not enough power to USB ports.
Compaqs were well known for this.

Older Dell laptops and desktops have issues.


If there is nothing on your drive
and you have a Windows machine available......

download the USB zip here.


Small >> fast >> no install.

Format your USB with it >> Fat32.

Now try to see if it boots >>> into DOS.
If it does it's not a bios issue.

If it boots then you are not installing Puppy correctly.


Now try installing Puppy.

Have you tried GParted after universal install to see that

LBA and Boot??? are checked.

Some USBs are rubbish and you have to try different install options.

You have tried different USB ports???
This is critical sometimes.

Could you get another cheap USB to try.

I have 5 USBs working with different Puppies.
Plus 4 hard drives >> 40 >> 160 >> 120 >>160 >> 500 MBs.


I would try again if none of the above work.

Does it boot on another computer.

Check bios. >> F12 boots some.

Other Bios may need you to nominate the hard drive to boot from.

Usually under Advanced Options...Hard drive Boot Order.

Others want you to nominate USB or USB hard drive.

If not you need to change the Bios.

And did you try another port >> a rear port.

but Boot and LBA are crical....none of that
but all of the other posted options = failure.

Your specs may help...hardware and which Puppy version?


Here is the old reliable HP formatter.



Install to USB Videos.


How to make USB flash stick bootable using Puppy Linux

Your drive will probably show as SBC 1

Do Nothing leave current MBR Alone

Otherwise follow all the defaults >> Enter

Do not save on reboot.


Other posts.

Some overlap but useful if I missed a point or 2.


Back to top
View user's profile Send private message 

Joined: 11 Jul 2008
Posts: 88

PostPosted: Wed 08 Sep 2010, 10:33    Post subject:  

Sounds like you need to "Flip The Removable Media Bit " to make the flash drive act as a hard drive.
Here is one from Lexor that might work for you
Back to top
View user's profile Send private message 

Joined: 12 Aug 2006
Posts: 3702
Location: Tamworth UK

PostPosted: Sat 11 Sep 2010, 14:36    Post subject:  

Flipping the bit does not always work. There are three kinds of USB stick.
1) those that pretend to be hard disks
2) those that pretend to be 'superfloppies' like an iomega zip drive (this is the most common)
3) those that can be flipped between 1) and 2) by changing 1 bit in the controller.
The layout of the boot/partitioning is different between the two

Most BIOS will recognise 2) AND NOT 1)
Some recognise 1) and not 2) which I suspect you have (Thinkpads T4n I know fall into this class)
even less recognise both.

It is possible to confuse the issue and format the drive incorrectly so a type 1) can be formatted as if it was a type 2) and vice versa. This will confuse even BIOSes that normally would recognise either type.

One BIOS that I know looks at the bit and reports the type is the AMI BIOS from an ECS k7S5A Pro which is perhaps why they are so popular.

Tools like FLASHBOOT ask you which type your stick is.
Windows treats the drives differently and reports type 1) as a 'local' disk and allows you to cache writes and partition it whereas type 2) show as a removable drive and it won't cache writes properly or allow partitioning other than as a single partition.
There are drivers for Windows that if used treat type 2) as if they were type 1)
As a IT Consultant I carry one of each type with Puppy+ wine and Hiren plus a load of Portable Aps on.

"Just think of it as leaving early to avoid the rush" - T Pratchett
Back to top
View user's profile Send private message 

Joined: 10 May 2017
Posts: 8

PostPosted: Sun 21 May 2017, 19:32    Post subject:  

Yesterday I had Slacko 6.3.2 running nicely on a brand-new 16gb flash drive, then because of problems running pBurn, replaced Slacko with a persistent Ubuntu 16.04 install. Ubuntu was too slow, though, and the multimedia stuff didn’t work the way it does when running on my internal hard drive. So I formatted my flash drive again (to ext2) and tried to go back to Slacko 6.3.2.

The problem now: Each time I install Slacko on my flash drive, the Puppy installer says:

“It seems that partition sdb1 does not have it’s [sic] ‘boot’ flag set, which is required to make it bootable.”

As soon as I open Gparted, though, the boot flag appears to already be activated. I have tried: toggling it back and forth, formatting my flash drive as a fat32 partition and then formatting it back to ext2 (with both Gparted and Fdisk, on two different computers) but when I attempt to boot from my flash drive now, the message is always “missing operating system.” I tried booting my computer from a flash drive that had a different Linux OS on it, and it worked perfectly. I can open files on my Slacko flash drive, so it doesn’t seem to be dead, it just won’t boot anymore.
Back to top
View user's profile Send private message 

Joined: 05 Sep 2006
Posts: 13129
Location: Stratford, Ontario

PostPosted: Sun 21 May 2017, 19:42    Post subject:  

Read here.
Back to top
View user's profile Send private message 

Joined: 10 May 2017
Posts: 8

PostPosted: Sun 21 May 2017, 21:57    Post subject:  

Oops! Looks like I stumbled upon a solution by myself. I installed a grumpier distro, and it could only be erased by creating a new partition table. Once I had done that, I was again able to flag my drive as “boot,” without also flagging it as “esp” while running Gparted in Ubuntu. This dual flagging had been the root of the problem before, I think, and now I am back to having a functional, bootable Slacko USB install.

Anyway, I followed your link, rcrsn51, and it suggests an interesting work-around that I will keep in mind for later, especially if I get more interested in dual-booting. For now, I would prefer to take my chances debugging pBurn rather than mess with Ubuntu anymore. It is just getting too bloated, and the Amazon thingy built into the desktop kinda gives me the willies! Thanks for your help.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0522s ][ Queries: 12 (0.0117s) ][ GZIP on ]