Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Nov 2017, 01:41
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[Résolu] Pidgin 2.7.2
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Mon 25 Oct 2010, 17:35    Post subject:  [Résolu] Pidgin 2.7.2  

Pidgin 2.7.2 testé avec Toutou 431.

http://download.tuxfamily.org/ludoeduasri/ludo-educative_paquets_populaires/pidgin-2.7.2_en_repack_asri.pet

Pour l'instant, c'est uniquement en anglais car je n'ai pas été capable d'intégrer la traduction fr (j'ai pourtant testé plusieurs .mo). Si quelqu'un sait comment faire...

Cordialement,

Last edited by ASRI éducation on Wed 27 Oct 2010, 08:03; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
esmourguit


Joined: 17 Nov 2006
Posts: 1393
Location: Entre l'ile aux oiseaux.et l'ile de sainte Lucie

PostPosted: Tue 26 Oct 2010, 04:27    Post subject:  

Bonjour à tous,
Pidgin, c'est gaim. Je me rappelle avoir changé le nom de gaim.mo en pidgin.mo et ça avait marché. Maintenant, j'ignore si pour les nouvelles version ça marche.
Je vais essayer de te trouver un fichier .po ou .mo
Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1393
Location: Entre l'ile aux oiseaux.et l'ile de sainte Lucie

PostPosted: Tue 26 Oct 2010, 04:45    Post subject:  

Bonjour à tous,
Est-ce que ce fichier pidgin.mo fonctionne? Extrait du fichier fr.po de la version Pidgin 2.7.4,
Cordialement Wink
pidgin.tar.gz
Description 
gz

 Download 
Filename  pidgin.tar.gz 
Filesize  119.25 KB 
Downloaded  239 Time(s) 

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Tue 26 Oct 2010, 06:24    Post subject:  

Merci esmourguit.

Mais, j'ai déjà essayé avec le .mo de Pidgin 2.7.4 et il n'est pas reconnu par 2.7.2 Pidgin.
D'ailleurs, je constate que le fichier intégré au .pet est le même que celui que tu as trouvé (moi j'ai utilisé comme base le .po proposé avec les sources de Pidgin 2.7.4).

Evidemment, j'ai cherché sur le web, mais je n'ai pas trouvé le .mo (ou le .po) de la 2.7.2. Ai-je bien cherché ?

L'affaire reste donc d'actualité.

Cordialement,
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Tue 26 Oct 2010, 08:13    Post subject:  

Finalement, j'ai trouvé un fichier .mo correspondant à la version 2.7.2 de Pidgin (je l'ai extrait d'une application Windows).

Mais, cela ne change rien. Pidgin reste bloqué sur l'anglais.

http://asri.la-super-boite.fr/z_tests_divers/locale_pidgin_2.7.2.tar.gz
Back to top
View user's profile Send private message Visit poster's website 
vezuve


Joined: 24 Jan 2008
Posts: 1289

PostPosted: Tue 26 Oct 2010, 12:17    Post subject:  

Hello,
Idea mets le mo-po français dans la locale anglaise et française

@+

_________________
Recherche
sur PUPPY anglai + souven
PUPPY wikka tou sur tou anglai
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Tue 26 Oct 2010, 12:55    Post subject:  

Quote:
mets le mo-po français dans la locale anglaise et française

Ca ne change rien.

Remarque 1 : au départ, il n'y a pas de .mo dans la locale anglaise.
Est-ce que ça signifie que le logiciel étant codé en anglais, il ne nécessite pas de locale ? Ou bien est-ce une version "only english" ?


Remarque 2 : j'ai essayé de compiler Pidgin 2.7.4 à partir des sources, ,mais je me suis noyé dans les dépendances nécessaires à la compilation.
Back to top
View user's profile Send private message Visit poster's website 
vezuve


Joined: 24 Jan 2008
Posts: 1289

PostPosted: Tue 26 Oct 2010, 18:32    Post subject:  

Hello,
Il aurait été bien de savoir ou tu a trouvez et ce que tu a télécharger ainsi que la procédure pour fairre ton paquet pet Question Question
Avec le lien de recherche on trouve sous puppy une version antérieur avec la locale, sauf que le lien est mort ...........


@+

_________________
Recherche
sur PUPPY anglai + souven
PUPPY wikka tou sur tou anglai
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Tue 26 Oct 2010, 19:24    Post subject:  

Tu as raison Vezuve. Je n'avais pas pris la peine de préciser tout cela, mais je peux évidemment le faire.

Au départ, je voulais simplement obtenir un Pidgin qui fonctionne correctement. La version 2.6.6 que je possédais ne fonctionnait pas bien avec la ludo-éducative et un instit me demandait une solution de "chat" interclasses.

J'ai donc commencé à regarder de plus près la 2.6.6 et je me suis rendu compte qu'il existait des versions plus récentes.

Après quelques essais de différents .pet dénichés sur le forum de Murga, j'ai arrêté mon choix sur la version pidgin-2.7.2-i486-410.pet
http://www.murga-linux.com/puppy/viewtopic.php?search_id=339983447&t=58553

J'ai effectué quelques modifications mineures (entrée menu, icônes, etc), puis j'ai cherché le fichier de traduction. Celui de la 2.6.6 fr ne fonctionnant pas, je me suis finalement orienté sur le .po de Pidgin 2.7.4 (j'ai téléchargé les sources sur le site officiel de Pidgin) que j'ai transformé en .mo (sans réussite).
J'ai également testé avec le .mo de la version 2.7.2 Windows.

Et mes essais de compilation à partir des sources (version actuelle 2.7.4), n'ont pas apporté plus de réussite.

Voilà.
Wink
Back to top
View user's profile Send private message Visit poster's website 
esmourguit


Joined: 17 Nov 2006
Posts: 1393
Location: Entre l'ile aux oiseaux.et l'ile de sainte Lucie

PostPosted: Wed 27 Oct 2010, 02:54    Post subject:  

Bonjour à tous,
@ ASRI,
Il semble que le paquet pet sur lequel tu as basé ta version n'ait pas été compilé pour prendre en compte les locales.
Cela arrive parfois, surtout pour Puppy. Lors de mes francisations, je suis obligé de compiler une version d'une application qui prenne en charge les locales.
Tu as donc fait le bon choix de compiler la version 2.74. mais certains programmes sont beaucoup moins faciles que d'autres à compiler et ça se solde par un échec. Peut-être pourrais-tu demander à ttuuxx ou iguleder de voir s'ils peuvent faire ça.
Cordialement Wink

_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
vezuve


Joined: 24 Jan 2008
Posts: 1289

PostPosted: Wed 27 Oct 2010, 07:05    Post subject:  

Hello,
JAI la solution et je pense qu'esmourguit a raison tu a du te planter, te rétamer ................... Twisted Evil
Le wika
ici une ancienne et si on l'installe ou on ouvre le paquet elle a les fichiers .mo et tout ça vient du wika Embarassed
Sinon Wolf Pup sur ce fil a un paquet local et le pdgin, mais ses liens son mort et ça viens encore une fois du wika Confused
Donc ta pas du être bon dans ta recherche, reste plus qu'a recommencer une nouvelle compile Surprised


@+

_________________
Recherche
sur PUPPY anglai + souven
PUPPY wikka tou sur tou anglai
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Wed 27 Oct 2010, 08:02    Post subject:  

Ok, merci pour vos explications.
Je vais indiquer Résolu.
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Wed 27 Oct 2010, 14:27    Post subject:  

J'étais un peu pressé lors de mon dernier post.
Je me permets donc un complément d'information.

@ esmourguit
Merci pour tes infos, elles vont m'aider à me bonifier.

@vezuve
Quote:
tu a du te planter, te rétamer

Merci pour ton soutien, voilà une intervention constructive qui va probablement beaucoup m'aider Evil or Very Mad
L'objectif du forum est-il uniquement de dénigrer les tentatives infructueuses des utilisateurs ?

Quote:
Le wika

Je l'ai évidemment utilisé.

Quote:
ici une ancienne

J'ai testé cette 2.7.1 (et toi ?), mais elle est loin d'être compatible avec Toutou (de nombreuses dépendances sont absentes).

Quote:
Sinon Wolf Pup sur ce fil

Je sais que les puppystes ne sont pas forcément des adeptes de la nouveauté, mais tout de même... Cette 2.6.6 n'est plus d'actualité (nous en sommes à la 2.7.4). De plus, comme tu le dis, les liens sont HS.

Quote:
Donc ta pas du être bon dans ta recherche

Pour ce qui est de la recherche, c'est relatif. Trouver des liens est une chose, mais obtenir un paquet vraiment compatible et fonctionnel en est une autre (et ça tu le sais, car tu je sais que tu consacres du temps à Puppy/Toutou).

Quote:
reste plus qu'a recommencer une nouvelle compile

Pour profiter à nouveau de tes railleries ?

Ok, ce soir je ne suis pas de bonne humeur, mais franchement après avoir passé des heures à bidouiller/tester pour essayer d'aider la communauté, je ne suis qu'à moitié d'humeur à apprécier les conseils d'un prof sans solutions.

Cordialement,
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0677s ][ Queries: 15 (0.0198s) ][ GZIP on ]