Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 02:20
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
GXine closes on fullscreen mode
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Rhino


Joined: 04 May 2005
Posts: 262
Location: Cincinnati, OH, USA

PostPosted: Wed 11 May 2005, 22:13    Post_subject:  GXine closes on fullscreen mode  

I'm trying out the new puppy 1.02RC and Gxine works great for my DVD's, but it closes after about 1 second when I set it to fullscreen mode. Otherwise it plays and sounds great.

Anyone else having this problem?
Back to top
View user's profile Send_private_message YIM 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 11 May 2005, 23:02    Post_subject:  

gxine 0.3.3 usually crashes when you try to play fullscreen

i've tried 0.3.4 and it will play full screen

i made an Mplayer dotpup package ... it has no problems playing full screen ... and couldn't be easier to install
Back to top
View user's profile Send_private_message 
Guest
Guest


PostPosted: Wed 11 May 2005, 23:36    Post_subject:  

Thanks, I'll try it.
Back to top
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Thu 12 May 2005, 08:31    Post_subject:  

GuestToo,
Thanks for that info about 0.3.4.
I downloaded 0.4.x, but it needs GTK 2.4.
Back to top
View user's profile Send_private_message Visit_website 
Guest
Guest


PostPosted: Thu 12 May 2005, 09:38    Post_subject:  

ummm, there doesn't seem to be any gxine 0.3.4.
Sourceforge project page has 0.3.3 then 0.4.0.
Back to top
Guest
Guest


PostPosted: Thu 12 May 2005, 09:41    Post_subject:  

Okay, just looked at release notes.
0.4.0, 0.4.1 need GTK 2.4,
however 0.4.2 and later work with GTK 2.2.
That's great news.
Back to top
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Thu 12 May 2005, 09:45    Post_subject:  

That was me, showing up as "guest".
...I think the forum logs us out after an idle period.

Anyway, I'll see if I can get Gxine 0.4.4 into v1.0.2.
Back to top
View user's profile Send_private_message Visit_website 
mouldy


Joined: 04 May 2005
Posts: 498

PostPosted: Thu 12 May 2005, 12:47    Post_subject:  

I dont play dvds much on computer, but did play one recently use Gxine. Seemed rather hesitating compared to the dvd software player you used to have. Ogilvie or something like that wasnt it? Thought I might try to add Ogilvie back sometime, but again not big deal. Was it real hard to set up on Puppy? Suppose if I had more memory could just boot 0.9.3 Puppy cd that has Ogilvie and play dvd with that. Works smoother though when installed to hardrive as memory isnt tied up running Puppy.
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 12 May 2005, 14:08    Post_subject:  

see:
http://www.goosee.com/puppy/sforum/simpleforum_pro.cgi?fid=04&topic_id=1108519921

http://xine.sourceforge.net/stefan/

the gxine_installer.bin seems to be version 3.4
it installs anywhere, in it's own dir
(there's a library path bug ... edit the line to fix it)
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Thu 12 May 2005, 22:12    Post_subject:  

Thanks for that info.

Wasted considerable time this morning compiling Xine 1.0.1 and Gxine 0.4.4.
Tried it in Puppy -- segmentation fault.

So, 0.3.4 seems like the way to go for now.
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Thu 12 May 2005, 23:20    Post_subject:  

Sigh, I can't get 0.3.4 to work either.
It starts up, but there's an error message that it can't start the Xine engine.
Back to top
View user's profile Send_private_message Visit_website 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 12 May 2005, 23:52    Post_subject:  

that installer does work with Puppy ... it unzips to a self-contained dir, about 13 megs

i changed these 2 lines in the gxine script:

TOPDIR="/mnt/hda11/puppy-stuff/gxine"
LD_LIBRARY_PATH="$TOPDIR/lib:$LD_LIBRARY_PATH"

here's a pic of gxine 0.3.4 running in Puppy:
http://tinypic.com/52f5tx

and a pic of it running fullscreen:
http://tinypic.com/52f5vl

so gxine can play fullscreen ...
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Fri 13 May 2005, 08:11    Post_subject:  

Maybe the problem is the new kernel...
or I did something wrong.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0573s ][ Queries: 12 (0.0057s) ][ GZIP on ]