Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 10:28
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Installing plugin for HP 1102w
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Fri 22 Oct 2010, 02:00    Post_subject:  Installing plugin for HP 1102w  

I'm attempting to use an HP 1102w laserJet USB printer, which requires a proprietary plugin. I installed hpliplite-3.10.5, and downloaded plugins hplip-3.10.5-plugin.run and hplip-3.10.5-plugin.run.asc from

http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/

which can't find HPLIP. Cups recognized the local printer, with a note that it needs the plugin. Any suggestions?? Thanks

Code:

~/Downloads $ ./hplip-3.10.5-plugin.run
Verifying archive integrity... All good.
Uncompressing HPLIP 3.10.5 Plugin Self Extracting Archive.........................................
Error importing HPLIP modules.  Is HPLIP installed?


Note: ./hplip-3.10.5-plugin.run --list correctly lists the printer

EDIT: I compiled foo2zjs, which worked fine without any plugin.
http://foo2zjs.rkkda.com/
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9153
Location: Stratford, Ontario

PostPosted: Fri 22 Oct 2010, 08:37    Post_subject:  

There are already driver packages available for your printer in Puppy. Read here.
Back to top
View user's profile Send_private_message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Sat 23 Oct 2010, 21:32    Post_subject:  

rcrsn51 wrote:
There are already driver packages available for your printer in Puppy. Read here.



FYI/ hpijs-3.10.6-dynppd.pet gets foomatic-rip errors. I didn't try
Patriot's patch for 4.1.2 (I'm using 5.1). I didn't try: foo2xxx_r220909-0.0 (zjs/xqx/slx/oak/hp/xxx) package (11MB) from the same site, since the compiled version that works is foo2zjs.c,v 1.98 2010/07/23. Compiling from the above link is just 'make, make install'
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 24 Oct 2010, 04:04    Post_subject:  

I have used foo2xxx_r220909 with many recent puppies - puplets - derivatives succesfully. Still nice to hear that more recent versions also works.

The needed thing is hotplugin, Some HP printers needs firmware autoloading every time you use it. Foo2xxx creates needed folders and firmware autoloading.
Back to top
View user's profile Send_private_message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Mon 08 Nov 2010, 23:41    Post_subject:  

pemasu wrote:
I have used foo2xxx_r220909 with many recent puppies - puplets - derivatives succesfully. Still nice to hear that more recent versions also works.

The needed thing is hotplugin, Some HP printers needs firmware autoloading every time you use it. Foo2xxx creates needed folders and firmware autoloading.


foo2xxx_r220909 doesn't have p1102w driver, so newer version is needed.
http://www.murga-linux.com/puppy/viewtopic.php?t=61663
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0461s ][ Queries: 12 (0.0034s) ][ GZIP on ]