Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 14:36
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Video Editing - Cinelerra 4.2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
drerock

Joined: 03 Feb 2010
Posts: 8

PostPosted: Sat 06 Nov 2010, 14:27    Post_subject:  Video Editing - Cinelerra 4.2  

There is a new version of cinelerra out

http://heroinewarrior.com/cinelerra.php

The existing cinelerra pet is from 4.1 which has a bug making the program virtually unusable.

Does anyone wanna take a shot at compiling the new version 4.2 and making a pet?

I don't know how..
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Sun 07 Nov 2010, 16:42    Post_subject:  

I might consider it if there's enough people who want it. I don't remember it being too hard last time round. What version of Puppy do you want it on? And as a pet or SFS?

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
drerock

Joined: 03 Feb 2010
Posts: 8

PostPosted: Sun 07 Nov 2010, 18:56    Post_subject:  

ideally, I would like it for whatever the latest release of puppy is.. i think currently that's 5.1.1

the current version cinelerra 4.1 has a bug causing the video not to display in the viewer, which is what is used to preview clips and crop them.

Thanks
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Mon 08 Nov 2010, 17:21    Post_subject:  

Ok then, see how it goes. No promises, but if not me, someone else will probably do it as well, Cinelerra's quite popular.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1070
Location: Australia

PostPosted: Wed 10 Nov 2010, 05:05    Post_subject:  

Ok, all dependencies taken care of, except for one problem I've been sealing with all day:
Code:

/usr/include/bits/mathcalls.h:326: error: conflicting types for 'lrintf'
common.h:313: note: previous definition of 'lrintf' was here


Googling isn't loads of help as there are only a few hits and they all seem to point to compiling the latest faad2, which I've done after deleting all traces of the old faad2, but I still get the error. So this is my stand still for the moment. I'm thinking of trying to compile the CV version, but the download from their git isn't working so well for me right now.

That's the update for now.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 10 Nov 2010, 08:53    Post_subject:  

battleshooter wrote:
Ok, all dependencies taken care of, except for one problem I've been sealing with all day:
Code:

/usr/include/bits/mathcalls.h:326: error: conflicting types for 'lrintf'
common.h:313: note: previous definition of 'lrintf' was here


Googling isn't loads of help as there are only a few hits and they all seem to point to compiling the latest faad2, which I've done after deleting all traces of the old faad2, but I still get the error. So this is my stand still for the moment. I'm thinking of trying to compile the CV version, but the download from their git isn't working so well for me right now.

That's the update for now.

Battleshooter


I had those errors but I removed them, about 7 or so.
I compiled it on Wary, but Haven't got the time to test it, any testers?, you should be using the latest Wary 0.96+.
http://www.smokey01.com/ttuuxxx/Wary/Software/Cinelerra/cinelerra-4.2-w5.pet
http://www.smokey01.com/ttuuxxx/Wary/Software/Cinelerra/cinelerra-4.2-extraFonts-w5.pet
also could you tell me if it needs this quicktime lib or did it use the built in one, There are only about 98 files I would have to lld to find out, easier if you say yes its work without it.
this would be the libquicktime in question
http://www.smokey01.com/ttuuxxx/Wary/Software/libquicktime-1.1.5-i386.pet
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send_private_message Visit_website 
disciple

Joined: 20 May 2006
Posts: 6429
Location: Auckland, New Zealand

PostPosted: Thu 11 Nov 2010, 03:19    Post_subject:  

ttuuxxx wrote:
I had those errors but I removed them

Will you provide a patch?

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 11 Nov 2010, 05:49    Post_subject:  

disciple wrote:
ttuuxxx wrote:
I had those errors but I removed them

Will you provide a patch?

hhmmmm really I need someone to test the package and see if its better, Plus making a patch would be hard because I was editing some of the sources and some of compiler includes.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send_private_message Visit_website 
drerock

Joined: 03 Feb 2010
Posts: 8

PostPosted: Thu 11 Nov 2010, 11:00    Post_subject:  

ttuuxxx wrote:
disciple wrote:
ttuuxxx wrote:
I had those errors but I removed them

Will you provide a patch?

hhmmmm really I need someone to test the package and see if its better, Plus making a patch would be hard because I was editing some of the sources and some of compiler includes.
ttuuxxx


Thanks for giving this a shot, I'll certainly test it. I'm not familiar with Wary.. but I'll search these forums..
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10747
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 11 Nov 2010, 11:19    Post_subject:  

drerock wrote:
ttuuxxx wrote:
disciple wrote:
ttuuxxx wrote:
I had those errors but I removed them

Will you provide a patch?

hhmmmm really I need someone to test the package and see if its better, Plus making a patch would be hard because I was editing some of the sources and some of compiler includes.
ttuuxxx


Thanks for giving this a shot, I'll certainly test it. I'm not familiar with Wary.. but I'll search these forums..

Latest version of wary can be read about
http://bkhome.org/blog/?viewDetailed=01940
and downloaded from
http://distro.ibiblio.org/pub/linux/distributions/quirky/wary-096/wary-096.iso
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send_private_message Visit_website 
drerock

Joined: 03 Feb 2010
Posts: 8

PostPosted: Thu 11 Nov 2010, 12:03    Post_subject:  

I get "Error Package ....[....] failed to install" for all three of those packages.

I booted into Wary, and have a 8800GS Nvidia video card, apparently there's not a driver that supports my card, which might be a problem for decompressing codecs while using the program.
Back to top
View user's profile Send_private_message 
drerock

Joined: 03 Feb 2010
Posts: 8

PostPosted: Thu 11 Nov 2010, 12:15    Post_subject:  

scratch that last part, found a working driver
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0720s ][ Queries: 12 (0.0036s) ][ GZIP on ]