Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Aug 2014, 09:52
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pCD 1.5 - CD-audio player
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 13 [194 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
Author Message
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Wed 01 Dec 2010, 04:01    Post subject:  

Version 1.4
See main post

Changelog
- Bugfix: New disc-scan after 'No disc insterted' message (thanks to don570)

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Mon 06 Dec 2010, 16:38    Post subject: no change noticed in pcd 1.4  

I didn't notice any change in the new version pcd 1.4
I still get the 'no disc inserted' message in the window
if I launch pcd and then insert the Audio CD.
Tested on luci 241 . I have no internet access.

________________________________________
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Wed 08 Dec 2010, 14:00    Post subject:  

don570
So there is more....... Smile

I have added a 1 sec sleep in line 20 (/usr/local/pcd/func), to wait for the disc to spin up. Does it help you? Please try pCD-1.4-1 in the main post.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Karl Godt


Joined: 20 Jun 2010
Posts: 3964
Location: Kiel,Germany

PostPosted: Wed 08 Dec 2010, 18:05    Post subject: Take your time  

Spider mode enabled. Check if remote file exists.
--2010-12-08 19:43:18-- http://puppylinux.com/
Resolving puppylinux.com... failed: Connection timed out.
wget: unable to resolve host address `puppylinux.com'

AND ANOTHER TRY 'Read CD' >
Quote:
# LANG=C wget -S --spider -T 1 puppylinux.com

Spider mode enabled. Check if remote file exists.
--2010-12-08 19:28:50-- http://puppylinux.com/
Resolving puppylinux.com... 74.53.27.162
Connecting to puppylinux.com|74.53.27.162|:80... connected.
HTTP request sent, awaiting response...
HTTP/1.1 200 OK
Date: Wed, 08 Dec 2010 18:26:55 GMT
Server: Apache mod_fcgid/2.3.5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
Last-Modified: Fri, 26 Nov 2010 12:45:35 GMT
ETag: "5bb4003-15b4-495f4193f99c0"
Accept-Ranges: bytes
Content-Length: 5556
Content-Type: text/html
Connection: keep-alive
Length: 5556 (5.4K) [text/html]
Remote file exists and could contain further links,
but recursion is disabled -- not retrieving.

It seems that the disk drive icon has to appear on the desktop before clicking 'Read CD' which can take sometimes several seconds. Clicking 'Read CD' immediately after inserting the CD `pcd` showed no disk inserted, Clicking 'Read CD' another time before the drive icon appeared also no disk inserted, Clicking 'Read CD' immediately after the drive icon appeared just unknown artist and track #Nrs. The FOURTH Clicking 'Read CD' then showed the retrieved Data.

I also looked into the code and gtkdialog is poorly documented ... google for gtkdialog3 and you'll find zigbert and murga linux Cool
Code:
<button>
     <label>$LOC204</label>
     <action>$APPDIR/func -stop</action>
     <action>eject</action>
     <action>for i in \`ls /root/.pcd/tmp\` ; do echo > /root/.pcd/tmp/\"\$i\" ; done</action>
     <action>sleep 1.4</action>
     <action type=\"clear\">ENTRY_ARTIST</action>
     <action>refresh:ENTRY_ARTIST</action>
     <action type=\"clear\">ENTRY_ALBUM</action>
     <action>Refresh:ENTRY_ALBUM</action>
     <action type=\"clear\">CDDA</action>
     <action>Refresh:CDDA</action>
     <action type=\"clear\">PB</action>
     <action>Refresh:PB</action>
    </button>

is working on dpup-005 but with warnings ( of which I get a lot from seamonkey, abiword and other apps here )
** (gtkdialog3:4382): WARNING **: gtkdialog: Warning: Clear not implemented for this widget..
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Sat 11 Dec 2010, 14:46    Post subject: no disc inserted  

I tried pcd 1.4.1 and I'm still getting 'no disc inserted'
messages if I launch pcd first.

I tried terminating my DVD burner differently to see
if that would change anything, but no difference.

I wait to see desktop drive icon before clicking 'Read CD'
Am I the only one with this problem?
I have an IBM M41 desktop machine.

_________________________________________________
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Sun 12 Dec 2010, 05:14    Post subject:  

Karl Godt wrote:
is working on dpup-005 but with warnings ( of which I get a lot from seamonkey, abiword and other apps here )
** (gtkdialog3:4382): WARNING **: gtkdialog: Warning: Clear not implemented for this widget..
The warning is not critical. <action type=\"clear\">CDDA</action> is not a legal call for a <entry> or <tree> widget. It works well without this. A clear-call is used with the <table> widget.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Sun 12 Dec 2010, 05:22    Post subject: Re: no disc inserted  

don570 wrote:
I tried pcd 1.4.1 and I'm still getting 'no disc inserted'
messages if I launch pcd first.
Anyone else got this trouble ???

1. Launch pCD without an audio-CD in drive
2. Insert Audio-CD
3. Wait for CD-icon show up on screen
4. Click the 'Read CD' button in pCD.


Thanks
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Sun 12 Dec 2010, 05:33    Post subject:  

Karl Godt
I have included this into the next release:
Code:
    <button>
     <label>$LOC204</label>
     <action>$APPDIR/func -stop</action>
     <action>eject</action>
     <action>echo > $WORKDIR/pcd-ARTIST</action>
     <action>echo > $WORKDIR/pcd-ALBUM</action>
     <action>echo > $WORKDIR/pcd-cdda</action>
     <action>refresh:ENTRY_ARTIST</action>
     <action>refresh:ENTRY_ALBUM</action>
     <action>refresh:CDDA</action>
    </button>


Thanks a lot for your input
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Wed 15 Dec 2010, 20:41    Post subject: pcd 1.0 solves problem  

Quote:
1. Launch pCD without an audio-CD in drive
2. Insert Audio-CD
3. Wait for CD-icon show up on screen
4. Click the 'Read CD' button in pCD.



This is exactly what I have been doing, but it results in
the 'no disc inserted' message. However the player
does play the tracks beginning with one .

I installed a copy of pcd 1.0 and this solved the problem.

I checked pcd 1.2 and it has the problem,
so I'll take a guess and suggest that the problem
started when you introduced some new features in pcd 1.2.

Nobody else has complained about this in half a year,
which is surprising.
__________________________________________________
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Sat 01 Jan 2011, 09:09    Post subject:  

Version 1.5
See main post

changelog
- Bugfix: Clear fields after eject (thanks Karl Godt)
- Bugfix: Read CD from button (thanks to don570)

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Tue 04 Jan 2011, 18:55    Post subject: version 1.5  

pcd version 1.5 works great now!!

I don't even have to click on 'Read CD' button.
__________________________________
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Tue 04 Jan 2011, 21:45    Post subject:  

Hopefully, we got it right this time.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3254
Location: Ontario

PostPosted: Thu 17 Feb 2011, 16:18    Post subject: spelling error in local filename  

I think I spotted an error in the filename of a local
when I looked in the folder containing the locals.

...but I don't think it affects the application at all,
since it still displayed the German labels.



____________________________________________
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5676
Location: Valåmoen, Norway

PostPosted: Thu 17 Feb 2011, 19:06    Post subject:  

Fixed

Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 13 of 13 [194 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0843s ][ Queries: 13 (0.0079s) ][ GZIP on ]