Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 02:03
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
imagemagick 6.6.6-6 and 6.6.6-7
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Dingo


Joined: 11 Dec 2007
Posts: 1418
Location: somewhere at the end of rainbow...

PostPosted: Sat 25 Dec 2010, 17:44    Post subject:  imagemagick 6.6.6-6 and 6.6.6-7
Subject description: for Puppy 3.01, 4.21, 4.3.1
 

Woof Woof! time to compile latest imagemagick:

since I'm a Puppy 3.01 lover, and I use use even frequently Puppy 4.2.1 and Puppy 4.3.1, I compiled for all three puppy versions

*imagemagick 6.6.6-6* for Puppy 3.01
*imagemagick 6.6.6-6* (STATIC BUILD with jpeg2000 support) for Puppy 3.01
*imagemagick 6.6.6-6* (docs and manual)
*imagemagick 6.6.6-6* for Puppy 4.2.1
*imagemagick 6.6.6-7* for Puppy 4.3.1 (with jpeg 2000 support)
- http://dokupuppylinux.co.cc/programs:imagemagick (download here)

apps in every package:

animate
compare
composite
conjure
convert
display
identify
import
mogrify
montage
stream

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux

Last edited by Dingo on Tue 28 Dec 2010, 21:21; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sat 25 Dec 2010, 18:37    Post subject: thanks  

Dear dingo,

Since I still use 3.01 on three machines, I, for one, am grateful.

Thanks, mate.

With kind regards,
vovchik
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 4276
Location: Earth

PostPosted: Sat 25 Dec 2010, 20:12    Post subject: I was unfamiliar with this until I noticed the thread.  

  • Does ImageMagick also includes an X Window graphical user interface for rendering and manipulating images? (I saw a reference to this on Wikipedia)
  • Would you recommend this for PUPs 5.1+?
  • Is there a PET on Ibiblio?
Thanks in advance

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
Dingo


Joined: 11 Dec 2007
Posts: 1418
Location: somewhere at the end of rainbow...

PostPosted: Sun 26 Dec 2010, 11:01    Post subject:  

*display* (type in console display and a GUI will be shown)

is utility from imagemagick with a GUI, but I recommend learning processing images via command-line. Once learned, you will use very fast and easily

animate
compare
composite
conjure
convert
display <----
identify
import
mogrify
montage
stream


I remember that Barry has already done in past an imagemagick package for Lupu (see his blog)

every Puppy series needs to have its proper imagemagick package, since it has differences in system and in libs

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send private message Visit poster's website 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Sun 26 Dec 2010, 21:49    Post subject:  

I agree with Dingo, that commandline is best, but for some gui is preferred.

I don't know whether this Flimp pet will work with the Imagemagick version above...might be worth a try.

Converseen is a QT4 frontend, to Imagemagick, that provides image conversion & resizing.
Back to top
View user's profile Send private message 
miriam


Joined: 06 Dec 2006
Posts: 279
Location: Queensland, Australia

PostPosted: Mon 07 Mar 2011, 20:25    Post subject: imagemagick for Puppy 5.0.2 Lucid
Subject description: troubles, troubles, troubles, and a solution
 

I've just spent most of a couple of days trying to get ImageMagick working on Puppy 5.0.2 Lucid. In previous Puppies I had little or no difficulty compiling it, but for some weird reason I'm unable to in this Puppy. The compilation fails with
Code:
magick/libMagickCore.la: No such file or directory
when that file actually does exist. I tried many versions that compiled on previous Puppies, always with the same problem. One or two people have posted the same problem on the web, but with no solution as far as I can find.

So I turned to trying pre-compiled versions. These failed too. At first I got the same error no matter what I installed, but I eventually realised that they were installing in different places and the old problematic versions were not being replaced by the newer ones. So I tracked down all the files and deleted them by hand to get a clean slate.

Now I tried Dingo's ImageMagick-6.6.6-6-i486-static-puppy-301.pet because I figured static files would be less likely to have problems (don't know if my reasoning is correct here). Now when trying a simple convert test.png test.jpg it returned the error:
Code:
convert: error while loading shared libraries: libxcb-xlib.so.0: cannot open shared object file: No such file or directory
Ahhh! Smile Now we're getting somewhere. It seems that lib was left out of Puppy 5.0.2 Lucid. (That, of course is the eternal struggle with Puppy -- to leave out unnecessary stuff and include what is needed.) Anyway, I located it in an earlier pet libxcb-1.0.pet (from Puppy3 I think). I only copied the relevant lib over instead of installing the whole libxcb pet in case of bad repercussions. (I seem to recall something about incompatibilities between some of those libs and later Puppies.)

That ImageMagick now works fine on Puppy 5.0.2 Lucid. Yay!
I can finally get some work done!
Thank you Dingo, for providing them.

Oh, and for those who don't know the trick to selecting only some files from a pet, or checking to see what they contain before installing them, here's what I do:
First, I rename the pet, adding ".tgz" to the end of the name, because they are actually tar.gzip files.
Then I click to open in Puppy's archive extraction program (Xarchive in Puppy 5).
Next I select all and extract to the current location. It will give an error because of the way pets are wrapped (with checksum?). Ignore it.
Now you have a folder with all the files in it arranged in the layout they are intended to install on your computer and you can check to see if they are what you want or you can pick and choose from them.

_________________
A life! Cool! Where can I download one of those from?
Back to top
View user's profile Send private message Visit poster's website 
bleepingbeep


Joined: 29 Mar 2011
Posts: 15
Location: Tucson, Arizona

PostPosted: Wed 20 Apr 2011, 15:54    Post subject: Imagemagick for Lucid 5.20/5.25?  

Imagemagick has been a long-time favorite of mine. I'd love to see a PET for the newest versions of Lucid.
_________________
Lucid Puppy 5.2.5 frugal install on SD card in Eee PC (earliest model, given new life by Puppy)
Back to top
View user's profile Send private message 
DPUP5520

Joined: 16 Feb 2011
Posts: 801

PostPosted: Thu 21 Apr 2011, 17:25    Post subject:  

newest version compiled in 525 for lupu is in this thread

http://murga-linux.com/puppy/viewtopic.php?p=515725#515725

_________________
PupRescue 2.5
Puppy Crypt 528
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0719s ][ Queries: 12 (0.0080s) ][ GZIP on ]