Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 06:18
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Opera 11 at mnt/home .pet Here
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 4 [55 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Mon 03 Jan 2011, 23:58    Post subject:  

DaveS wrote:
Small but crucial point... if you need to print from you browser, stuff like Boarding Passes, receipts etc., dont bother with Opera. Its hopeless.......

Why do you say that? I'm using a different dot-pet, but printing works just fine for me from Opera. (EDIT: I should specify- Opera 11.00, Lucid 511.)

Last edited by TheAsterisk! on Tue 04 Jan 2011, 06:39; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 04 Jan 2011, 02:16    Post subject:  

TheAsterisk! wrote:
DaveS wrote:
Small but crucial point... if you need to print from you browser, stuff like Boarding Passes, receipts etc., dont bother with Opera. Its hopeless.......

Why do you say that? I'm using a different dot-pet, but printing works just fine for me from Opera.

http://www.murga-linux.com/puppy/viewtopic.php?t=63578

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 04 Jan 2011, 03:20    Post subject:  

TheAsterisk! wrote:
DaveS wrote:
Small but crucial point... if you need to print from you browser, stuff like Boarding Passes, receipts etc., dont bother with Opera. Its hopeless.......

Why do you say that? I'm using a different dot-pet, but printing works just fine for me from Opera.


Here is a typical sample:



So what is that about then!

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Tue 04 Jan 2011, 06:28    Post subject:  

DaveS wrote:
So what is that about then!

I think I may have discovered what I'm doing differently (without even thinking about it) that gives me better results.
I save webpages as MHTML files, then later open those and then print everything I need at once. It seems to make a difference.

I've attached a wonky PDF that's printed/exported directly from a view of the forum, and then I've attached a PDF printed from a saved *.mht of the same thread page. (They're both in an archive, since the forum doesn't allow PDF attachments.) The "bad" direct-print copy isn't as dramatic as your example, but there is a noticeable difference.

I'm going to go try it out on a few other sites and see if saving to *.mht files before printing might not be a decent work-around.

EDIT: I tried it out on Techrights.org, and it seemed to help preserve the site layout there, too. Images were a little low-res, but not distorted or marred like your screenshot.
Opera's printing still won't win any awards for image fidelity, but it's better than nothing.

Might want to give this method a try. Nothing to lose, after all.
opera_printing.tar.bz2
Description  Sample PDFs for direct printing & printing from saved *.mht
bz2

 Download 
Filename  opera_printing.tar.bz2 
Filesize  161.39 KB 
Downloaded  259 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Tue 04 Jan 2011, 12:44    Post subject:  

Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Tue 04 Jan 2011, 12:46    Post subject: Opera perpetual printing problem
Subject description: post removed
 

Back to top
View user's profile Send private message Visit poster's website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 04 Jan 2011, 12:51    Post subject:  

Henry.. I guess you can see your posts are blank. Using Opera? Smile
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Tue 04 Jan 2011, 13:08    Post subject:  

DaveS wrote:
Henry.. I guess you can see your posts are blank. Using Opera? Smile


Yes, my published post was deleted, and attempts to repeat it were blanked. I don't know what's going on. Perhaps a moderator is playing games. Wish someone would explain.

Henry
Back to top
View user's profile Send private message Visit poster's website 
Bert


Joined: 30 Jun 2006
Posts: 950

PostPosted: Tue 04 Jan 2011, 14:13    Post subject:  

Henry wrote:
Hello,

I just posted the following here, which appeared but seems to have been removed. I recovered it from "view my posts." Mystified, what happened?

Henry

Quote:
I went to the Opera support site and picked one of the many strings on printing problems:



Take a moment to read this and you won't be looking in Puppy for the problem.


This is what I see, when clicking "quote" on your first post and remove the link in your text. Some links cause trouble in the forum it seems..

_________________


Back to top
View user's profile Send private message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Tue 04 Jan 2011, 15:58    Post subject:  

Bert wrote:

This is what I see, when clicking "quote" on your first post and remove the link in your text. Some links cause trouble in the forum it seems..


Thanks, Bert, but this does not explain it for me. The message I originally posted has appeared, disappeared, my followups appeared with the body removed, my original message again appeared without the followups and later disappeared, the followups returning. Nothing like this has ever happened in my previous 600 some posts. I've wasted too much time on it; I don't like it. Let's see if this post survives.
Back to top
View user's profile Send private message Visit poster's website 
Bert


Joined: 30 Jun 2006
Posts: 950

PostPosted: Tue 04 Jan 2011, 16:15    Post subject:  

Yes, this post survived Wink

I again clicked "quote" on your last post and it was there in 'preview'. Then I added the opera link from your first post and it became invisible in 'preview'.

So, maybe there's more to it, but the link certainly plays a role.
Hope this gets solved!

_________________


Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 04 Jan 2011, 16:25    Post subject:  

Maybe the Opera guys are hiding something Smile
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 950

PostPosted: Tue 04 Jan 2011, 16:32    Post subject:  

http://my.opera.com/community/forums/topic.dml?id=783492

Think I found the cause:

In the original empty post, the link had a space between' id=783492' and '[/url]'. Removing that space, makes the link and the post visible.

_________________


Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 950

PostPosted: Tue 04 Jan 2011, 16:52    Post subject:  

This one is for Dave Laughing


_________________


Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Tue 04 Jan 2011, 16:55    Post subject:  

Bert wrote:
This one is for Dave Laughing



LOL... Brilliant!

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 4 [55 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0970s ][ Queries: 13 (0.0153s) ][ GZIP on ]