Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 04:07
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Network Samba
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 15:53    Post_subject:  Network Samba  

I'm probably doing something wrong. I installed the two pets as per the instructions. When I type samba-start in console, I get
"bash: samba-start: console not found"

When I run samba-login (after dragging to desktop) with default settings I get a dialogue box saying "no connection to pupshare"

On the plus side Pnethood now shows a tab for pupserver, but does not show a drive. It still sees the Windows machine and allows me to connect to the drive there.

Where to next?

Thanks.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Tue 18 Jan 2011, 15:58    Post_subject:  

Where did you type "samba-start"? You have an icon on your desktop that opens a window for typing commands. You can check that Samba is running with the "ps" command.

Also, does your Puppy setup have a /mnt/home folder? You can tell with the command "ls /mnt/home".
Back to top
View user's profile Send_private_message 
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 16:11    Post_subject: Network Samba  

Thanks again.

I used the console on the Puppy 5.2 desktop.
samba-start now does nothing.
is /mnt/home gives me "bash: is: command not found"
Back to top
View user's profile Send_private_message 
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 16:12    Post_subject: Network Samba  

but I checked and there is a /mnt/home folder.
Back to top
View user's profile Send_private_message 
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 16:16    Post_subject: Network Samba  

ps command shows several services in usr/local/samba/sbin loaded.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Tue 18 Jan 2011, 16:23    Post_subject:  

The "ls" command is typed with an "ell".

When you type the "ps" command, you should see ten processes running, starting with nmbd and ending with smbd.

It sounds like the server is running. Go to a client machine and see if you can connect to it.
Back to top
View user's profile Send_private_message 
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 16:46    Post_subject: Samba network on Puppy  

Sorry, I used "is". Ls does show the content of the folder. The 10 programs are running on Puppy.

From the XP machine, Network Places does see the Puppy but there are no shared drives, so cannot log onto them.
Back to top
View user's profile Send_private_message 
gcmartin

Joined: 14 Oct 2005
Posts: 4355
Location: Earth

PostPosted: Tue 18 Jan 2011, 16:58    Post_subject: check your system for smb or smbd  

Couple of question where we might be better able to zero-in on your problem.
  • Which SAMBA did you install? (How did you get SAMBA on your system)
  • Which Puppy are you using? (Several recent Puppies changed fs structure and rules and it looks like you are using Puppy 5.2)
Should be snap to help you after this.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 17:14    Post_subject: Network Samba  

You are very kind.

I think Samba came with the the distro though I don't know what version. The Puppy is 5.2. How can I find the version of Samba?

Why isn't there a GUI for this?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Tue 18 Jan 2011, 17:16    Post_subject:  

Go back to the Samba-TNG tutorial and follow the instructions for making a desktop shortcut.

ie. Right click on the desktop - New - Shortcut - \\pupserver

Edited_time_total
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Tue 18 Jan 2011, 17:21    Post_subject: Re: Network Samba  

autumnleaves wrote:
I think Samba came with the distro though I don't know what version.

Quote:
I installed the two pets as per the instructions.

Now I'm confused as to what you are running.
Back to top
View user's profile Send_private_message 
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 18:22    Post_subject: More of Samba  

When I create the windows shortcut I am told that the file \\pupserver cannot be found.

I installed the two samba-tng pets as per the tutorial. However I do not know what was installed with the distro. You think you're confused...?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Tue 18 Jan 2011, 18:25    Post_subject:  

Do you have firewalls running on either your Puppy or Windows machine that might be blocking access to the server?
Back to top
View user's profile Send_private_message 
autumnleaves

Joined: 07 Jan 2011
Posts: 53

PostPosted: Tue 18 Jan 2011, 18:39    Post_subject: Network Samba  

Ahahh! After turning off firewalls I was able to connect to \\pupserver using root/woofwoof. Thank you.

Is it now possible to add other shared drives and remove the username/password requirement?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9200
Location: Stratford, Ontario

PostPosted: Tue 18 Jan 2011, 18:45    Post_subject: Re: Network Samba  

autumnleaves wrote:
Ahahh! After turning off firewalls I was able to connect to \\pupserver using root/woofwoof. Thank you.

Excellent!
Quote:
Is it now possible to add other shared drives and remove the username/password requirement?

That's what the tutorial is for. Wink
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0667s ][ Queries: 12 (0.0041s) ][ GZIP on ]