Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Sep 2014, 16:15
All times are UTC - 4
 Forum index » Off-Topic Area » Programming
ffmpeg record your desktop but how to stop? [Solved]
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [21 Posts]   Goto page: Previous 1, 2
Author Message
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Fri 31 Dec 2010, 12:00    Post subject:  

trapster wrote:
The one I have shows --enable-x11grab was configured. ?


Yes, but it apparently failed. Here's the ubunto config (used in lucid), which worked:
Code:

FFmpeg version 0.6-4:0.6-2ubuntu4, Copyright (c) 2000-2010 the FFmpeg developers
  built on Oct  5 2010 09:49:10 with gcc 4.4.5
  configuration: --extra-version=4:0.6-2ubuntu4 --prefix=/usr --enable-avfilter --enable-avfilter-lavf  --enable-vdpau --enable-bzlib --enablelibgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads-enable-zlib--enable-libvpx --disable-stripping --enable-runtime-cpudetectenable-gpl --enable-postproc --enable-x11grab --enablelibdc1394 --enable-shared --disable-static
 libavutil     50.15. 1 / 50.15. 1
  libavcodec    52.72. 2 / 52.72. 2
  libavformat   52.64. 2 / 52.64. 2
  libavdevice   52. 2. 0 / 52. 2. 0
  libavfilter    1.19. 0 /  1.19. 0
  libswscale     0.11. 0 /  0.11. 0
  libpostproc   51. 2. 0 / 51. 2. 0


edit: although it complains of a "library mismatch"; ffmpeg probably needs a fresh compile.
Back to top
View user's profile Send private message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Fri 31 Dec 2010, 14:41    Post subject: Re: ffmpeg record your desktop but how to stop? [Solved]  

TheAsterisk! wrote:
jpeps wrote:
works, but app is better run/stopped by clicking on icons so terminal doesn't appear in video.

I'd just as soon run the script with "xterm -e" in its *.desktop file, switch to another workspace, record my stuff, then switch back and halt/close it. You could trim away the few seconds of on-screen terminal time at the beginning and end with FFmpeg afterwards, too.

Well, to each his or her own, I suppose.


BTW/ "q" terminates ffmpeg


I did a fresh compile for Lucid-518:
http://murga-linux.com/puppy/viewtopic.php?p=482365#482365
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7802
Location: qld

PostPosted: Fri 31 Dec 2010, 21:03    Post subject:  

big_bass wrote:

Smile

this can be configured many ways and far from simple
if you want a full version

Joe


Thanks Joe, yes I should have qualified my statement Smile

let me say, compiles fairly easily with these options (btw, these are similar to shinobar's)
Code:
FFmpeg version SVN-r26159, Copyright (c) 2000-2010 the FFmpeg developers
  built on Dec 30 2010 09:43:50 with gcc 4.4.4
  configuration: --prefix=/usr --cpu=i686 --enable-libmp3lame --enable-libx264 --enable-libfaac --enable-pthreads --enable-small --enable-postproc --enable-libvorbis --enable-gpl --enable-shared --enable-nonfree --enable-libopencore-amrnb --enable-libopencore-amrwb --disable-debug --enable-bzlib --enable-zlib --enable-libspeex --enable-version3 --enable-runtime-cpudetect --enable-x11grab --enable-libdc1394 --enable-libschroedinger --enable-libtheora --enable-libxvid --enable-swscale --enable-libvpx


______________________________________________

jpeps, yes "q" is the command to quit ffmpeg! (and it works)

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
stu90


Joined: 25 Feb 2010
Posts: 1401
Location: England. Dell Inspiron 1501. Dpup

PostPosted: Sat 01 Jan 2011, 04:19    Post subject:  

I guess my laptop is lacking abit i the power department as i only get a low fps but using Lobsters script (changed output file to avi instead) and Jpegs ffmpeg .pet works here and the q key to stop.

Would be a nice feature to have built into the newer puppies. Wink
Back to top
View user's profile Send private message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 22 Jan 2011, 13:10    Post subject:  

stu90 wrote:
Use avidemux for trimming videos as you don't have to re-encode the video file.

There are options you can pass FFmpeg to simply copy the stream. Works fine for both audio and video. "-acodec copy" and "-vcodec copy" are involved somewhere, but as I have a poor memory I don't remember the syntax. A while ago I made a hacky little script to compensate for that, though.

If anyone is interested, I could post it for what it's worth.
Back to top
View user's profile Send private message Visit poster's website 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Sat 22 Jan 2011, 16:09    Post subject:  

Hey 01micko


Thanks for posting the config options that were used
that makes the difference when you try and compile the package easily Very Happy

*good to see you are on the slackware track again

Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [21 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Off-Topic Area » Programming
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0839s ][ Queries: 12 (0.0294s) ][ GZIP on ]