Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 12:46
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
PET für EMC2 gesucht
Moderators: MU
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Author Message
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Tue 18 Jan 2011, 18:45    Post_subject:  

Ich habe mir 431-de installiert und dann versucht emc zum Laufen zum bringen. Hat leider nicht geklappt, ich bekomme die gleiche Fehlermeldung. Allerdings ist das nicht die ganze Meldung, ein Stück weiter oben (nicht auf dem screenshot) gibt es einen Traceback error, das Module _tkinter kann nicht geladen werden.

Also steckts momentan bei python. Ich habe dann versucht das zu behoben, habe ich allerdings mit den vorhandenen Modulen nicht geschafft. Irgenwo gabs immer einen Versionskonflikt (emc möchte TCL8.5, TCL8.5 möchte eine neuere libc.so.6 Version als in Puppy 431 enthalten ist. Meine möglichen Auswege, "compile from scratch", oder neueres Puppy. Vielleicht gibts auch altere Binaries von emc, die sich mit TclTk 8.4 zufrieden geben.
Leider kann ich dir im Moment nicht weiterhelfen
emil
Back to top
View user's profile Send_private_message Visit_website 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Tue 18 Jan 2011, 19:07    Post_subject:  

ich habe mir 431-de installiert um dem Problem auf die Spur zu kommen, die traurige Wahrheit ist, ich habe emc auch nicht zum Laufen bekommen.

Ich bekomme die gleiche Fehlermeldung wie auf deinem Screenshot, aber ich denke die eigentliche Fehlermeldung ist nicht auf dem Foto drauf. Etwas weiter oben kommt ein python traceback error, das Modul _tkinter kann nicht geladen werden. Also ein python/tcltk/tkinter Problem.

Ich habs mit den verschiedenen debian Modulen versucht, aber die Versionen passen nicht. emc will tcl 8.5, und Tcl 8.5 ist mit der libc.so.6 in Puppy 431 nicht mehr zufrieden und will eine neuere. Ich habe ein wenig mit Symlinks gespielt, hat aber nicht funktioniert.

Ich weis keine Lösung als alles selbst zu kompilieren (das kann richtig schwierig werden) oder ein neueres Puppy zu verwenden. Wie gesagt, bei mir hats mit Lupq 511 fast auf Anhieb geklappt.

Tut mir leid Crying or Very sad
emil
Back to top
View user's profile Send_private_message Visit_website 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Wed 19 Jan 2011, 11:31    Post_subject:  

Hallo Emil,

ist ja auf der einen Seite gut, dass du es auch nicht zum Laufen bekommst. Dann bin ich wohl doch nicht so ungeschickt.

Es gab vor einiger Zeit ein ISO mit Puppy 1 oder 2 und EMC.
Dieses Iso habe ich gefunden. Könnte man daraus das EMC-System in das 4.3.1 übetragen?

Grüße Wolfgang

emil wrote:
ich habe mir 431-de installiert um dem Problem auf die Spur zu kommen, die traurige Wahrheit ist, ich habe emc auch nicht zum Laufen bekommen.

Ich bekomme die gleiche Fehlermeldung wie auf deinem Screenshot, aber ich denke die eigentliche Fehlermeldung ist nicht auf dem Foto drauf. Etwas weiter oben kommt ein python traceback error, das Modul _tkinter kann nicht geladen werden. Also ein python/tcltk/tkinter Problem.

Ich habs mit den verschiedenen debian Modulen versucht, aber die Versionen passen nicht. emc will tcl 8.5, und Tcl 8.5 ist mit der libc.so.6 in Puppy 431 nicht mehr zufrieden und will eine neuere. Ich habe ein wenig mit Symlinks gespielt, hat aber nicht funktioniert.

Ich weis keine Lösung als alles selbst zu kompilieren (das kann richtig schwierig werden) oder ein neueres Puppy zu verwenden. Wie gesagt, bei mir hats mit Lupq 511 fast auf Anhieb geklappt.

Tut mir leid Crying or Very sad
emil
Back to top
View user's profile Send_private_message 
deepsea

Joined: 17 Jan 2009
Posts: 154
Location: Deutschland

PostPosted: Wed 19 Jan 2011, 14:56    Post_subject:  

Moin
Emil und Schutzhund

Ich habe auch einiges Probiert (Quirky, Lucid 5.2, zpup )
Leider funktioniert Emils Pet bei mir auch nicht mit Lucid 5.2 Sad .

Nun habe ich erstmal folgende Verdächtige .

1. Kernel Version
(mit welcher bist du unterwegs Emil)
2. Graphik (X11)
(Version Xorg , DRI , GLOPEN )
3.C Libs wie Emil schon sagte
(Barry setzt auf das T2- Projekt .Ist das wirklich alles Kompatibel ?)

Daher meine Bitte an Emil
Bitte poste mal deine Software Versionen von
1 Kernel
2. Lupup (mit Erstelldatum)
3. Xorg mit Zusatz Modulen.
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Wed 19 Jan 2011, 15:56    Post_subject:  

Kernel Version: 2.6.33.2
DISTRO_KERNEL_PET='linux_kernel-2.6.33.2-tickless_smp_patched-L3.pet'
Xorg: 1.7.6
OpenGL 1.4 Mesa 7.7.1
libc-2.11.1.so

[gRant] Ich arbeite mit LupQ von Shinobar als Basis, das basiert auf 511, habe mich nach langem Überlegen dafür entschieden. Komme auch ganz gut zurecht damit. Aber ich habe leider festgestellt: 100% kompatibel sind 5.2 aund 5.11 leider nicht - sehr *sehr* ärgerlich.

Emc habe ich auf meinem Derivat sagelive gemacht. Habe schon befürchtet, dass das mit "schnell ein pet machen" nichts wird. Na ja.
Das eigentlich Problem ist ja, dass jetzt so viele Puppy Vaianten herumschwirren, dass sich jeder seine Software wieder selber zusammenbasteln muss damit es bei ihm läuft, deshalb bin ich auch etwas grantig. [/gRant]

Ich sehe die Sache so, wenn Wolfgang Emc auf 431 zum Laufen bringen will dann muss man realistischerweise noch mit einigen Stunden Tüftelei rechnen. Ich schau noch mal, dass es bei mir auf 511 läuft und dass da die Schritte und pets passen.

Na, ja. Wird schon werden, immer optimistisch sein Very Happy
Emil
Back to top
View user's profile Send_private_message Visit_website 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Wed 19 Jan 2011, 16:58    Post_subject:  

Hallo Emil,

vielen Dank für deinen Einsatz aber mach jetzt mal besser Schluß damit.
Dann läuft das EMC halt nicht mit 4.3.1.
Wäre schön gewesen aber wenn es sich mit vernünftigem Aufwand nicht realisieren lässt, dann halt nicht! Kein Problem!!

Aber die Sache mit den vielen verschiedenen Versionen ist genau das Problem. Hatte ich vor längerer Zeit schon mal angesprochen aber leider ohne große Wirkung!

Durch die Aufspaltung der Entwicklungsarbeit wird sinnlos Zeit und Energie verschwendet. Im Grunde ist das ein ganz klarer Rückschritt!
Jeder bastelt ein Wenig an seiner Version herum und ärgert sich, dass etwas nicht funktioniert, was in einer anderen Version läuft.
Das ist so, als wenn Microdoof gleichzeitig 100 verschiedene Betriebssysteme entwickeln würde.
Machen sie aber nicht ... sind ja nicht doof;-))
Sie setzen sich zusammen, legen fest was die neue Software können soll und dann wird systematisch daran gearbeitet.

Jetzt aber mal was Anderes:
Gibt es eine Möglichkeit die Temperatur des Prozessors zu senken?
So eine Art Pausefunktion, die man anklicken kann und dann die Belastung des Prozessors senkt, wenn man nicht die volle Leistung braucht.

Grüße Wolfgang

emil wrote:
Kernel Version: 2.6.33.2
DISTRO_KERNEL_PET='linux_kernel-2.6.33.2-tickless_smp_patched-L3.pet'
Xorg: 1.7.6
OpenGL 1.4 Mesa 7.7.1
libc-2.11.1.so

[gRant] Ich arbeite mit LupQ von Shinobar als Basis, das basiert auf 511, habe mich nach langem Überlegen dafür entschieden. Komme auch ganz gut zurecht damit. Aber ich habe leider festgestellt: 100% kompatibel sind 5.2 aund 5.11 leider nicht - sehr *sehr* ärgerlich.

Emc habe ich auf meinem Derivat sagelive gemacht. Habe schon befürchtet, dass das mit "schnell ein pet machen" nichts wird. Na ja.
Das eigentlich Problem ist ja, dass jetzt so viele Puppy Vaianten herumschwirren, dass sich jeder seine Software wieder selber zusammenbasteln muss damit es bei ihm läuft, deshalb bin ich auch etwas grantig. [/gRant]

Ich sehe die Sache so, wenn Wolfgang Emc auf 431 zum Laufen bringen will dann muss man realistischerweise noch mit einigen Stunden Tüftelei rechnen. Ich schau noch mal, dass es bei mir auf 511 läuft und dass da die Schritte und pets passen.

Na, ja. Wird schon werden, immer optimistisch sein Very Happy
Emil
Back to top
View user's profile Send_private_message 
deepsea

Joined: 17 Jan 2009
Posts: 154
Location: Deutschland

PostPosted: Sat 22 Jan 2011, 17:28    Post_subject:  

Moin
Emil und Wolfgang

So meine Test haben folgendes ergeben.

Ich habe alle Files von debian
und konnte ein Pet für Lucid 5.2 erstellen.
Das grösste Problem war wohl
"pidof -- x Option not ...."
Es funktioniert mit killall5 vom debian
(Der Link von pidof muss natürlich auf die neue killall5 zeigen
Das ist aber im Pet enthalten.)

Emil hat recht OPENGL ist wohl erforderlich.

Bei Puppy 431 musste Libc6 aktualisiert und
Python installiert werden, aber auch hier braucht mann OPENGL
"xorg_xorg_dri-7.3-1.pet".

Daher gibt es ein extra Pet
Es enthält die Addons für 4.31

Wenn noch jemand interressiert ist soll er sich hier Melden.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Sat 22 Jan 2011, 17:59    Post_subject:  

Hallo deepsea,

soll das heißen, du hast ein komplettes EMC-Pet für 4.31 fertig???

Wenn ja, dann her damit Very Happy

Viele Grüße

Wolfgang

deepsea wrote:
Moin
Emil und Wolfgang

So meine Test haben folgendes ergeben.

Ich habe alle Files von debian
und konnte ein Pet für Lucid 5.2 erstellen.
Das grösste Problem war wohl
"pidof -- x Option not ...."
Es funktioniert mit killall5 vom debian
(Der Link von pidof muss natürlich auf die neue killall5 zeigen
Das ist aber im Pet enthalten.)

Emil hat recht OPENGL ist wohl erforderlich.

Bei Puppy 431 musste Libc6 aktualisiert und
Python installiert werden, aber auch hier braucht mann OPENGL
"xorg_xorg_dri-7.3-1.pet".

Daher gibt es ein extra Pet
Es enthält die Addons für 4.31

Wenn noch jemand interressiert ist soll er sich hier Melden.
Back to top
View user's profile Send_private_message 
deepsea

Joined: 17 Jan 2009
Posts: 154
Location: Deutschland

PostPosted: Sat 22 Jan 2011, 18:15    Post_subject:  

Naja
Fertig ?

Aber bereit zum Testen

Zum Download müssen wir mal Opera Unite probieren


Und Bitte:
Teste es erst in einer frugal Installation oder erstelle eine Sicherung.

Edit 23.Jan 2011 06:38
Bei meiner schmalen Internet Verbindung und 8 Zugriffen gleichzeitig
ist das keine gute Wahl gewesen. Wink
Ich werde einen anderen Weg suchen und dann den Link hier Posten

Edited_time_total
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Sat 22 Jan 2011, 18:42    Post_subject:  

Den Download versuche ich morgen noch mal.
Die Downloadgeschw. ist aktuell nur 8KB/s Wink

Viele Grüße und erst mal eine gute Nacht;-))

Wolfgang

deepsea wrote:
Naja
Fertig ?

Aber bereit zum Testen

Zum Download müssen wir mal Opera Unite probieren

Bitte alle 3 Dateien downloaden

Und Bitte:
Teste es erst in einer frugal Installation oder erstelle eine Sicherung.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Sun 23 Jan 2011, 12:59    Post_subject:  

Hallo deepsea,

sieht sehr gut aus! Die Oberfläche läuft mit Standarteinstellungen. Läuft bei dir die Konfigurationsoberfläche (aus dem Menü heraus oder mit stepconf aus dem Terminal?
Damit kann man nämlich dann die ganzen Maschinenparameter einstellen.

Ich bekomme die folgende Fehlermeldung im Terminal:
--------------
/usr/bin/python: /lib/libz.so.1: no version information available (required by /usr/bin/python)
/usr/bin/python: /usr/lib/libcrypto.so.0.9.8: no version information available (required by /usr/bin/python)
/usr/bin/python: /usr/lib/libssl.so.0.9.8: no version information available (required by /usr/bin/python)
/usr/bin/stepconf:24: DeprecationWarning: the md5 module is deprecated; use hashlib instead
--------------

Viele Grüße

Wolfgang


deepsea wrote:
Naja

Fertig ?

Aber bereit zum Testen

Zum Download müssen wir mal Opera Unite probieren


Und Bitte:
Teste es erst in einer frugal Installation oder erstelle eine Sicherung.

Edit 23.Jan 2011 06:38
Bei meiner schmalen Internet Verbindung und 8 Zugriffen gleichzeitig
ist das keine gute Wahl gewesen. Wink
Ich werde einen anderen Weg suchen und dann den Link hier Posten
Back to top
View user's profile Send_private_message 
deepsea

Joined: 17 Jan 2009
Posts: 154
Location: Deutschland

PostPosted: Sun 23 Jan 2011, 16:58    Post_subject:  

Moin

Wolfgang

Hier die offiziellen Links:
1) Basis Paket für Lucid Puppy 5.2
emc2.pet
(Xorg High-GLX muss installiert sein.)
2) Zusätzliches Packet für puppy_431
emc2_431_extra_files.pet
(Auch hier muss OPENGL installiert sein.
Wenn nicht kann man es von hier xorg_xorg_dri-7.3-1.pet downloaden. )
Ein Danke an MU Laughing

Ps. Bitte editiere den Thraed und kopiere die Links in den ersten Eintrag.

Ach ja das Problem mit stepconf muss man sich mal ansehen.
Ist aber auch bei Lucid Puppy:
Code:
 /usr/bin/stepconf:24: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Traceback (most recent call last):
 File "/usr/bin/stepconf", line 32, in <module>
    import gobject
ImportError: No module named gobject

ImportError: No module named gobject ist wohl eher das Problem .
Ansonsten kanst du die Dateien von /usr/share/doc/emc/... doch auch mit einem Texteditor bearbeiten oder nicht ?
Back to top
View user's profile Send_private_message 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Mon 24 Jan 2011, 13:16    Post_subject:  

Hallo deepsea, Gratulation und Danke!
Ich habe im englischen Forumsbereich einen Link gesetzt
http://murga-linux.com/puppy/viewtopic.php?t=63973
als Dependencies habe ich:
Python
TclTK
Xorg High drivers angegeben - stimmt das so?
Back to top
View user's profile Send_private_message Visit_website 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Tue 25 Jan 2011, 12:53    Post_subject:  

Hallo deepsea,

vielen Dank für deinen Einsatz!!

Klar kann man die Parameter auch bestimmt über die Ini einstellen.

Könnte man eigentlich nun auch die Vollversion zum Laufen bringen?Wink

Also das *.deb mit deb2pet in ein pet umwandeln und installieren,
dann das Extrapet für 4.31 aufspielen?

Viele Grüße

Wolfgang

deepsea wrote:

Ansonsten kanst du die Dateien von /usr/share/doc/emc/... doch auch mit einem Texteditor bearbeiten oder nicht ?
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Thu 13 Oct 2011, 16:25    Post_subject:  

Hallo deepsea,

bin gerade dabei meine Physik-Technik-CD zusammen zu stellen und dabei ist mir ein merkwürdiger Effekt aufgefallen.
Ich verwende ja als Basis 431-de und da wird nach der Installation von EMC und dem nächsten Neustart plötzlich wieder das englische Menü angezeigt.
Das ist mir bei den Tests bisher gar nicht aufgefallen.
Ist allerdings reproduzierbar! Liegt es an der Änderung der lib6?
Es ist zwar schon eine kleine Weile, her aber vielleicht kannst du mir dazu noch was sagen.

Viele Grüße

Wolfgang

der-schutzhund wrote:
Hallo deepsea,

vielen Dank für deinen Einsatz!!

Klar kann man die Parameter auch bestimmt über die Ini einstellen.

Könnte man eigentlich nun auch die Vollversion zum Laufen bringen?Wink

Also das *.deb mit deb2pet in ein pet umwandeln und installieren,
dann das Extrapet für 4.31 aufspielen?

Viele Grüße

Wolfgang

deepsea wrote:

Ansonsten kanst du die Dateien von /usr/share/doc/emc/... doch auch mit einem Texteditor bearbeiten oder nicht ?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1077s ][ Queries: 13 (0.0139s) ][ GZIP on ]