Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 08:50
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Lupu_5.2 Acer Aspire 4745G can't connect to network [SOLVED]
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Pup Terrier

Joined: 24 Jan 2011
Posts: 2
Location: South Africa

PostPosted: Mon 24 Jan 2011, 03:39    Post_subject:  Lupu_5.2 Acer Aspire 4745G can't connect to network [SOLVED]
Sub_title: Solved by installing Atheros AR81 pet from link in this topic.
 

I have installed puppy 5.2 to boot from a 16GB Sandisk Blade Cruser Flash drive. I have set my ACER ASPIRE 4745G BIOS to boot from this flash drive (Ext3 partition). The installation went well except I cannot connect to the network and therefore internet.

This laptop has an Atheros AR8151 pci-e Gigabit Ethernet Controller.
Puppy 5.2 has the Atheros module installed called "atl1e" but when loaded it does not connect. I believe it needs updating to the latest and would appreciate some help to do that.

I went to the Atheros site, http://partner.atheros.com/Drivers.aspx
and downloaded the the current tar "AR81Family-linux-v1.0.1.14.tar.gz"
under the section "AR81Family Linux Driver".

I put the file at path: /lib/modules/2.6.33.2/kernel/drivers/pci/AR81Family/ then unpacked it. From within the AR81Family folder I tried to make install without success; messages like "make command does not exist" are returned.

I'm stuck and would appreciate a friendly prod in the right direction. How do I make and install the module correctly?

Edited_times_total
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 24 Jan 2011, 09:57    Post_subject:  

http://www.murga-linux.com/puppy/viewtopic.php?p=467845#467845
In that link is working pet for AR81 nic family.
Install the pet. Reboot. Your nic will probbably be autorecognized. The driver installed is atl1e.

For compiling kernel module drivers you need kernel source sfs and devx sfs spesific for your puppy.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Mon 24 Jan 2011, 10:47    Post_subject:  

Pemasu, I have atheros too. How do I know exactly which version?

I am in Snow puppy now and when I do Hardinfo hardware info then it says
AR8132 / L1c gigabit ethernet

but when I try out Dpup then it fail to use that one.

But your Snow and Fluppy and also Mijn Pup and others do just load and get going while in Dpup it totally fails.

Do you mean that of I Download or click on that link then these puppies will work too?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 24 Jan 2011, 11:35    Post_subject:  

Snow Puppy has 2.6.35.7 kernel and it has support for AR81 family nic cards.
Lucid puppies with 2.6.33.2 kernel needs this addon kernel module driver pet.
I dont know which dpup you are using. The kernel version of your dpup is the crucial information.
And this discussion goes a little bit off topic of the original question. Smile
Back to top
View user's profile Send_private_message 
Pup Terrier

Joined: 24 Jan 2011
Posts: 2
Location: South Africa

PostPosted: Mon 24 Jan 2011, 16:47    Post_subject:  

Thanks pemasu. You hit the nail right on the head!
I installed the pet from your link and my Atheros AR8151 ethernet controller is up and running.
(And the pet has the latest manufacturer's driver. Sweet!)
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 24 Jan 2011, 16:49    Post_subject:  

Thank you of the feedback. Add SOLVED to the end of the main header of the first post.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0499s ][ Queries: 12 (0.0060s) ][ GZIP on ]