Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Sep 2014, 14:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
puppy 5 compatibility
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Sun 23 Jan 2011, 18:04    Post subject:  puppy 5 compatibility
Subject description: make puppy 4 binary compatible with lupu/wary/quirky/etc
 

puppy 5 compatibility
make puppy 4 binary compatible with lupu/wary/quirky/etc

Screenshot

Consider this for testing only!
(Don't install when using a save file or full HD install)

This is a simple GUI which will download a .pet that updates your puppy 4 system, so that it becomes compatible with packages compiled for puppy 5.

This, in simpler terms, means you can install pets from Lupu, LupQ, Wary, Quirky and so on, into your Puppy 4.
(Also Ubuntu, Debian, Slackware, and whatever else your Puppy supports)

You can avoid the dreaded 'GLIBC 2.7' (etc) terminal errors produced by packages that are 'newer' than your puppy 4 system.

Here is some info on the puppy 5 compatibility update pet:

- contains: libc-2.22.1, libesd-0.2.41, libfaad-2.7-4, libglib-2.24.0, libselinux-2.0.89, libslang-2.2.2, libstc++-4.4.3, libx86-1.1
(from ubuntu, a few of these are unnecessary, I guess)

- you should change gobject symlink in /usr/lib from pointing at version 2400 to 1400 to fix firefox (and others I guess), but it breaks pprocess 2.2.2
(I did the same with other libs, to seemingly no effect)

- it needs to be updated a little bit, with a nice pinstall script, so any old symlinks are pointing at the new files, and old ones removed.

I will do this soon, but it works quite well as it is.. I can install Lupu pets which otherwise dont work.

HOWEVER!!

It does seem to break something in GTK-Dialog and GTK+ (which are used by many apps to produce menus, etc), especially with locales, so you will be stuck with english menus, etc, but puppy 4 has very little localisation anyway...

(After installing this you will always get a gtk error in the terminal which says 'Locale XXX not found, falling back to 'C'.. Not critical, but means no localisation, as I said)
puppy-5-compatibility.pet
Description 
pet

 Download 
Filename  puppy-5-compatibility.pet 
Filesize  1.29 KB 
Downloaded  504 Time(s) 

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search

Last edited by sc0ttman on Tue 25 Jan 2011, 16:23; edited 1 time in total
Back to top
View user's profile Send private message 
tengzelius

Joined: 15 Oct 2010
Posts: 11

PostPosted: Mon 24 Jan 2011, 21:04    Post subject: puppy 5 Updater 0.1
Subject description: Makes puppy 4 binary compatible with lupu/wary/quirky/etc
 

Search of Google & your web site yielded no download hyperlink to ap site. Please furnish one. Here is a puppy work around when using opera.sfs--find /usr/local/bin/defaultbrowser & change text within to reflect opera.

Great web site.

Lou
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Tue 25 Jan 2011, 03:40    Post subject:  

Don't you think you should upgrade GTK too?
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Tue 25 Jan 2011, 16:21    Post subject:  

disciple wrote:
Don't you think you should upgrade GTK too?

Yes I do!

Every time I tried, X crashed, and wouldn't even restart.
And I couldn't check any errors in the command line prompt, it kept spitting the same errors
(can't remember which....I have to do it again and see... )

Any help on it would be great, although I appreciate if no one is interested in this...
Just thought I'd share..

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2376
Location: UK

PostPosted: Tue 25 Jan 2011, 16:24    Post subject: Re: puppy 5 Updater 0.1
Subject description: Makes puppy 4 binary compatible with lupu/wary/quirky/etc
 

tengzelius wrote:
Search of Google & your web site yielded no download hyperlink to ap site. Please furnish one. Here is a puppy work around when using opera.sfs--find /usr/local/bin/defaultbrowser & change text within to reflect opera.

Great web site.

Lou

God I'm soooo thick... I forgot to attach the pet file.

Now attached in the main post..

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Wed 26 Jan 2011, 04:51    Post subject:  

sc0ttman wrote:
disciple wrote:
Don't you think you should upgrade GTK too?

Yes I do!

Every time I tried, X crashed, and wouldn't even restart.
And I couldn't check any errors in the command line prompt, it kept spitting the same errors
(can't remember which....I have to do it again and see... )

Any help on it would be great, although I appreciate if no one is interested in this...
Just thought I'd share..

I've used packages from the forum with no problem, although I've never upgraded to a really recent version. The order in which you install gtk, gdk and any dependencies probably matters.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0598s ][ Queries: 13 (0.0080s) ][ GZIP on ]